diff mbox series

[meta-python,PATCHv2] python3-google-auth-oauthlib: add recipe

Message ID 20240201174020.94018-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-python,PATCHv2] python3-google-auth-oauthlib: add recipe | expand

Commit Message

Alper Ak Feb. 1, 2024, 5:40 p.m. UTC
This library is part of the Google Auth Library and simplifies the authentication and authorization processes by utilizing the OAuth protocol.

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../python/python3-google-auth-oauthlib_1.2.0.bb   | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-google-auth-oauthlib_1.2.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-google-auth-oauthlib_1.2.0.bb b/meta-python/recipes-devtools/python/python3-google-auth-oauthlib_1.2.0.bb
new file mode 100644
index 000000000..b1e89e4b4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-google-auth-oauthlib_1.2.0.bb
@@ -0,0 +1,14 @@ 
+SUMMARY = "Google Authentication Library"
+DESCRIPTION = "This library provides oauthlib integration with google-auth"
+HOMEPAGE = "https://github.com/googleapis/google-auth-library-python-oauthlib"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI[sha256sum] = "292d2d3783349f2b0734a0a0207b1e1e322ac193c2c09d8f7c613fb7cc501ea8"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} = " \
+    ${PYTHON_PN}-google-auth \
+    ${PYTHON_PN}-requests-oauthlib \
+"