diff mbox series

[meta-python] python3-google-auth-oauthlib: add recipe

Message ID 20240131074948.18462-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-python] python3-google-auth-oauthlib: add recipe | expand

Commit Message

Alper Ak Jan. 31, 2024, 7:49 a.m. UTC
Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../python/python3-google-auth-oauthlib_1.2.0.bb   | 14 ++++++++++++++
 1 file changed, 14 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-google-auth-oauthlib_1.2.0.bb

Comments

Trevor Gamblin Jan. 31, 2024, 8:36 p.m. UTC | #1
On 2024-01-31 02:49, Alper Ak wrote:
> Signed-off-by: alperak <alperyasinak1@gmail.com>
I know that the recipe name is fairly self-explanatory, but you should 
submit new recipes like this with a short commit message describing what 
the recipe does and why it'd be useful to have in the layer.
> ---
>   .../python/python3-google-auth-oauthlib_1.2.0.bb   | 14 ++++++++++++++
>   1 file changed, 14 insertions(+)
>   create mode 100644 meta-python/recipes-devtools/python/python3-google-auth-oauthlib_1.2.0.bb
>
> diff --git a/meta-python/recipes-devtools/python/python3-google-auth-oauthlib_1.2.0.bb b/meta-python/recipes-devtools/python/python3-google-auth-oauthlib_1.2.0.bb
> new file mode 100644
> index 000000000..b1e89e4b4
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/python3-google-auth-oauthlib_1.2.0.bb
> @@ -0,0 +1,14 @@
> +SUMMARY = "Google Authentication Library"
> +DESCRIPTION = "This library provides oauthlib integration with google-auth"
> +HOMEPAGE = "https://github.com/googleapis/google-auth-library-python-oauthlib"
> +LICENSE = "Apache-2.0"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
> +
> +SRC_URI[sha256sum] = "292d2d3783349f2b0734a0a0207b1e1e322ac193c2c09d8f7c613fb7cc501ea8"
> +
> +inherit pypi setuptools3
> +
> +RDEPENDS:${PN} = " \
> +    ${PYTHON_PN}-google-auth \
> +    ${PYTHON_PN}-requests-oauthlib \
> +"
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#108505): https://lists.openembedded.org/g/openembedded-devel/message/108505
> Mute This Topic: https://lists.openembedded.org/mt/104071227/7611679
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [tgamblin@baylibre.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Alper Ak Feb. 1, 2024, 5:36 a.m. UTC | #2
Thanks for feedback. I will be more careful.

Trevor Gamblin <tgamblin@baylibre.com>, 31 Oca 2024 Çar, 23:36 tarihinde
şunu yazdı:

>
> On 2024-01-31 02:49, Alper Ak wrote:
> > Signed-off-by: alperak <alperyasinak1@gmail.com>
> I know that the recipe name is fairly self-explanatory, but you should
> submit new recipes like this with a short commit message describing what
> the recipe does and why it'd be useful to have in the layer.
> > ---
> >   .../python/python3-google-auth-oauthlib_1.2.0.bb   | 14 ++++++++++++++
> >   1 file changed, 14 insertions(+)
> >   create mode 100644 meta-python/recipes-devtools/python/
> python3-google-auth-oauthlib_1.2.0.bb
> >
> > diff --git a/meta-python/recipes-devtools/python/
> python3-google-auth-oauthlib_1.2.0.bb
> b/meta-python/recipes-devtools/python/
> python3-google-auth-oauthlib_1.2.0.bb
> > new file mode 100644
> > index 000000000..b1e89e4b4
> > --- /dev/null
> > +++ b/meta-python/recipes-devtools/python/
> python3-google-auth-oauthlib_1.2.0.bb
> > @@ -0,0 +1,14 @@
> > +SUMMARY = "Google Authentication Library"
> > +DESCRIPTION = "This library provides oauthlib integration with
> google-auth"
> > +HOMEPAGE = "
> https://github.com/googleapis/google-auth-library-python-oauthlib"
> > +LICENSE = "Apache-2.0"
> > +LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
> > +
> > +SRC_URI[sha256sum] =
> "292d2d3783349f2b0734a0a0207b1e1e322ac193c2c09d8f7c613fb7cc501ea8"
> > +
> > +inherit pypi setuptools3
> > +
> > +RDEPENDS:${PN} = " \
> > +    ${PYTHON_PN}-google-auth \
> > +    ${PYTHON_PN}-requests-oauthlib \
> > +"
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#108505):
> https://lists.openembedded.org/g/openembedded-devel/message/108505
> > Mute This Topic: https://lists.openembedded.org/mt/104071227/7611679
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> tgamblin@baylibre.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
>
Khem Raj Feb. 1, 2024, 4:18 p.m. UTC | #3
On Wed, Jan 31, 2024 at 9:36 PM Alper Ak <alperyasinak1@gmail.com> wrote:
>
> Thanks for feedback. I will be more careful.
>

Please send a v2 of this patch addressing the review feedback. I have
dropped it from master-next.

> Trevor Gamblin <tgamblin@baylibre.com>, 31 Oca 2024 Çar, 23:36 tarihinde şunu yazdı:
>>
>>
>> On 2024-01-31 02:49, Alper Ak wrote:
>> > Signed-off-by: alperak <alperyasinak1@gmail.com>
>> I know that the recipe name is fairly self-explanatory, but you should
>> submit new recipes like this with a short commit message describing what
>> the recipe does and why it'd be useful to have in the layer.
>> > ---
>> >   .../python/python3-google-auth-oauthlib_1.2.0.bb   | 14 ++++++++++++++
>> >   1 file changed, 14 insertions(+)
>> >   create mode 100644 meta-python/recipes-devtools/python/python3-google-auth-oauthlib_1.2.0.bb
>> >
>> > diff --git a/meta-python/recipes-devtools/python/python3-google-auth-oauthlib_1.2.0.bb b/meta-python/recipes-devtools/python/python3-google-auth-oauthlib_1.2.0.bb
>> > new file mode 100644
>> > index 000000000..b1e89e4b4
>> > --- /dev/null
>> > +++ b/meta-python/recipes-devtools/python/python3-google-auth-oauthlib_1.2.0.bb
>> > @@ -0,0 +1,14 @@
>> > +SUMMARY = "Google Authentication Library"
>> > +DESCRIPTION = "This library provides oauthlib integration with google-auth"
>> > +HOMEPAGE = "https://github.com/googleapis/google-auth-library-python-oauthlib"
>> > +LICENSE = "Apache-2.0"
>> > +LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
>> > +
>> > +SRC_URI[sha256sum] = "292d2d3783349f2b0734a0a0207b1e1e322ac193c2c09d8f7c613fb7cc501ea8"
>> > +
>> > +inherit pypi setuptools3
>> > +
>> > +RDEPENDS:${PN} = " \
>> > +    ${PYTHON_PN}-google-auth \
>> > +    ${PYTHON_PN}-requests-oauthlib \
>> > +"
>> >
>> >
>> >
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#108513): https://lists.openembedded.org/g/openembedded-devel/message/108513
> Mute This Topic: https://lists.openembedded.org/mt/104071227/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-google-auth-oauthlib_1.2.0.bb b/meta-python/recipes-devtools/python/python3-google-auth-oauthlib_1.2.0.bb
new file mode 100644
index 000000000..b1e89e4b4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-google-auth-oauthlib_1.2.0.bb
@@ -0,0 +1,14 @@ 
+SUMMARY = "Google Authentication Library"
+DESCRIPTION = "This library provides oauthlib integration with google-auth"
+HOMEPAGE = "https://github.com/googleapis/google-auth-library-python-oauthlib"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI[sha256sum] = "292d2d3783349f2b0734a0a0207b1e1e322ac193c2c09d8f7c613fb7cc501ea8"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} = " \
+    ${PYTHON_PN}-google-auth \
+    ${PYTHON_PN}-requests-oauthlib \
+"