diff mbox series

[meta-python,v2] python3-janus: add recipe for v1.0.0

Message ID 20240130210734.493630-1-dev@g0hl1n.net
State Accepted
Headers show
Series [meta-python,v2] python3-janus: add recipe for v1.0.0 | expand

Commit Message

Richard Leitner Jan. 30, 2024, 9:07 p.m. UTC
janus is a python library providing a mixed sync-async queue to
interoperate between asyncio tasks and classic threads. This recipe uses
pypi as source:

	https://pypi.org/project/janus/

Signed-off-by: Richard Leitner <dev@g0hl1n.net>
---
 .../python/python3-janus_1.0.0.bb                 | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-janus_1.0.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-janus_1.0.0.bb b/meta-python/recipes-devtools/python/python3-janus_1.0.0.bb
new file mode 100644
index 000000000..c709bcfbf
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-janus_1.0.0.bb
@@ -0,0 +1,15 @@ 
+SUMMARY = "Mixed sync-async queue to interoperate between asyncio tasks and classic threads"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=23878c357ebb4c8ce1109be365043349"
+
+SRC_URI[sha256sum] = "df976f2cdcfb034b147a2d51edfc34ff6bfb12d4e2643d3ad0e10de058cb1612"
+
+inherit pypi python_setuptools_build_meta
+
+RDEPENDS:${PN} += "\
+    python3-asyncio \
+    python3-threading \
+"
+
+BBCLASSEXTEND = "native nativesdk"