diff mbox series

[meta-oe] flatcc: Add tool recipe

Message ID 20240129163418.143102-1-Angelo.Ribeiro@criticaltechworks.com
State Accepted
Headers show
Series [meta-oe] flatcc: Add tool recipe | expand

Commit Message

Angelo.Ribeiro Jan. 29, 2024, 4:34 p.m. UTC
Add FlatCC FlatBuffers in C for C.
FlatCC is a compiler that generates FlatBuffers code for C given a
FlatBuffer schema file.

Signed-off-by: Angelo Ribeiro <Angelo.Ribeiro@criticaltechworks.com>
---
 meta-oe/recipes-devtools/flatcc/flatcc_git.bb | 27 +++++++++++++++++++
 1 file changed, 27 insertions(+)
 create mode 100644 meta-oe/recipes-devtools/flatcc/flatcc_git.bb

--
2.34.1

The information in this communication may contain confidential or legally privileged information. It is intended solely for the use of the individual or entity it addresses and others authorized to receive it. If you are not an intended recipient, you are hereby notified that any disclosure, copying, distribution or action in reliance on the contents of this information is strictly prohibited and may be unlawful. If you have received this communication by error, please notify us immediately by responding to this e-mail and then delete it from your system. Critical TechWorks is not liable for the proper and complete transmission of the information in this communication nor for any delay in its receipt

This e-mail is environmentally friendly, just like Critical TechWorks, which lives in a paper-free atmosphere. Therefore, please consider the environment before printing it!
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/flatcc/flatcc_git.bb b/meta-oe/recipes-devtools/flatcc/flatcc_git.bb
new file mode 100644
index 000000000..660a44c5a
--- /dev/null
+++ b/meta-oe/recipes-devtools/flatcc/flatcc_git.bb
@@ -0,0 +1,27 @@ 
+SUMMARY = "FlatCC FlatBuffers in C for C"
+DESCRIPTION = "FlatCC is a compiler that generates FlatBuffers code for C \
+given a FlatBuffer schema file."
+HOMEPAGE = "https://github.com/dvidelabs/flatcc"
+SECTION = "devel/lib"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=b3d8fb7158bf7e2600ba3191428dc4ef"
+
+PV = "0.6.2+gitr${SRCPV}"
+
+SRC_URI = " \
+           git://github.com/dvidelabs/flatcc.git;protocol=https;branch=master \
+"
+SRCREV = "1653ec964730ec7d9892a08a1695ada6d20f5196"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+# Enable installation for target
+# Disable tests as is not possible to execute with cross-compilation
+EXTRA_OECMAKE += " \
+    -DFLATCC_INSTALL=On \
+    -DFLATCC_TEST=Off \
+"
+
+BBCLASSEXTEND = "native nativesdk"