diff mbox series

[meta-filesystems] e2tools: Add tool recipe

Message ID 20240126102409.215142-2-Angelo.Ribeiro@criticaltechworks.com
State Superseded
Headers show
Series [meta-filesystems] e2tools: Add tool recipe | expand

Commit Message

Angelo.Ribeiro Jan. 26, 2024, 10:24 a.m. UTC
e2tools is a simple set of GPL'ed utilities to read, write, and manipulate
files in an ext2/ext3 filesystem.
These utilities access a filesystem directly using the ext2fs library.

Signed-off-by: Angelo.Ribeiro <Angelo.Ribeiro@criticaltechworks.com>
---
 .../recipes-utils/e2tools/e2tools_git.bb      | 25 +++++++++++++++++++
 1 file changed, 25 insertions(+)
 create mode 100644 meta-filesystems/recipes-utils/e2tools/e2tools_git.bb

--
2.34.1

The information in this communication may contain confidential or legally privileged information. It is intended solely for the use of the individual or entity it addresses and others authorized to receive it. If you are not an intended recipient, you are hereby notified that any disclosure, copying, distribution or action in reliance on the contents of this information is strictly prohibited and may be unlawful. If you have received this communication by error, please notify us immediately by responding to this e-mail and then delete it from your system. Critical TechWorks is not liable for the proper and complete transmission of the information in this communication nor for any delay in its receipt

This e-mail is environmentally friendly, just like Critical TechWorks, which lives in a paper-free atmosphere. Therefore, please consider the environment before printing it!

Comments

Khem Raj Jan. 26, 2024, 5:23 p.m. UTC | #1
Thanks for your contribution Angelo

On Fri, Jan 26, 2024 at 2:24 AM Angelo Ribeiro via
lists.openembedded.org
<Angelo.Ribeiro=criticaltechworks.com@lists.openembedded.org> wrote:
>
> e2tools is a simple set of GPL'ed utilities to read, write, and manipulate
> files in an ext2/ext3 filesystem.
> These utilities access a filesystem directly using the ext2fs library.
>
> Signed-off-by: Angelo.Ribeiro <Angelo.Ribeiro@criticaltechworks.com>
> ---
>  .../recipes-utils/e2tools/e2tools_git.bb      | 25 +++++++++++++++++++
>  1 file changed, 25 insertions(+)
>  create mode 100644 meta-filesystems/recipes-utils/e2tools/e2tools_git.bb
>
> diff --git a/meta-filesystems/recipes-utils/e2tools/e2tools_git.bb b/meta-filesystems/recipes-utils/e2tools/e2tools_git.bb
> new file mode 100644
> index 000000000..d8492bf8d
> --- /dev/null
> +++ b/meta-filesystems/recipes-utils/e2tools/e2tools_git.bb
> @@ -0,0 +1,25 @@
> +SUMMARY = "Set of GPL'ed utilities to ext2/ext3 filesystem."
> +DESCRIPTION = "e2tools is a simple set of GPL'ed utilities to read, write, \
> +and manipulate files in an ext2/ext3 filesystem. These utilities access a \
> +filesystem directly using the ext2fs library. Can also be used on a Linux \
> +machine to read/write to disk images or floppies without having to mount \
> +them or have root access."
> +HOMEPAGE = "https://github.com/e2tools/e2tools"
> +SECTION = "base"
> +LICENSE = "GPL-2.0-only"
> +LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
> +
> +DEPENDS += "e2fsprogs"
> +
> +PV = "0.1.0+gitr${SRCPV}"

I think SRCPV can be dropped here these days. PV = "0.1.0+git" would suffice.

> +
> +SRC_URI = " \
> +           git://github.com/e2tools/e2tools;protocol=https;branch=master \
> +"
> +SRCREV = "fd092754a6b65c3a769f74f888668c066f09c36d"
> +
> +S = "${WORKDIR}/git"
> +
> +inherit autotools pkgconfig
> +
> +BBCLASSEXTEND = "native"
> --
> 2.34.1
>
> The information in this communication may contain confidential or legally privileged information. It is intended solely for the use of the individual or entity it addresses and others authorized to receive it. If you are not an intended recipient, you are hereby notified that any disclosure, copying, distribution or action in reliance on the contents of this information is strictly prohibited and may be unlawful. If you have received this communication by error, please notify us immediately by responding to this e-mail and then delete it from your system. Critical TechWorks is not liable for the proper and complete transmission of the information in this communication nor for any delay in its receipt
>
> This e-mail is environmentally friendly, just like Critical TechWorks, which lives in a paper-free atmosphere. Therefore, please consider the environment before printing it!
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#108460): https://lists.openembedded.org/g/openembedded-devel/message/108460
> Mute This Topic: https://lists.openembedded.org/mt/103973659/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-filesystems/recipes-utils/e2tools/e2tools_git.bb b/meta-filesystems/recipes-utils/e2tools/e2tools_git.bb
new file mode 100644
index 000000000..d8492bf8d
--- /dev/null
+++ b/meta-filesystems/recipes-utils/e2tools/e2tools_git.bb
@@ -0,0 +1,25 @@ 
+SUMMARY = "Set of GPL'ed utilities to ext2/ext3 filesystem."
+DESCRIPTION = "e2tools is a simple set of GPL'ed utilities to read, write, \
+and manipulate files in an ext2/ext3 filesystem. These utilities access a \
+filesystem directly using the ext2fs library. Can also be used on a Linux \
+machine to read/write to disk images or floppies without having to mount \
+them or have root access."
+HOMEPAGE = "https://github.com/e2tools/e2tools"
+SECTION = "base"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS += "e2fsprogs"
+
+PV = "0.1.0+gitr${SRCPV}"
+
+SRC_URI = " \
+           git://github.com/e2tools/e2tools;protocol=https;branch=master \
+"
+SRCREV = "fd092754a6b65c3a769f74f888668c066f09c36d"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig
+
+BBCLASSEXTEND = "native"