diff mbox series

[meta-python] python3-flask-marshmallow: upgrade 0.15.0 -> 1.1.0

Message ID 20240125112620.91634-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-python] python3-flask-marshmallow: upgrade 0.15.0 -> 1.1.0 | expand

Commit Message

Alper Ak Jan. 25, 2024, 11:26 a.m. UTC
* Upstream provides a pyproject.toml which declares the "python_setuptools_build_meta" backend for PEP-517 packaging.

	use python_setuptools_build_meta since normal setuptools3 bbclass ends up in error -> ERROR: 'python3 setup.py bdist_wheel ' execution failed.

* Set PYPI_PACKAGE to "flask_marshmallow" because when downloading the archive error pops up. they use "_" instead of "-".

* Dependencies defined ["Flask>=2.2", "marshmallow>=3.0.0"] in pyproject.toml so "python3-packaging" removed.

License-Update: Copyright years change

Changelog:
=================================
1.1.0 (2024-01-16)

Features:

    Add type coverage (:pr:`290`).

==================================
1.0.0 (2024-01-16)

Features:

    Add field fields.File, validate.FileType, and validate.FileSize for deserializing uploaded files (:issue:`280`, :pr:`282`). Thanks :user:`uncle-lv` for the PR
    Add field Config for serializing Flask configuration values (:issue:`280`, :pr:`281`). Thanks :user:`greyli` for the PR.

Support:

    Support marshmallow-sqlalchemy>=0.29.0.
    Test against Python 3.12.
    Drop support for Python 3.7.

Other changes:

    Backwards-incompatible: Remove `flask_marshmallow.__version__ and flask_marshmallow.__version_info__ attributes (:pr:`284`). Use feature detection or importlib.metadata.version("flask-marshmallow") instead.

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../python/python3-flask-marshmallow_0.15.0.bb    | 14 --------------
 .../python/python3-flask-marshmallow_1.1.0.bb     | 15 +++++++++++++++
 2 files changed, 15 insertions(+), 14 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-flask-marshmallow_0.15.0.bb
 create mode 100644 meta-python/recipes-devtools/python/python3-flask-marshmallow_1.1.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-flask-marshmallow_0.15.0.bb b/meta-python/recipes-devtools/python/python3-flask-marshmallow_0.15.0.bb
deleted file mode 100644
index 25ca4d24c..000000000
--- a/meta-python/recipes-devtools/python/python3-flask-marshmallow_0.15.0.bb
+++ /dev/null
@@ -1,14 +0,0 @@ 
-SUMMARY = "Flask + marshmallow for beautiful APIs"
-HOMEPAGE = "https://github.com/marshmallow-code/flask-marshmallow"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=c3ff8567ef1f2a8cf223f30ac5a6f094"
-
-inherit pypi setuptools3
-
-SRC_URI[sha256sum] = "2083ae55bebb5142fff98c6bbd483a2f5dbc531a8bc1be2180ed5f75e7f3fccc"
-
-RDEPENDS:${PN} += "\
-    python3-flask \
-    python3-marshmallow \
-    python3-packaging \
-    "
diff --git a/meta-python/recipes-devtools/python/python3-flask-marshmallow_1.1.0.bb b/meta-python/recipes-devtools/python/python3-flask-marshmallow_1.1.0.bb
new file mode 100644
index 000000000..15fb22900
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flask-marshmallow_1.1.0.bb
@@ -0,0 +1,15 @@ 
+SUMMARY = "Flask + marshmallow for beautiful APIs"
+HOMEPAGE = "https://github.com/marshmallow-code/flask-marshmallow"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=dfbd4ae0074716275fc229c775723e8f"
+
+inherit pypi python_setuptools_build_meta
+
+PYPI_PACKAGE = "flask_marshmallow"
+
+SRC_URI[sha256sum] = "2d186af7c8b4455b8a2c166c7470939c17d70353671ea5a287a14676846fa013"
+
+RDEPENDS:${PN} += "\
+    python3-flask \
+    python3-marshmallow \
+    "