diff mbox series

[meta-python] python3-janus: add recipe for v1.0.0

Message ID 20240123233625.38469-1-dev@g0hl1n.net
State Superseded
Headers show
Series [meta-python] python3-janus: add recipe for v1.0.0 | expand

Commit Message

Richard Leitner Jan. 23, 2024, 11:36 p.m. UTC
janus is a python library providing a mixed sync-async queue to
interoperate between asyncio tasks and classic threads. This recipe uses
pypi as source:

	https://pypi.org/project/janus/

Signed-off-by: Richard Leitner <dev@g0hl1n.net>
---
 .../python/python3-janus_1.0.0.bb                 | 15 +++++++++++++++
 1 file changed, 15 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-janus_1.0.0.bb

Comments

Tim Orling Jan. 23, 2024, 11:41 p.m. UTC | #1
On Tue, Jan 23, 2024 at 3:36 PM Richard Leitner via lists.openembedded.org
<dev=g0hl1n.net@lists.openembedded.org> wrote:

> janus is a python library providing a mixed sync-async queue to
> interoperate between asyncio tasks and classic threads. This recipe uses
> pypi as source:
>
>         https://pypi.org/project/janus/
>
> Signed-off-by: Richard Leitner <dev@g0hl1n.net>
> ---
>  .../python/python3-janus_1.0.0.bb                 | 15 +++++++++++++++
>  1 file changed, 15 insertions(+)
>  create mode 100644 meta-python/recipes-devtools/python/
> python3-janus_1.0.0.bb
>
> diff --git a/meta-python/recipes-devtools/python/python3-janus_1.0.0.bb
> b/meta-python/recipes-devtools/python/python3-janus_1.0.0.bb
> new file mode 100644
> index 000000000..be1f284d8
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/python3-janus_1.0.0.bb
> @@ -0,0 +1,15 @@
> +SUMMARY = "Mixed sync-async queue to interoperate between asyncio tasks
> and classic threads"
> +SECTION = "devel/python"
> +LICENSE = "Apache-2.0"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=23878c357ebb4c8ce1109be365043349"
> +
> +SRC_URI[sha256sum] =
> "df976f2cdcfb034b147a2d51edfc34ff6bfb12d4e2643d3ad0e10de058cb1612"
> +
> +inherit pypi setuptools3
>
inherit python_setuptools_build_meta
https://github.com/aio-libs/janus/blob/master/pyproject.toml#L3

> +
> +RDEPENDS:${PN} += "\
> +    python3-asyncio \
> +    python3-threading \
> +"
> +
> +BBCLASSEXTEND = "native nativesdk"
> --
> 2.40.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#108441):
> https://lists.openembedded.org/g/openembedded-devel/message/108441
> Mute This Topic: https://lists.openembedded.org/mt/103921995/924729
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Richard Leitner Jan. 30, 2024, 8:34 p.m. UTC | #2
On Tue, Jan 23, 2024 at 03:41:15PM -0800, Tim Orling wrote:
> On Tue, Jan 23, 2024 at 3:36 PM Richard Leitner via lists.openembedded.org
> <dev=g0hl1n.net@lists.openembedded.org> wrote:
> 
> > janus is a python library providing a mixed sync-async queue to
> > interoperate between asyncio tasks and classic threads. This recipe uses
> > pypi as source:
> >
> >         https://pypi.org/project/janus/
> >
> > Signed-off-by: Richard Leitner <dev@g0hl1n.net>
> > ---
> >  .../python/python3-janus_1.0.0.bb                 | 15 +++++++++++++++
> >  1 file changed, 15 insertions(+)
> >  create mode 100644 meta-python/recipes-devtools/python/
> > python3-janus_1.0.0.bb
> >
> > diff --git a/meta-python/recipes-devtools/python/python3-janus_1.0.0.bb
> > b/meta-python/recipes-devtools/python/python3-janus_1.0.0.bb
> > new file mode 100644
> > index 000000000..be1f284d8
> > --- /dev/null
> > +++ b/meta-python/recipes-devtools/python/python3-janus_1.0.0.bb
> > @@ -0,0 +1,15 @@
> > +SUMMARY = "Mixed sync-async queue to interoperate between asyncio tasks
> > and classic threads"
> > +SECTION = "devel/python"
> > +LICENSE = "Apache-2.0"
> > +LIC_FILES_CHKSUM = "file://LICENSE;md5=23878c357ebb4c8ce1109be365043349"
> > +
> > +SRC_URI[sha256sum] =
> > "df976f2cdcfb034b147a2d51edfc34ff6bfb12d4e2643d3ad0e10de058cb1612"
> > +
> > +inherit pypi setuptools3
> >
> inherit python_setuptools_build_meta
> https://github.com/aio-libs/janus/blob/master/pyproject.toml#L3

Thanks for the pointer! v2 will go out soon.

regards;rl
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-janus_1.0.0.bb b/meta-python/recipes-devtools/python/python3-janus_1.0.0.bb
new file mode 100644
index 000000000..be1f284d8
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-janus_1.0.0.bb
@@ -0,0 +1,15 @@ 
+SUMMARY = "Mixed sync-async queue to interoperate between asyncio tasks and classic threads"
+SECTION = "devel/python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=23878c357ebb4c8ce1109be365043349"
+
+SRC_URI[sha256sum] = "df976f2cdcfb034b147a2d51edfc34ff6bfb12d4e2643d3ad0e10de058cb1612"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+    python3-asyncio \
+    python3-threading \
+"
+
+BBCLASSEXTEND = "native nativesdk"