diff mbox series

[meta-oe] flatpak: fix gtk-doc build

Message ID 20240112130825.940790-1-f_l_k@t-online.de
State Accepted
Headers show
Series [meta-oe] flatpak: fix gtk-doc build | expand

Commit Message

Markus Volk Jan. 12, 2024, 1:08 p.m. UTC
this fixes:
| Run-time dependency gtk-doc found: NO (tried pkgconfig)
|
| ../git/meson.build:206:13: ERROR: Dependency "gtk-doc" not found, tried pkgconfig

Signed-off-by: Markus Volk <f_l_k@t-online.de>
---
 ...01-meson.build-require-native-gtkdoc.patch | 33 +++++++++++++++++++
 .../flatpak/flatpak_1.15.6.bb                 |  1 +
 2 files changed, 34 insertions(+)
 create mode 100644 meta-oe/recipes-extended/flatpak/flatpak/0001-meson.build-require-native-gtkdoc.patch

Comments

Ross Burton Jan. 12, 2024, 2:23 p.m. UTC | #1
On 12 Jan 2024, at 13:08, Markus Volk via lists.openembedded.org <f_l_k=t-online.de@lists.openembedded.org> wrote:
> 
> this fixes:
> | Run-time dependency gtk-doc found: NO (tried pkgconfig)
> |
> | ../git/meson.build:206:13: ERROR: Dependency "gtk-doc" not found, tried pkgconfig

Hm, before I posted my gtk-doc changes I built everything in meta-oe that inherited gtk-doc, so I’m not sure how this slipped through the cracks.

Thanks for fixing.

Cheers,
Ross
diff mbox series

Patch

diff --git a/meta-oe/recipes-extended/flatpak/flatpak/0001-meson.build-require-native-gtkdoc.patch b/meta-oe/recipes-extended/flatpak/flatpak/0001-meson.build-require-native-gtkdoc.patch
new file mode 100644
index 000000000..77b60ec98
--- /dev/null
+++ b/meta-oe/recipes-extended/flatpak/flatpak/0001-meson.build-require-native-gtkdoc.patch
@@ -0,0 +1,33 @@ 
+From 49737b1e4a74c77a8cd7ae727974d68503da087f Mon Sep 17 00:00:00 2001
+From: Markus Volk <f_l_k@t-online.de>
+Date: Fri, 12 Jan 2024 13:52:08 +0100
+Subject: [PATCH] meson.build: require native gtkdoc
+
+this fixes:
+| Run-time dependency gtk-doc found: NO (tried pkgconfig)
+|
+| ../git/meson.build:206:13: ERROR: Dependency "gtk-doc" not found, tried pkgconfig
+
+Upstream-Status: Submitted [https://github.com/flatpak/flatpak/pull/5650/commits/e5de3e46b917f830d7f81e9db6ed2a9b7d7db942]
+
+Signed-off-by: Markus Volk <f_l_k@t-online.de>
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index f7f9372d..dccc3eb4 100644
+--- a/meson.build
++++ b/meson.build
+@@ -203,7 +203,7 @@ appstream_dep = dependency('appstream', version : '>=0.12.0')
+ gdk_pixbuf_dep = dependency('gdk-pixbuf-2.0')
+ libseccomp_dep = dependency('libseccomp', required : get_option('seccomp'))
+ gir_dep = dependency('gobject-introspection-1.0', version : '>=1.40.0', required : get_option('gir'))
+-gtkdoc_dep = dependency('gtk-doc', required : get_option('gtkdoc'))
++gtkdoc_dep = dependency('gtk-doc', required : get_option('gtkdoc'), native : true)
+ build_gtk_doc = gtkdoc_dep.found()
+ 
+ wayland_client = dependency('wayland-client', required : get_option('wayland_security_context'))
+-- 
+2.43.0
+
diff --git a/meta-oe/recipes-extended/flatpak/flatpak_1.15.6.bb b/meta-oe/recipes-extended/flatpak/flatpak_1.15.6.bb
index caa353bb8..19f6f45fc 100644
--- a/meta-oe/recipes-extended/flatpak/flatpak_1.15.6.bb
+++ b/meta-oe/recipes-extended/flatpak/flatpak_1.15.6.bb
@@ -7,6 +7,7 @@  SRC_URI = " \
     gitsm://github.com/flatpak/flatpak;protocol=https;branch=main \
     file://0001-flatpak-pc-add-pc_sysrootdir.patch \
     file://0001-meson.build-require-for-native-wayland-scanner.patch \
+    file://0001-meson.build-require-native-gtkdoc.patch \
 "
 
 SRCREV = "27b11b93c2a80a91c9461bc6c7f5e9a201406041"