diff mbox series

[meta-oe] grpc: upgrade 1.59.2 -> 1.60.0

Message ID 20240111152027.956402-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-oe] grpc: upgrade 1.59.2 -> 1.60.0 | expand

Commit Message

Alper Ak Jan. 11, 2024, 3:20 p.m. UTC
0001-cmake-Link-with-libatomic-on-rv32-rv64.patch refreshed

Changelog:

Core

    Implemented dualstack IPv4 and IPv6 backend support, as per draft gRFC A61. xDS support currently guarded by GRPC_EXPERIMENTAL_XDS_DUALSTACK_ENDPOINTS env var.
    Dropped Bazel 5 support. (#34813)
    [deps] Upgrade protobuf version to v25.0. (#34513)
    [Security - Revocation] Crl Directory Watcher Implementation. (#34749)
    [server] Cap size of pending request queue with RealRequestMatcher. (#34782)
    [chttp2] Fix outgoing data stats. (#34693)
    [EventEngine] Enable Posix EventEngine Listener on all builds. (#34748)
    [EventEngine] Enable Windows EventEngine Listener on all builds. (#34436)
    [chttp2] Alternative protection for too many streams in the system. (#34697)
    [Proxy] Support for setting proxy for addresses. (#34617)
    [client idleness] client channels go idle after 30 minutes by default. (#34653)
    [chttp2] Add an experiment to separate liveness checks from ping timeouts. (#34647)
    [chttp2] Tarpit invalid requests. (#34641)
    [chttp2] Enforce settings acks. (#34640)
    [chttp2] Limit work per read cycle. (#34639)
    [chttp2] Limit request count before receiving settings ack. (#34638)
    [chttp2] Randomly ping on RST_STREAM. (#34637)

C++

    [xds] C++ XdsServerBuilder Remove src/... header dependency from public header. (#34790)
    [reflection] Add v1 reflection. (#34535)

C#

    [csharp] Grpc.Tools documentation for sharing proto files between projects and nuget packages. (#34521)

Ruby

    [ruby] create debug symbol packages. (#34632)

Python

    [Bug Fix] Change return of grpc.aio.ServicerContext.code() from integer to grpc.StatusCode. (#34292)

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../0001-cmake-Link-with-libatomic-on-rv32-rv64.patch  | 10 +++++-----
 .../grpc/{grpc_1.59.2.bb => grpc_1.60.0.bb}            |  4 ++--
 2 files changed, 7 insertions(+), 7 deletions(-)
 rename meta-oe/recipes-devtools/grpc/{grpc_1.59.2.bb => grpc_1.60.0.bb} (97%)
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/grpc/grpc/0001-cmake-Link-with-libatomic-on-rv32-rv64.patch b/meta-oe/recipes-devtools/grpc/grpc/0001-cmake-Link-with-libatomic-on-rv32-rv64.patch
index fbdf06d69..594503ae2 100644
--- a/meta-oe/recipes-devtools/grpc/grpc/0001-cmake-Link-with-libatomic-on-rv32-rv64.patch
+++ b/meta-oe/recipes-devtools/grpc/grpc/0001-cmake-Link-with-libatomic-on-rv32-rv64.patch
@@ -1,4 +1,4 @@ 
-From c321f19ff1cd1251c19d20b17a2d86c4237ce506 Mon Sep 17 00:00:00 2001
+From 54e8dca9b39b8c8a6532576a0286e548f97607fa Mon Sep 17 00:00:00 2001
 From: Khem Raj <raj.khem@gmail.com>
 Date: Tue, 19 Apr 2022 16:07:19 -0700
 Subject: [PATCH] cmake: Link with libatomic on rv32/rv64
@@ -15,12 +15,12 @@  Signed-off-by: Khem Raj <raj.khem@gmail.com>
  1 file changed, 3 insertions(+)
 
 diff --git a/CMakeLists.txt b/CMakeLists.txt
-index b272816685..e1fe1102c4 100644
+index 06e6453b5c..476d7f1576 100644
 --- a/CMakeLists.txt
 +++ b/CMakeLists.txt
-@@ -303,6 +303,9 @@ if(UNIX AND NOT HAIKU)
-   if(_gRPC_PLATFORM_LINUX OR _gRPC_PLATFORM_POSIX)
-     set(_gRPC_ALLTARGETS_LIBRARIES ${_gRPC_ALLTARGETS_LIBRARIES} rt)
+@@ -306,6 +306,9 @@ if(UNIX AND NOT HAIKU)
+       set(_gRPC_ALLTARGETS_LIBRARIES ${_gRPC_ALLTARGETS_LIBRARIES} rt)
+     endif()
    endif()
 +  if(CMAKE_SYSTEM_PROCESSOR STREQUAL "riscv64" OR CMAKE_SYSTEM_PROCESSOR STREQUAL "riscv32")
 +    set(_gRPC_ALLTARGETS_LIBRARIES ${_gRPC_ALLTARGETS_LIBRARIES} atomic)
diff --git a/meta-oe/recipes-devtools/grpc/grpc_1.59.2.bb b/meta-oe/recipes-devtools/grpc/grpc_1.60.0.bb
similarity index 97%
rename from meta-oe/recipes-devtools/grpc/grpc_1.59.2.bb
rename to meta-oe/recipes-devtools/grpc/grpc_1.60.0.bb
index c30e52263..14fca669d 100644
--- a/meta-oe/recipes-devtools/grpc/grpc_1.59.2.bb
+++ b/meta-oe/recipes-devtools/grpc/grpc_1.60.0.bb
@@ -20,8 +20,8 @@  RDEPENDS:${PN}-dev:append:class-native = " ${PN}-compiler"
 # RDEPENDS:${PN}-dev += "${PN}-compiler"
 
 S = "${WORKDIR}/git"
-SRCREV_grpc = "883e5f76976b86afee87415dc67bde58d9b295a4"
-BRANCH = "v1.59.x"
+SRCREV_grpc = "0ef13a7555dbaadd4633399242524129eef5e231"
+BRANCH = "v1.60.x"
 SRC_URI = "gitsm://github.com/grpc/grpc.git;protocol=https;name=grpc;branch=${BRANCH} \
            file://0001-cmake-Link-with-libatomic-on-rv32-rv64.patch \
            "