diff mbox series

[meta-python,1/3] python3-webargs: Upgrade 8.3.0 -> 8.4.0

Message ID 20240109135121.3460927-1-leon.anavi@konsulko.com
State Accepted
Headers show
Series [meta-python,1/3] python3-webargs: Upgrade 8.3.0 -> 8.4.0 | expand

Commit Message

Leon Anavi Jan. 9, 2024, 1:51 p.m. UTC
Upgrade to version 8.4.0:

- Add a new class attribute, empty_value to DelimitedList and
  DelimitedTuple, with a default of "". This controls the value
  deserialized when an empty string is seen.
- The rule for default argument names has been made configurable
  by overriding the get_default_arg_name method. This is described
  in the argument passing documentation.
- Drop support for Python 3.7, which is EOL.
- Type annotations for FlaskParser have been improved.

License-Update: Copyright year changes

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../python/python3-webargs_8.3.0.bb             | 13 -------------
 .../python/python3-webargs_8.4.0.bb             | 17 +++++++++++++++++
 2 files changed, 17 insertions(+), 13 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-webargs_8.3.0.bb
 create mode 100644 meta-python/recipes-devtools/python/python3-webargs_8.4.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-webargs_8.3.0.bb b/meta-python/recipes-devtools/python/python3-webargs_8.3.0.bb
deleted file mode 100644
index d8ce4ab40..000000000
--- a/meta-python/recipes-devtools/python/python3-webargs_8.3.0.bb
+++ /dev/null
@@ -1,13 +0,0 @@ 
-SUMMARY = "Declarative parsing and validation of HTTP request objects, with built-in support for popular web frameworks."
-HOMEPAGE = "https://github.com/marshmallow-code/webargs"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=c3ff8567ef1f2a8cf223f30ac5a6f094"
-
-inherit pypi setuptools3
-
-SRC_URI[sha256sum] = "cab207941b0686c4d086c823632ddcd4343151644341a32fcf50b8eaa71e31c7"
-
-RDEPENDS:${PN} += "\
-    python3-marshmallow \
-    python3-packaging \
-    "
diff --git a/meta-python/recipes-devtools/python/python3-webargs_8.4.0.bb b/meta-python/recipes-devtools/python/python3-webargs_8.4.0.bb
new file mode 100644
index 000000000..ea830807c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-webargs_8.4.0.bb
@@ -0,0 +1,17 @@ 
+SUMMARY = "Declarative parsing and validation of HTTP request objects, with built-in support for popular web frameworks."
+HOMEPAGE = "https://github.com/marshmallow-code/webargs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=dfbd4ae0074716275fc229c775723e8f"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "ea99368214a4ce613924be99d71db58c269631e95eff4fa09b7354e52dc006a5"
+
+RDEPENDS:${PN} += "\
+    ${PYTHON_PN}-marshmallow \
+    ${PYTHON_PN}-packaging \
+    ${PYTHON_PN}-core \
+    ${PYTHON_PN}-json \
+    ${PYTHON_PN}-asyncio \
+    ${PYTHON_PN}-logging \
+"