diff mbox series

[meta-python] python3-pydantic-core: Rename the cpython module on musl

Message ID 20240107050934.2399534-1-raj.khem@gmail.com
State Accepted
Headers show
Series [meta-python] python3-pydantic-core: Rename the cpython module on musl | expand

Commit Message

Khem Raj Jan. 7, 2024, 5:09 a.m. UTC
wheel contains site-package .so named linux-musl which is not loadable
on musl systems, rename it to linux-gnu even on musl like other python
dynamic modules.

This fixed ptest runs for both pydantic-core and pydantic recipes

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../python/python3-pydantic-core_2.14.6.bb            | 11 +++++++++++
 1 file changed, 11 insertions(+)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pydantic-core_2.14.6.bb b/meta-python/recipes-devtools/python/python3-pydantic-core_2.14.6.bb
index 601ba25b60..e58ee7fd66 100644
--- a/meta-python/recipes-devtools/python/python3-pydantic-core_2.14.6.bb
+++ b/meta-python/recipes-devtools/python/python3-pydantic-core_2.14.6.bb
@@ -34,6 +34,17 @@  RDEPENDS:${PN}-ptest += "\
     python3-unittest-automake-output \
 "
 
+do_install:append() {
+    for f in ${D}/${libdir}/${PYTHON_DIR}/site-packages/pydantic_core/_pydantic_core.*.so
+    do
+        fname=`basename $f`
+        lname=`echo $fname | sed 's/musl/gnu/'`
+        if [ "$fname" != "$lname" ]; then
+            mv $f ${D}/${libdir}/${PYTHON_DIR}/site-packages/pydantic_core/$lname
+        fi
+    done
+}
+
 do_install_ptest() {
     cp -rf ${S}/tests/ ${D}${PTEST_PATH}/
     rm -rf ${D}${PTEST_PATH}/tests/benchmarks