diff mbox series

[meta-python] gyp: update to the latest commit

Message ID 20231221180609.3902636-1-derek@asterius.io
State Accepted
Headers show
Series [meta-python] gyp: update to the latest commit | expand

Commit Message

Derek Straka Dec. 21, 2023, 6:06 p.m. UTC
NOTE: gyp is now idle, and support will be removed in future releases
https://chromium.googlesource.com/external/gyp/+/d6c5dd51dc3a60bf4ff32a5256713690a1a10376

Signed-off-by: Derek Straka <derek@asterius.io>
---
 ...01-Fix-for-Python-3.10-compatibility.patch | 36 -------------------
 meta-python/recipes-devtools/gyp/gyp_git.bb   |  3 +-
 2 files changed, 1 insertion(+), 38 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/gyp/gyp/0001-Fix-for-Python-3.10-compatibility.patch

Comments

Khem Raj Dec. 27, 2023, 8:21 a.m. UTC | #1
On Thu, 21 Dec 2023 18:06:09 +0000, Derek Straka wrote:
> NOTE: gyp is now idle, and support will be removed in future releases
> https://chromium.googlesource.com/external/gyp/+/d6c5dd51dc3a60bf4ff32a5256713690a1a10376
> 
> 

Applied, thanks!

[1/1] gyp: update to the latest commit
      commit: 1a1deabbf0e420fa93e136cdacddc85f9d3f42fe

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/gyp/gyp/0001-Fix-for-Python-3.10-compatibility.patch b/meta-python/recipes-devtools/gyp/gyp/0001-Fix-for-Python-3.10-compatibility.patch
deleted file mode 100644
index d1ac2c6b4..000000000
--- a/meta-python/recipes-devtools/gyp/gyp/0001-Fix-for-Python-3.10-compatibility.patch
+++ /dev/null
@@ -1,36 +0,0 @@ 
-From bfe579283e5fcab60172818bfe4e6e1d40c2bed0 Mon Sep 17 00:00:00 2001
-From: Kurt Kiefer <kurt.kiefer@arthrex.com>
-Date: Mon, 18 Oct 2021 11:21:14 -0700
-Subject: [PATCH] Fix for Python 3.10 compatibility
-
-The collections.abc module replaces collections for Python 3.10
-
-Signed-off-by: Kurt Kiefer <kurt.kiefer@arthrex.com>
----
-Upstream-Status: Pending
-
- pylib/gyp/common.py | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/pylib/gyp/common.py b/pylib/gyp/common.py
-index b268d229..4f9cb0ec 100644
---- a/pylib/gyp/common.py
-+++ b/pylib/gyp/common.py
-@@ -4,7 +4,7 @@
- 
- from __future__ import with_statement
- 
--import collections
-+import collections.abc
- import errno
- import filecmp
- import os.path
-@@ -494,7 +494,7 @@ def uniquer(seq, idfun=None):
- 
- 
- # Based on http://code.activestate.com/recipes/576694/.
--class OrderedSet(collections.MutableSet):
-+class OrderedSet(collections.abc.MutableSet):
-   def __init__(self, iterable=None):
-     self.end = end = []
-     end += [None, end, end]         # sentinel node for doubly linked list
diff --git a/meta-python/recipes-devtools/gyp/gyp_git.bb b/meta-python/recipes-devtools/gyp/gyp_git.bb
index 38906de75..0f94a4476 100644
--- a/meta-python/recipes-devtools/gyp/gyp_git.bb
+++ b/meta-python/recipes-devtools/gyp/gyp_git.bb
@@ -5,9 +5,8 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=ab828cb8ce4c62ee82945a11247b6bbd"
 SECTION = "devel"
 
 SRC_URI = "git://chromium.googlesource.com/external/gyp;protocol=https;branch=master \
-           file://0001-Fix-for-Python-3.10-compatibility.patch \
            "
-SRCREV = "caa60026e223fc501e8b337fd5086ece4028b1c6"
+SRCREV = "a03d7413becefc8d55c8aa3df58b55b9bd0e9052"
 
 S = "${WORKDIR}/git"
 PV = "0.1+git${SRCPV}"