diff mbox series

[meta-python] python3-wtforms: fix upstream uri and version check

Message ID 20231221174822.3900911-1-derek@asterius.io
State Accepted
Headers show
Series [meta-python] python3-wtforms: fix upstream uri and version check | expand

Commit Message

Derek Straka Dec. 21, 2023, 5:48 p.m. UTC
Signed-off-by: Derek Straka <derek@asterius.io>
---
 meta-python/recipes-devtools/python/python3-wtforms_3.1.1.bb | 3 +++
 1 file changed, 3 insertions(+)

Comments

Khem Raj Dec. 27, 2023, 8:21 a.m. UTC | #1
On Thu, 21 Dec 2023 17:48:22 +0000, Derek Straka wrote:
> 


Applied, thanks!

[1/1] python3-wtforms: fix upstream uri and version check
      commit: c600141d649c2b1099624384708a03c497ae5be1

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-wtforms_3.1.1.bb b/meta-python/recipes-devtools/python/python3-wtforms_3.1.1.bb
index c9ad1be48..b57c31100 100644
--- a/meta-python/recipes-devtools/python/python3-wtforms_3.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-wtforms_3.1.1.bb
@@ -7,6 +7,9 @@  LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=17ed54aa95f4a6cd0d7a4747d14b64d0"
 
 SRC_URI[sha256sum] = "5e51df8af9a60f6beead75efa10975e97768825a82146a65c7cbf5b915990620"
 
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/WTForms"
+UPSTREAM_CHECK_REGEX = "/WTForms/(?P<pver>(\d+[\.\-_]*)+)"
+
 inherit pypi python_hatchling
 
 DEPENDS += "\