diff mbox series

[meta-python] python3-ninja: update to version 1.11.1.1

Message ID 20231220220733.3787024-1-derek@asterius.io
State Accepted
Headers show
Series [meta-python] python3-ninja: update to version 1.11.1.1 | expand

Commit Message

Derek Straka Dec. 20, 2023, 10:07 p.m. UTC
Changelog
  fix(wheels): link libstdc++ statically on manylinux1 by @mayeut in #159
  chore(wheels): link libstdc++/libgcc statically on musllinux by @mayeut in #160
  chore: add Windows ARM support by @henryiii in #169
  chore: continue testing with python 2.7 by @mayeut in #199
  chore: move to setuptools_scm by @henryiii in #170
  chore: switch to ruff by @henryiii in #174
  chore: use trusted publisher deployment by @jcfr in #191
  chore: use wheel tags cli by @mayeut in #84
  ci: allow setting a version by @henryiii in #171
  ci: cancel on repeated pushes by @henryiii in #177

Signed-off-by: Derek Straka <derek@asterius.io>
---
 .../python/python3-ninja/no-scikit-build.patch            | 8 ++++----
 ...{python3-ninja_1.11.1.bb => python3-ninja_1.11.1.1.bb} | 4 +++-
 2 files changed, 7 insertions(+), 5 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-ninja_1.11.1.bb => python3-ninja_1.11.1.1.bb} (79%)

Comments

Khem Raj Dec. 27, 2023, 8:21 a.m. UTC | #1
On Wed, 20 Dec 2023 22:07:33 +0000, Derek Straka wrote:
> Changelog
>   fix(wheels): link libstdc++ statically on manylinux1 by @mayeut in #159
>   chore(wheels): link libstdc++/libgcc statically on musllinux by @mayeut in #160
>   chore: add Windows ARM support by @henryiii in #169
>   chore: continue testing with python 2.7 by @mayeut in #199
>   chore: move to setuptools_scm by @henryiii in #170
>   chore: switch to ruff by @henryiii in #174
>   chore: use trusted publisher deployment by @jcfr in #191
>   chore: use wheel tags cli by @mayeut in #84
>   ci: allow setting a version by @henryiii in #171
>   ci: cancel on repeated pushes by @henryiii in #177
> 
> [...]

Applied, thanks!

[1/1] python3-ninja: update to version 1.11.1.1
      commit: d8637f07a28128f42c69e397b1ddd4ca0e053060

Best regards,
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-ninja/no-scikit-build.patch b/meta-python/recipes-devtools/python/python3-ninja/no-scikit-build.patch
index 276fb5017..b7d191e24 100644
--- a/meta-python/recipes-devtools/python/python3-ninja/no-scikit-build.patch
+++ b/meta-python/recipes-devtools/python/python3-ninja/no-scikit-build.patch
@@ -8,11 +8,11 @@  diff --git a/pyproject.toml b/pyproject.toml
 index b895c20..577b642 100644
 --- a/pyproject.toml
 +++ b/pyproject.toml
-@@ -1,7 +1,6 @@
- [build-system]
+@@ -2,7 +2,6 @@
  requires = [
-     "setuptools>=42",
--    "scikit-build>=0.12",
+     "setuptools >=42",
+     "setuptools-scm[toml]",
+-    "scikit-build",
  ]
  build-backend = "setuptools.build_meta"
  
diff --git a/meta-python/recipes-devtools/python/python3-ninja_1.11.1.bb b/meta-python/recipes-devtools/python/python3-ninja_1.11.1.1.bb
similarity index 79%
rename from meta-python/recipes-devtools/python/python3-ninja_1.11.1.bb
rename to meta-python/recipes-devtools/python/python3-ninja_1.11.1.1.bb
index 3b9077f32..a9e0ed208 100644
--- a/meta-python/recipes-devtools/python/python3-ninja_1.11.1.bb
+++ b/meta-python/recipes-devtools/python/python3-ninja_1.11.1.1.bb
@@ -6,11 +6,13 @@  PYPI_PACKAGE = "ninja"
 PYPI_ARCHIVE_NAME_PREFIX = "pypi-"
 
 inherit pypi python_setuptools_build_meta
-SRC_URI[sha256sum] = "c833a47d39b2d1eee3f9ca886fa1581efd5be6068b82734ac229961ee8748f90"
+SRC_URI[sha256sum] = "9d793b08dd857e38d0b6ffe9e6b7145d7c485a42dcfea04905ca0cdb6017cc3c"
 
 SRC_URI += "file://no-scikit-build.patch \
             file://run-ninja-from-path.patch"
 
+DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
+
 do_install:append () {
 	rm -rf ${D}${bindir}
 }