diff mbox series

[meta-oe] tk: Remove buildpath issue

Message ID 20231220065648.3032297-1-mingli.yu@windriver.com
State Accepted
Headers show
Series [meta-oe] tk: Remove buildpath issue | expand

Commit Message

Yu, Mingli Dec. 20, 2023, 6:56 a.m. UTC
From: Mingli Yu <mingli.yu@windriver.com>

Though the S defined as ${WORKDIR}/${BPN}${PV}/unix, but some source
files come from such as ${WORKDIR}/${BPN}${PV}/unix/../generic, so add
"-fdebug-prefix-map=${S}/../" to fix the below buildpath issue:
  WARNING: tk-8.6.10-r0 do_package_qa: QA Issue: File /usr/lib64/.debug/libtk8.6.so in package tk-dbg contains reference to TMPDIR
  File /usr/bin/.debug/wish8.6 in package tk-dbg contains reference to TMPDIR [buildpaths]

Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
---
 meta-oe/recipes-devtools/tcltk/tk_8.6.10.bb | 2 ++
 1 file changed, 2 insertions(+)

Comments

Khem Raj Dec. 27, 2023, 8:21 a.m. UTC | #1
On Wed, 20 Dec 2023 14:56:48 +0800, mingli.yu@windriver.com wrote:
> Though the S defined as ${WORKDIR}/${BPN}${PV}/unix, but some source
> files come from such as ${WORKDIR}/${BPN}${PV}/unix/../generic, so add
> "-fdebug-prefix-map=${S}/../" to fix the below buildpath issue:
>   WARNING: tk-8.6.10-r0 do_package_qa: QA Issue: File /usr/lib64/.debug/libtk8.6.so in package tk-dbg contains reference to TMPDIR
>   File /usr/bin/.debug/wish8.6 in package tk-dbg contains reference to TMPDIR [buildpaths]
> 
> 
> [...]

Applied, thanks!

[1/1] tk: Remove buildpath issue
      commit: 4bd31c4915094071a114fd5339e0d9db8dcbb11f

Best regards,
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/tcltk/tk_8.6.10.bb b/meta-oe/recipes-devtools/tcltk/tk_8.6.10.bb
index f3cab4e61..237c4e738 100644
--- a/meta-oe/recipes-devtools/tcltk/tk_8.6.10.bb
+++ b/meta-oe/recipes-devtools/tcltk/tk_8.6.10.bb
@@ -28,6 +28,8 @@  SRC_URI[sha256sum] = "63df418a859d0a463347f95ded5cd88a3dd3aaa1ceecaeee362194bc30
 
 S = "${WORKDIR}/${BPN}${PV}/unix"
 
+DEBUG_PREFIX_MAP += "-fdebug-prefix-map=${S}/../=${TARGET_DBGSRC_DIR}/.."
+
 PSEUDO_IGNORE_PATHS .= ",${WORKDIR}/${BPN}${PV}"
 
 # Short version format: "8.6"