diff mbox series

[meta-python,4/4] python3-rlp: upgrade 3.0.0 -> 4.0.0

Message ID 20231218170901.1378254-4-leon.anavi@konsulko.com
State Accepted
Headers show
Series [meta-python,1/4] python3-sdbus: upgrade 0.11.0 -> 0.11.1 | expand

Commit Message

Leon Anavi Dec. 18, 2023, 5:09 p.m. UTC
Upgrade to version 4.0.0:

- repr() now returns an evaluatable string, like
  MyRLPObj(my_int_field=1, my_str_field="a_str")
- Convert .format strings to f-strings
- Add autoflake linting and move config to pyproject.toml

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 ...-setup-don-t-use-setuptools-markdown.patch | 37 -------------------
 ...hon3-rlp_3.0.0.bb => python3-rlp_4.0.0.bb} |  8 ++--
 2 files changed, 5 insertions(+), 40 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-rlp/0001-setup-don-t-use-setuptools-markdown.patch
 rename meta-python/recipes-devtools/python/{python3-rlp_3.0.0.bb => python3-rlp_4.0.0.bb} (60%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-rlp/0001-setup-don-t-use-setuptools-markdown.patch b/meta-python/recipes-devtools/python/python3-rlp/0001-setup-don-t-use-setuptools-markdown.patch
deleted file mode 100644
index 0ab012a98..000000000
--- a/meta-python/recipes-devtools/python/python3-rlp/0001-setup-don-t-use-setuptools-markdown.patch
+++ /dev/null
@@ -1,37 +0,0 @@ 
-From 5a2db801c6520be296cee9cba0e0e4ffac68430c Mon Sep 17 00:00:00 2001
-From: Bartosz Golaszewski <brgl@bgdev.pl>
-Date: Wed, 11 May 2022 15:11:19 +0200
-Subject: [PATCH] setup: don't use setuptools-markdown
-
-This project is deprecated and irrelevant for the functionality of
-pyrlp. We don't support it in meta-python so just drop it from the
-dependencies.
-
-Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
----
-Upstream-Status: Pending
-
- setup.py | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/setup.py b/setup.py
-index 1055fb1..55fca24 100755
---- a/setup.py
-+++ b/setup.py
-@@ -46,13 +46,11 @@ setup(
-     # *IMPORTANT*: Don't manually change the version here. See README for more.
-     version='3.0.0',
-     description="A package for Recursive Length Prefix encoding and decoding",
--    long_description_markdown_filename='README.md',
-     author="jnnk",
-     author_email='jnnknnj@gmail.com',
-     url='https://github.com/ethereum/pyrlp',
-     packages=find_packages(exclude=["tests", "tests.*"]),
-     include_package_data=True,
--    setup_requires=['setuptools-markdown'],
-     install_requires=[
-         "eth-utils>=2.0.0,<3",
-     ],
--- 
-2.34.1
-
diff --git a/meta-python/recipes-devtools/python/python3-rlp_3.0.0.bb b/meta-python/recipes-devtools/python/python3-rlp_4.0.0.bb
similarity index 60%
rename from meta-python/recipes-devtools/python/python3-rlp_3.0.0.bb
rename to meta-python/recipes-devtools/python/python3-rlp_4.0.0.bb
index e747ae33b..49efd09a4 100644
--- a/meta-python/recipes-devtools/python/python3-rlp_3.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-rlp_4.0.0.bb
@@ -4,11 +4,13 @@  SECTION = "devel/python"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=00854fa80a84236706b11f47f23e61e7"
 
-SRC_URI[sha256sum] = "63b0465d2948cd9f01de449d7adfb92d207c1aef3982f20310f8009be4a507e8"
-SRC_URI += "file://0001-setup-don-t-use-setuptools-markdown.patch"
+SRC_URI[sha256sum] = "61a5541f86e4684ab145cb849a5929d2ced8222930a570b3941cf4af16b72a78"
 
 inherit pypi setuptools3
 
 DEPENDS += "python3-pip-native"
 
-RDEPENDS:${PN} += "python3-eth-utils"
+RDEPENDS:${PN} += " \
+    ${PYTHON_PN}-eth-utils \
+    ${PYTHON_PN}-typing-extensions \
+"