diff mbox series

[meta-oe,2/2] sdbus-c++: Install ptests into PTEST_PATH

Message ID 20231201081117.569210-2-raj.khem@gmail.com
State Accepted, archived
Headers show
Series [meta-oe,1/2] basu: Update to latest master | expand

Commit Message

Khem Raj Dec. 1, 2023, 8:11 a.m. UTC
add rdep on basu and dbus when not using systemd

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.4.0/run-ptest | 4 ++--
 meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.4.0.bb        | 9 ++++-----
 2 files changed, 6 insertions(+), 7 deletions(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.4.0/run-ptest b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.4.0/run-ptest
index f6ade0c7e4..2dc6e1eca1 100755
--- a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.4.0/run-ptest
+++ b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.4.0/run-ptest
@@ -4,12 +4,12 @@  set -o pipefail
 
 SCRIPTPATH="$( cd "$(dirname "$0")" ; pwd -P )"
 
-${SCRIPTPATH}/../tests/sdbus-c++-unit-tests 2>&1 | \
+${SCRIPTPATH}/sdbus-c++-unit-tests 2>&1 | \
 sed -r 's/^\[\s+OK\s+\] (.*) \([0-9]+\sms\)$/OK: \1 /' | \
 sed -r 's/^\[\s+FAILED\s+\] (.*) \([0-9]+\sms\)$/FAILED: \1 /' | \
 awk '{if ($1 == "OK:" || $1 == "FAILED:") {print $0}}'
 
-${SCRIPTPATH}/../tests/sdbus-c++-integration-tests 2>&1 | \
+${SCRIPTPATH}/sdbus-c++-integration-tests 2>&1 | \
 sed -r 's/^\[\s+OK\s+\] (.*) \([0-9]+\sms\)$/OK: \1 /' | \
 sed -r 's/^\[\s+FAILED\s+\] (.*) \([0-9]+\sms\)$/FAILED: \1 /' | \
 awk '{if ($1 == "OK:" || $1 == "FAILED:") {print $0}}' 
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.4.0.bb b/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.4.0.bb
index 869bfa951f..ca91b351ed 100644
--- a/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.4.0.bb
+++ b/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.4.0.bb
@@ -10,9 +10,9 @@  inherit cmake pkgconfig systemd ptest
 
 PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'with-external-libsystemd', 'with-builtin-libsystemd', d)} \
                    ${@bb.utils.contains('PTEST_ENABLED', '1', 'with-tests', '', d)}"
-PACKAGECONFIG[with-builtin-libsystemd] = ",,sdbus-c++-libsystemd,libcap"
+PACKAGECONFIG[with-builtin-libsystemd] = ",,sdbus-c++-libsystemd,libcap,basu"
 PACKAGECONFIG[with-external-libsystemd] = ",,systemd,libsystemd"
-PACKAGECONFIG[with-tests] = "-DBUILD_TESTS=ON -DTESTS_INSTALL_PATH=${libdir}/${BPN}/tests,-DBUILD_TESTS=OFF,googletest gmock"
+PACKAGECONFIG[with-tests] = "-DBUILD_TESTS=ON -DTESTS_INSTALL_PATH=${PTEST_PATH},-DBUILD_TESTS=OFF,googletest gmock"
 
 DEPENDS += "expat"
 
@@ -39,14 +39,13 @@  do_install:append() {
     fi
 }
 
-PTEST_PATH = "${libdir}/${BPN}/ptest"
 do_install_ptest() {
-    install -d ${D}${PTEST_PATH}
-    cp -r ${B}/tests/sdbus-c++-unit-tests  ${D}${PTEST_PATH}
+    DESTDIR='${D}' cmake_runcmake_build --target tests/install
 }
 
 FILES:${PN}-ptest =+ "${sysconfdir}/dbus-1/system.d/"
 FILES:${PN}-dev += "${bindir}/sdbus-c++-xml2cpp"
 
+RDEPENDS:${PN}-ptest += "dbus"
 # It adds -isystem which is spurious, no idea where it gets it from
 CCACHE_DISABLE = "1"