diff mbox series

[meta-multimedia] gstd: Install systemd unit into sysem unitdir folder

Message ID 20231201080441.565612-1-raj.khem@gmail.com
State Accepted, archived
Headers show
Series [meta-multimedia] gstd: Install systemd unit into sysem unitdir folder | expand

Commit Message

Khem Raj Dec. 1, 2023, 8:04 a.m. UTC
bt default it installs into user systemd unitdir folder which can not be
preconfigured offline.

Signed-off-by: Khem Raj <raj.khem@gmail.com>
Cc: Mark Hatle <mark.hatle@amd.com>
---
 .../recipes-multimedia/gstreamer-1.0/gstd_git.bb            | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

Comments

Mark Hatle Dec. 1, 2023, 4:40 p.m. UTC | #1
Verified this fixes the build-time failure I observed.

Boot though does result in a [FAILED] when starting the GStreamer Daemon.  I 
don't have enough knowledge to diagnose this, but I'll see if I can find someone 
who might.

Based on resolving the build time issue, this is worth going in, IMHO.

--Mark

On 12/1/23 2:04 AM, Khem Raj wrote:
> bt default it installs into user systemd unitdir folder which can not be
> preconfigured offline.
> 
> Signed-off-by: Khem Raj <raj.khem@gmail.com>
> Cc: Mark Hatle <mark.hatle@amd.com>
> ---
>   .../recipes-multimedia/gstreamer-1.0/gstd_git.bb            | 6 ++++--
>   1 file changed, 4 insertions(+), 2 deletions(-)
> 
> diff --git a/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
> index 88acdb190e..2068302826 100644
> --- a/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
> +++ b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
> @@ -17,6 +17,8 @@ PV = "1.0+really0.15.0"
>   
>   GTKDOC_MESON_OPTION = "enable-gtk-doc"
>   
> +EXTRA_OEMESON += "-Dwith-gstd-systemddir=${systemd_system_unitdir}"
> +
>   inherit meson pkgconfig gettext gtk-doc systemd python3native python3-dir python3targetconfig
>   
>   do_install:append() {
> @@ -28,7 +30,7 @@ do_install:append() {
>                   install -d ${D}${sysconfdir}/tmpfiles.d
>                   echo "d /run/${BPN} - - - -" \
>                   > ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
> -                echo "d /${localstatedir}/log/${BPN} 0755 root root -" \
> +                echo "d ${localstatedir}/log/${BPN} 0755 root root -" \
>                   >> ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
>           fi
>           ln -sf gst-client-1.0 ${D}${bindir}/gst-client
> @@ -36,7 +38,7 @@ do_install:append() {
>   }
>   PACKAGES =+ "${PN}-python"
>   
> -FILES:${PN} += "${systemd_user_unitdir}"
> +FILES:${PN} += "${systemd_system_unitdir}"
>   FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*"
>   
>   SYSTEMD_SERVICE:${PN} = "gstd.service"
> 
> 
> 
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#107184): https://lists.openembedded.org/g/openembedded-devel/message/107184
> Mute This Topic: https://lists.openembedded.org/mt/102911359/3616948
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [mark.hatle@kernel.crashing.org]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
index 88acdb190e..2068302826 100644
--- a/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
+++ b/meta-multimedia/recipes-multimedia/gstreamer-1.0/gstd_git.bb
@@ -17,6 +17,8 @@  PV = "1.0+really0.15.0"
 
 GTKDOC_MESON_OPTION = "enable-gtk-doc"
 
+EXTRA_OEMESON += "-Dwith-gstd-systemddir=${systemd_system_unitdir}"
+
 inherit meson pkgconfig gettext gtk-doc systemd python3native python3-dir python3targetconfig
 
 do_install:append() {
@@ -28,7 +30,7 @@  do_install:append() {
                 install -d ${D}${sysconfdir}/tmpfiles.d
                 echo "d /run/${BPN} - - - -" \
                 > ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
-                echo "d /${localstatedir}/log/${BPN} 0755 root root -" \
+                echo "d ${localstatedir}/log/${BPN} 0755 root root -" \
                 >> ${D}${sysconfdir}/tmpfiles.d/${BPN}.conf
         fi
         ln -sf gst-client-1.0 ${D}${bindir}/gst-client
@@ -36,7 +38,7 @@  do_install:append() {
 }
 PACKAGES =+ "${PN}-python"
 
-FILES:${PN} += "${systemd_user_unitdir}"
+FILES:${PN} += "${systemd_system_unitdir}"
 FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*"
 
 SYSTEMD_SERVICE:${PN} = "gstd.service"