diff mbox series

[meta-oe] msgpack-cpp: upgrade 4.1.1 -> 6.1.0

Message ID 20231127131101.1391708-1-alperyasinak1@gmail.com
State Accepted
Headers show
Series [meta-oe] msgpack-cpp: upgrade 4.1.1 -> 6.1.0 | expand

Commit Message

Alper Ak Nov. 27, 2023, 1:11 p.m. UTC
Changelog:

- Remove dependency on boost in chrono.hpp (#1076)
- Add support for std::variant behavior (#1075)
- Fix msgpack::type::variant behavior to respect MessagePack format (#1071)
- Add rebind allocators (#1065)
- Change CMake package name of C++ library to msgpack-cxx (#1054)
- Unified all C++ package, library, cmake, tarball name become msgpack-cxx.
- Change CMake package name of C++ library to msgpackc-cxx (#1045, #1048)
- Fix config for new MSVC preprocessor (#1040)
- Fix compile error that direct inclusion of chrono with MSGPACK_NO_BOOST (#1038)
- Fix noexcept on zone (#1030)
- Improve cmake support (#1028, #1032)
- Improve CI (#1023)
- Improve supporting platform (#1021)
- Refine double/float packing (#1018)
- Refine include files dependency (#1011)

Signed-off-by: alperak <alperyasinak1@gmail.com>
---
 .../msgpack/{msgpack-cpp_4.1.1.bb => msgpack-cpp_6.1.0.bb}      | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-oe/recipes-devtools/msgpack/{msgpack-cpp_4.1.1.bb => msgpack-cpp_6.1.0.bb} (89%)

Comments

Khem Raj Nov. 28, 2023, 11:55 p.m. UTC | #1
On Mon, 27 Nov 2023 16:11:01 +0300, alperak wrote:
> Changelog:
> 
> - Remove dependency on boost in chrono.hpp (#1076)
> - Add support for std::variant behavior (#1075)
> - Fix msgpack::type::variant behavior to respect MessagePack format (#1071)
> - Add rebind allocators (#1065)
> - Change CMake package name of C++ library to msgpack-cxx (#1054)
> - Unified all C++ package, library, cmake, tarball name become msgpack-cxx.
> - Change CMake package name of C++ library to msgpackc-cxx (#1045, #1048)
> - Fix config for new MSVC preprocessor (#1040)
> - Fix compile error that direct inclusion of chrono with MSGPACK_NO_BOOST (#1038)
> - Fix noexcept on zone (#1030)
> - Improve cmake support (#1028, #1032)
> - Improve CI (#1023)
> - Improve supporting platform (#1021)
> - Refine double/float packing (#1018)
> - Refine include files dependency (#1011)
> 
> [...]

Applied, thanks!

[1/1] msgpack-cpp: upgrade 4.1.1 -> 6.1.0
      commit: 3991d85383b466a4948283cfd0167213a1dd2311

Best regards,
diff mbox series

Patch

diff --git a/meta-oe/recipes-devtools/msgpack/msgpack-cpp_4.1.1.bb b/meta-oe/recipes-devtools/msgpack/msgpack-cpp_6.1.0.bb
similarity index 89%
rename from meta-oe/recipes-devtools/msgpack/msgpack-cpp_4.1.1.bb
rename to meta-oe/recipes-devtools/msgpack/msgpack-cpp_6.1.0.bb
index fd08bf85c..5f5507bc7 100644
--- a/meta-oe/recipes-devtools/msgpack/msgpack-cpp_4.1.1.bb
+++ b/meta-oe/recipes-devtools/msgpack/msgpack-cpp_6.1.0.bb
@@ -8,7 +8,7 @@  LIC_FILES_CHKSUM = "file://NOTICE;md5=7a858c074723608e08614061dc044352 \
                    "
 
 SRC_URI = "https://github.com/msgpack/msgpack-c/releases/download/cpp-${PV}/msgpack-cxx-${PV}.tar.gz"
-SRC_URI[sha256sum] = "8115c5edcf20bc1408c798a6bdaec16c1e52b1c34859d4982a0fb03300438f0b"
+SRC_URI[sha256sum] = "23ede7e93c8efee343ad8c6514c28f3708207e5106af3b3e4969b3a9ed7039e7"
 
 S = "${WORKDIR}/msgpack-cxx-${PV}"