diff mbox series

[meta-oe,2/3] qpdf: Update 10.6.3 -> 11.6.3

Message ID 20231107152239.2219002-2-leon.anavi@konsulko.com
State New
Headers show
Series [meta-oe,1/3] imlib2: Upgrade 1.7.1 -> 1.12.1 | expand

Commit Message

Leon Anavi Nov. 7, 2023, 3:22 p.m. UTC
Update to version 11.6.3:

- Fix a bug in which qpdf could potentially discard a character
  in a binary string if that character was preceded by an octal
  escaped string with fewer than three digits. This bug was
  introduced in the 11.0.0 release. The bug would not apply to
  content streams with default settings.
- The linearization specification precludes linearized files that
  require offets past the 4 GB mark. A bug in qpdf was preventing
  it from working when offsets had to pass the 2 GB mark. This has
  been corrected.

Switch to cmake. Use /dev/random to perform encryption securely.
Change the fully defined path on the target to about buildpaths
QA issues with libqpdfTargets.cmake.

This work was sponsored by GOVCERT.LU.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../qpdf/{qpdf_10.6.3.bb => qpdf_11.6.3.bb}         | 13 ++++++++++---
 1 file changed, 10 insertions(+), 3 deletions(-)
 rename meta-oe/recipes-printing/qpdf/{qpdf_10.6.3.bb => qpdf_11.6.3.bb} (67%)

Comments

Khem Raj Nov. 8, 2023, 7:08 a.m. UTC | #1
seeing this error

WARNING: qpdf-11.6.3-r0 do_package_qa: QA Issue: File
/usr/lib/cmake/qpdf/libqpdfTargets.cmake in package qpdf-dev contains
reference to TMPDIR [bu
ildpaths]
ERROR: qpdf-11.6.3-r0 do_package_qa: QA Issue:
/usr/lib/libqpdf.so.29.6.3 contained in package libqpdf requires
libgnutls.so.30(GNUTLS_3_4)(64bit),
 but no providers found in RDEPENDS:libqpdf? [file-rdeps]
ERROR: qpdf-11.6.3-r0 do_package_qa: QA Issue:
/usr/lib/libqpdf.so.29.6.3 contained in package libqpdf requires
libgnutls.so.30()(64bit), but no pr
oviders found in RDEPENDS:libqpdf? [file-rdeps]
ERROR: qpdf-11.6.3-r0 do_package_qa: Fatal QA errors were found, failing task.
ERROR: Logfile of failure stored in:
/mnt/b/yoe/master/build/tmp/work/core2-64-yoe-linux/qpdf/11.6.3/temp/log.do_package_qa.3501227

On Tue, Nov 7, 2023 at 7:22 AM Leon Anavi <leon.anavi@konsulko.com> wrote:
>
> Update to version 11.6.3:
>
> - Fix a bug in which qpdf could potentially discard a character
>   in a binary string if that character was preceded by an octal
>   escaped string with fewer than three digits. This bug was
>   introduced in the 11.0.0 release. The bug would not apply to
>   content streams with default settings.
> - The linearization specification precludes linearized files that
>   require offets past the 4 GB mark. A bug in qpdf was preventing
>   it from working when offsets had to pass the 2 GB mark. This has
>   been corrected.
>
> Switch to cmake. Use /dev/random to perform encryption securely.
> Change the fully defined path on the target to about buildpaths
> QA issues with libqpdfTargets.cmake.
>
> This work was sponsored by GOVCERT.LU.
>
> Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
> ---
>  .../qpdf/{qpdf_10.6.3.bb => qpdf_11.6.3.bb}         | 13 ++++++++++---
>  1 file changed, 10 insertions(+), 3 deletions(-)
>  rename meta-oe/recipes-printing/qpdf/{qpdf_10.6.3.bb => qpdf_11.6.3.bb} (67%)
>
> diff --git a/meta-oe/recipes-printing/qpdf/qpdf_10.6.3.bb b/meta-oe/recipes-printing/qpdf/qpdf_11.6.3.bb
> similarity index 67%
> rename from meta-oe/recipes-printing/qpdf/qpdf_10.6.3.bb
> rename to meta-oe/recipes-printing/qpdf/qpdf_11.6.3.bb
> index fa33daf52..17a65acc6 100644
> --- a/meta-oe/recipes-printing/qpdf/qpdf_10.6.3.bb
> +++ b/meta-oe/recipes-printing/qpdf/qpdf_11.6.3.bb
> @@ -2,14 +2,14 @@ DESCRIPTION = "PDF transformation/inspection software"
>  HOMEPAGE = "http://qpdf.sourceforge.net"
>  LICENSE = "Artistic-2.0"
>  SECTION = "libs"
> -DEPENDS = "libpcre zlib libjpeg-turbo"
> +DEPENDS = "libpcre zlib libjpeg-turbo openssl"
>
>  SRC_URI = "${SOURCEFORGE_MIRROR}/qpdf/qpdf-${PV}.tar.gz"
> -SRC_URI[sha256sum] = "e8fc23b2a584ea68c963a897515d3eb3129186741dd19d13c86d31fa33493811"
> +SRC_URI[sha256sum] = "c394b1b0cff4cd9d13b0f5e16bdf3cf54da424dc434f9d40264b7fe67acd90bc"
>
>  LIC_FILES_CHKSUM = "file://Artistic-2.0;md5=7806296b9fae874361e6fb10072b7ee3"
>
> -inherit autotools-brokensep gettext
> +inherit cmake gettext
>
>  # disable random file detection for cross-compile
>  EXTRA_OECONF = "--without-random \
> @@ -17,11 +17,18 @@ EXTRA_OECONF = "--without-random \
>                  --disable-check-autofiles \
>                  "
>
> +EXTRA_OECMAKE = '-DRANDOM_DEVICE="/dev/random"'
> +
>  LDFLAGS:append:mipsarch = " -latomic"
>  LDFLAGS:append:riscv32 = " -latomic"
>
>  S="${WORKDIR}/${BPN}-${PV}"
>
> +do_install:append() {
> +    # Change the fully defined path on the target
> +    sed -i -e 's|${STAGING_LIBDIR}|${libdir}|g' ${D}${libdir}/cmake/${BPN}/libqpdfTargets.cmake
> +}
> +
>  # avoid Makefile returning error on 'make clean' before configure was run
>  CLEANBROKEN = "1"
>
> --
> 2.39.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#106455): https://lists.openembedded.org/g/openembedded-devel/message/106455
> Mute This Topic: https://lists.openembedded.org/mt/102444518/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Leon Anavi Nov. 8, 2023, 10:53 a.m. UTC | #2
Hi Khem,

Thank you for the feedback.

On 8.11.23 г. 9:08 ч., Khem Raj wrote:
> seeing this error
>
> WARNING: qpdf-11.6.3-r0 do_package_qa: QA Issue: File
> /usr/lib/cmake/qpdf/libqpdfTargets.cmake in package qpdf-dev contains
> reference to TMPDIR [bu
> ildpaths]

The sed command in do_install:append should fix this warning. I also 
inspected to /usr/lib/cmake/qpdf/libqpdfTargets.cmake on the booted 
target device and the paths look OK. I am wondering why does this 
warning appear on your build setup?

> ERROR: qpdf-11.6.3-r0 do_package_qa: QA Issue:
> /usr/lib/libqpdf.so.29.6.3 contained in package libqpdf requires
> libgnutls.so.30(GNUTLS_3_4)(64bit),
>   but no providers found in RDEPENDS:libqpdf? [file-rdeps]
> ERROR: qpdf-11.6.3-r0 do_package_qa: QA Issue:
> /usr/lib/libqpdf.so.29.6.3 contained in package libqpdf requires
> libgnutls.so.30()(64bit), but no pr
> oviders found in RDEPENDS:libqpdf? [file-rdeps]

I can't reproduce these errors on my side. Could you please provide any 
hints how to reproduce them?

Best regards,
Leon

> ERROR: qpdf-11.6.3-r0 do_package_qa: Fatal QA errors were found, failing task.
> ERROR: Logfile of failure stored in:
> /mnt/b/yoe/master/build/tmp/work/core2-64-yoe-linux/qpdf/11.6.3/temp/log.do_package_qa.3501227
>
> On Tue, Nov 7, 2023 at 7:22 AM Leon Anavi<leon.anavi@konsulko.com>  wrote:
>> Update to version 11.6.3:
>>
>> - Fix a bug in which qpdf could potentially discard a character
>>    in a binary string if that character was preceded by an octal
>>    escaped string with fewer than three digits. This bug was
>>    introduced in the 11.0.0 release. The bug would not apply to
>>    content streams with default settings.
>> - The linearization specification precludes linearized files that
>>    require offets past the 4 GB mark. A bug in qpdf was preventing
>>    it from working when offsets had to pass the 2 GB mark. This has
>>    been corrected.
>>
>> Switch to cmake. Use /dev/random to perform encryption securely.
>> Change the fully defined path on the target to about buildpaths
>> QA issues with libqpdfTargets.cmake.
>>
>> This work was sponsored by GOVCERT.LU.
>>
>> Signed-off-by: Leon Anavi<leon.anavi@konsulko.com>
>> ---
>>   .../qpdf/{qpdf_10.6.3.bb => qpdf_11.6.3.bb}         | 13 ++++++++++---
>>   1 file changed, 10 insertions(+), 3 deletions(-)
>>   rename meta-oe/recipes-printing/qpdf/{qpdf_10.6.3.bb => qpdf_11.6.3.bb} (67%)
>>
>> diff --git a/meta-oe/recipes-printing/qpdf/qpdf_10.6.3.bb b/meta-oe/recipes-printing/qpdf/qpdf_11.6.3.bb
>> similarity index 67%
>> rename from meta-oe/recipes-printing/qpdf/qpdf_10.6.3.bb
>> rename to meta-oe/recipes-printing/qpdf/qpdf_11.6.3.bb
>> index fa33daf52..17a65acc6 100644
>> --- a/meta-oe/recipes-printing/qpdf/qpdf_10.6.3.bb
>> +++ b/meta-oe/recipes-printing/qpdf/qpdf_11.6.3.bb
>> @@ -2,14 +2,14 @@ DESCRIPTION = "PDF transformation/inspection software"
>>   HOMEPAGE ="http://qpdf.sourceforge.net"
>>   LICENSE = "Artistic-2.0"
>>   SECTION = "libs"
>> -DEPENDS = "libpcre zlib libjpeg-turbo"
>> +DEPENDS = "libpcre zlib libjpeg-turbo openssl"
>>
>>   SRC_URI = "${SOURCEFORGE_MIRROR}/qpdf/qpdf-${PV}.tar.gz"
>> -SRC_URI[sha256sum] = "e8fc23b2a584ea68c963a897515d3eb3129186741dd19d13c86d31fa33493811"
>> +SRC_URI[sha256sum] = "c394b1b0cff4cd9d13b0f5e16bdf3cf54da424dc434f9d40264b7fe67acd90bc"
>>
>>   LIC_FILES_CHKSUM ="file://Artistic-2.0;md5=7806296b9fae874361e6fb10072b7ee3"
>>
>> -inherit autotools-brokensep gettext
>> +inherit cmake gettext
>>
>>   # disable random file detection for cross-compile
>>   EXTRA_OECONF = "--without-random \
>> @@ -17,11 +17,18 @@ EXTRA_OECONF = "--without-random \
>>                   --disable-check-autofiles \
>>                   "
>>
>> +EXTRA_OECMAKE = '-DRANDOM_DEVICE="/dev/random"'
>> +
>>   LDFLAGS:append:mipsarch = " -latomic"
>>   LDFLAGS:append:riscv32 = " -latomic"
>>
>>   S="${WORKDIR}/${BPN}-${PV}"
>>
>> +do_install:append() {
>> +    # Change the fully defined path on the target
>> +    sed -i -e 's|${STAGING_LIBDIR}|${libdir}|g' ${D}${libdir}/cmake/${BPN}/libqpdfTargets.cmake
>> +}
>> +
>>   # avoid Makefile returning error on 'make clean' before configure was run
>>   CLEANBROKEN = "1"
>>
>> --
>> 2.39.2
>>
>>
>>
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#106465):https://lists.openembedded.org/g/openembedded-devel/message/106465
>> Mute This Topic:https://lists.openembedded.org/mt/102444518/2167311
>> Group Owner:openembedded-devel+owner@lists.openembedded.org
>> Unsubscribe:https://lists.openembedded.org/g/openembedded-devel/unsub  [leon.anavi@konsulko.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
Khem Raj Nov. 8, 2023, 3:50 p.m. UTC | #3
On Wed, Nov 8, 2023 at 2:53 AM Leon Anavi <leon.anavi@konsulko.com> wrote:
>
> Hi Khem,
>
> Thank you for the feedback.
>
> On 8.11.23 г. 9:08 ч., Khem Raj wrote:
>
> seeing this error
>
> WARNING: qpdf-11.6.3-r0 do_package_qa: QA Issue: File
> /usr/lib/cmake/qpdf/libqpdfTargets.cmake in package qpdf-dev contains
> reference to TMPDIR [bu
> ildpaths]
>
>
> The sed command in do_install:append should fix this warning. I also inspected to /usr/lib/cmake/qpdf/libqpdfTargets.cmake on the booted target device and the paths look OK. I am wondering why does this warning appear on your build setup?

the CI in this case uses usermerge distro feature and clang+lld to link.

>
> ERROR: qpdf-11.6.3-r0 do_package_qa: QA Issue:
> /usr/lib/libqpdf.so.29.6.3 contained in package libqpdf requires
> libgnutls.so.30(GNUTLS_3_4)(64bit),
>  but no providers found in RDEPENDS:libqpdf? [file-rdeps]
> ERROR: qpdf-11.6.3-r0 do_package_qa: QA Issue:
> /usr/lib/libqpdf.so.29.6.3 contained in package libqpdf requires
> libgnutls.so.30()(64bit), but no pr
> oviders found in RDEPENDS:libqpdf? [file-rdeps]
>
>
> I can't reproduce these errors on my side. Could you please provide any hints how to reproduce them?
>
> Best regards,
> Leon
>
> ERROR: qpdf-11.6.3-r0 do_package_qa: Fatal QA errors were found, failing task.
> ERROR: Logfile of failure stored in:
> /mnt/b/yoe/master/build/tmp/work/core2-64-yoe-linux/qpdf/11.6.3/temp/log.do_package_qa.3501227
>
> On Tue, Nov 7, 2023 at 7:22 AM Leon Anavi <leon.anavi@konsulko.com> wrote:
>
> Update to version 11.6.3:
>
> - Fix a bug in which qpdf could potentially discard a character
>   in a binary string if that character was preceded by an octal
>   escaped string with fewer than three digits. This bug was
>   introduced in the 11.0.0 release. The bug would not apply to
>   content streams with default settings.
> - The linearization specification precludes linearized files that
>   require offets past the 4 GB mark. A bug in qpdf was preventing
>   it from working when offsets had to pass the 2 GB mark. This has
>   been corrected.
>
> Switch to cmake. Use /dev/random to perform encryption securely.
> Change the fully defined path on the target to about buildpaths
> QA issues with libqpdfTargets.cmake.
>
> This work was sponsored by GOVCERT.LU.
>
> Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
> ---
>  .../qpdf/{qpdf_10.6.3.bb => qpdf_11.6.3.bb}         | 13 ++++++++++---
>  1 file changed, 10 insertions(+), 3 deletions(-)
>  rename meta-oe/recipes-printing/qpdf/{qpdf_10.6.3.bb => qpdf_11.6.3.bb} (67%)
>
> diff --git a/meta-oe/recipes-printing/qpdf/qpdf_10.6.3.bb b/meta-oe/recipes-printing/qpdf/qpdf_11.6.3.bb
> similarity index 67%
> rename from meta-oe/recipes-printing/qpdf/qpdf_10.6.3.bb
> rename to meta-oe/recipes-printing/qpdf/qpdf_11.6.3.bb
> index fa33daf52..17a65acc6 100644
> --- a/meta-oe/recipes-printing/qpdf/qpdf_10.6.3.bb
> +++ b/meta-oe/recipes-printing/qpdf/qpdf_11.6.3.bb
> @@ -2,14 +2,14 @@ DESCRIPTION = "PDF transformation/inspection software"
>  HOMEPAGE = "http://qpdf.sourceforge.net"
>  LICENSE = "Artistic-2.0"
>  SECTION = "libs"
> -DEPENDS = "libpcre zlib libjpeg-turbo"
> +DEPENDS = "libpcre zlib libjpeg-turbo openssl"
>
>  SRC_URI = "${SOURCEFORGE_MIRROR}/qpdf/qpdf-${PV}.tar.gz"
> -SRC_URI[sha256sum] = "e8fc23b2a584ea68c963a897515d3eb3129186741dd19d13c86d31fa33493811"
> +SRC_URI[sha256sum] = "c394b1b0cff4cd9d13b0f5e16bdf3cf54da424dc434f9d40264b7fe67acd90bc"
>
>  LIC_FILES_CHKSUM = "file://Artistic-2.0;md5=7806296b9fae874361e6fb10072b7ee3"
>
> -inherit autotools-brokensep gettext
> +inherit cmake gettext
>
>  # disable random file detection for cross-compile
>  EXTRA_OECONF = "--without-random \
> @@ -17,11 +17,18 @@ EXTRA_OECONF = "--without-random \
>                  --disable-check-autofiles \
>                  "
>
> +EXTRA_OECMAKE = '-DRANDOM_DEVICE="/dev/random"'
> +
>  LDFLAGS:append:mipsarch = " -latomic"
>  LDFLAGS:append:riscv32 = " -latomic"
>
>  S="${WORKDIR}/${BPN}-${PV}"
>
> +do_install:append() {
> +    # Change the fully defined path on the target
> +    sed -i -e 's|${STAGING_LIBDIR}|${libdir}|g' ${D}${libdir}/cmake/${BPN}/libqpdfTargets.cmake
> +}
> +
>  # avoid Makefile returning error on 'make clean' before configure was run
>  CLEANBROKEN = "1"
>
> --
> 2.39.2
>
>
>
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#106465): https://lists.openembedded.org/g/openembedded-devel/message/106465
> Mute This Topic: https://lists.openembedded.org/mt/102444518/2167311
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [leon.anavi@konsulko.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-printing/qpdf/qpdf_10.6.3.bb b/meta-oe/recipes-printing/qpdf/qpdf_11.6.3.bb
similarity index 67%
rename from meta-oe/recipes-printing/qpdf/qpdf_10.6.3.bb
rename to meta-oe/recipes-printing/qpdf/qpdf_11.6.3.bb
index fa33daf52..17a65acc6 100644
--- a/meta-oe/recipes-printing/qpdf/qpdf_10.6.3.bb
+++ b/meta-oe/recipes-printing/qpdf/qpdf_11.6.3.bb
@@ -2,14 +2,14 @@  DESCRIPTION = "PDF transformation/inspection software"
 HOMEPAGE = "http://qpdf.sourceforge.net"
 LICENSE = "Artistic-2.0"
 SECTION = "libs"
-DEPENDS = "libpcre zlib libjpeg-turbo"
+DEPENDS = "libpcre zlib libjpeg-turbo openssl"
 
 SRC_URI = "${SOURCEFORGE_MIRROR}/qpdf/qpdf-${PV}.tar.gz"
-SRC_URI[sha256sum] = "e8fc23b2a584ea68c963a897515d3eb3129186741dd19d13c86d31fa33493811"
+SRC_URI[sha256sum] = "c394b1b0cff4cd9d13b0f5e16bdf3cf54da424dc434f9d40264b7fe67acd90bc"
 
 LIC_FILES_CHKSUM = "file://Artistic-2.0;md5=7806296b9fae874361e6fb10072b7ee3"
 
-inherit autotools-brokensep gettext
+inherit cmake gettext
 
 # disable random file detection for cross-compile
 EXTRA_OECONF = "--without-random \
@@ -17,11 +17,18 @@  EXTRA_OECONF = "--without-random \
                 --disable-check-autofiles \
                 "
 
+EXTRA_OECMAKE = '-DRANDOM_DEVICE="/dev/random"'
+
 LDFLAGS:append:mipsarch = " -latomic"
 LDFLAGS:append:riscv32 = " -latomic"
 
 S="${WORKDIR}/${BPN}-${PV}"
 
+do_install:append() {
+    # Change the fully defined path on the target
+    sed -i -e 's|${STAGING_LIBDIR}|${libdir}|g' ${D}${libdir}/cmake/${BPN}/libqpdfTargets.cmake
+}
+
 # avoid Makefile returning error on 'make clean' before configure was run
 CLEANBROKEN = "1"