diff mbox series

[meta-python,3/3] python3-py7zr: add recipe

Message ID 20231106134623.11522-3-leon.anavi@konsulko.com
State Under Review
Headers show
Series [meta-python,1/3] python3-pybcj: add recipe | expand

Commit Message

Leon Anavi Nov. 6, 2023, 1:46 p.m. UTC
Add py7zr, a pure python 7-zip library. Version 0.20.7 with Python
3.12 support.

This work was sponsored by GOVCERT.LU.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../python/python3-py7zr_0.20.7.bb            | 29 +++++++++++++++++++
 1 file changed, 29 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-py7zr_0.20.7.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-py7zr_0.20.7.bb b/meta-python/recipes-devtools/python/python3-py7zr_0.20.7.bb
new file mode 100644
index 000000000..d919c4a0d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-py7zr_0.20.7.bb
@@ -0,0 +1,29 @@ 
+SUMMARY = "Pure Python 7-zip library"
+HOMEPAGE = "https://py7zr.readthedocs.io/en/latest/"
+LICENSE = "LGPL-2.1-or-later"
+SECTION = "devel/python"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4fbd65380cdd255951079008b364516c"
+
+SRC_URI[sha256sum] = "55aa587fb4586c920437f5d6e6595f228beddb321bfee3f5146bb15c2e8e74d5"
+
+inherit pypi python_setuptools_build_meta
+
+DEPENDS += " \
+    ${PYTHON_PN}-setuptools-scm-native \
+    ${PYTHON_PN}-toml-native \
+    ${PYTHON_PN}-wheel-native \
+"
+
+RDEPENDS:${PN} += "\
+    ${PYTHON_PN}-pycryptodomex \
+    ${PYTHON_PN}-multivolumefile \
+    ${PYTHON_PN}-pybcj \
+    ${PYTHON_PN}-inflate64 \
+    ${PYTHON_PN}-pyppmd \
+    ${PYTHON_PN}-pyzstd \
+    ${PYTHON_PN}-brotli \
+    ${PYTHON_PN}-multiprocessing \
+    ${PYTHON_PN}-datetime \
+    ${PYTHON_PN}-core \
+    ${PYTHON_PN}-threading \
+"