diff mbox series

[meta-python,3/4] python3-olefile: add recipe

Message ID 20231102140523.3337713-3-leon.anavi@konsulko.com
State Under Review
Headers show
Series [meta-python,1/4] python3-multivolumefile: add recipe | expand

Commit Message

Leon Anavi Nov. 2, 2023, 2:05 p.m. UTC
Add olefile, a package to parse, read and write Microsoft OLE2
files. Version 0.46 changelog:

- OleFileIO can now be used as a context manager (with...as), to
  close the file automatically (see doc).
- Improved handling of malformed files.
- Fixed several bugs.

This work was sponsored by GOVCERT.LU.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 .../python/python3-olefile_0.46.bb              | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-olefile_0.46.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-olefile_0.46.bb b/meta-python/recipes-devtools/python/python3-olefile_0.46.bb
new file mode 100644
index 000000000..e29f30f6f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-olefile_0.46.bb
@@ -0,0 +1,17 @@ 
+SUMMARY = "Python package to parse, read and write Microsoft OLE2 files"
+HOMEPAGE = "https://github.com/decalage2/olefile"
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e21a06208415d5eb2001555d37851362"
+
+SRC_URI[sha256sum] = "133b031eaf8fd2c9399b78b8bc5b8fcbe4c31e85295749bb17a87cba8f3c3964"
+
+inherit pypi setuptools3
+
+PYPI_PACKAGE = "olefile"
+PYPI_PACKAGE_EXT = "zip"
+
+RDEPENDS:${PN} += "\
+    ${PYTHON_PN}-core \
+    ${PYTHON_PN}-datetime \
+    ${PYTHON_PN}-logging \
+"