diff mbox series

wayland: consider pkgconfig sysroot for pkgdatadir

Message ID 20230930105454.197209-1-cordlandwehr@kde.org
State New
Headers show
Series wayland: consider pkgconfig sysroot for pkgdatadir | expand

Commit Message

Andreas Cord-Landwehr Sept. 30, 2023, 10:54 a.m. UTC
Fix pkgconfig find calls to find wayland protocol XML files.
See discussion in:
https://gitlab.freedesktop.org/wayland/wayland/-/merge_requests/102

Signed-off-by: Andreas Cord-Landwehr <cordlandwehr@kde.org>
---
 ...der-pkgconfig-sysroot-for-pkgdatadir.patch | 46 +++++++++++++++++++
 .../wayland/wayland_1.22.0.bb                 |  1 +
 2 files changed, 47 insertions(+)
 create mode 100644 meta/recipes-graphics/wayland/wayland/0002-Consider-pkgconfig-sysroot-for-pkgdatadir.patch

Comments

Khem Raj Sept. 30, 2023, 10:50 p.m. UTC | #1
Hi Andreas

Thanks for the patch, but since this component is part of core layer,
the patch for core layers should be sent to
openembedded-core@lists.openembedded.org see
https://docs.yoctoproject.org/contributor-guide/submit-changes.html#finding-a-suitable-mailing-list

On Sat, Sep 30, 2023 at 3:37 PM Andreas Cord-Landwehr
<cordlandwehr@kde.org> wrote:
>
> Fix pkgconfig find calls to find wayland protocol XML files.
> See discussion in:
> https://gitlab.freedesktop.org/wayland/wayland/-/merge_requests/102
>
> Signed-off-by: Andreas Cord-Landwehr <cordlandwehr@kde.org>
> ---
>  ...der-pkgconfig-sysroot-for-pkgdatadir.patch | 46 +++++++++++++++++++
>  .../wayland/wayland_1.22.0.bb                 |  1 +
>  2 files changed, 47 insertions(+)
>  create mode 100644 meta/recipes-graphics/wayland/wayland/0002-Consider-pkgconfig-sysroot-for-pkgdatadir.patch
>
> diff --git a/meta/recipes-graphics/wayland/wayland/0002-Consider-pkgconfig-sysroot-for-pkgdatadir.patch b/meta/recipes-graphics/wayland/wayland/0002-Consider-pkgconfig-sysroot-for-pkgdatadir.patch
> new file mode 100644
> index 0000000000..4573bb635a
> --- /dev/null
> +++ b/meta/recipes-graphics/wayland/wayland/0002-Consider-pkgconfig-sysroot-for-pkgdatadir.patch
> @@ -0,0 +1,46 @@
> +From ff8ecbe8891d592e645927659318720f9e190054 Mon Sep 17 00:00:00 2001
> +From: Andreas Cord-Landwehr <cordlandwehr@kde.org>
> +Date: Sun, 6 Feb 2022 17:23:46 +0100
> +Subject: [PATCH] Consider pkgconfig sysroot for pkgdatadir
> +
> +For libs/cflags this is done automatically, but not for manually accessed
> +variables. This matches what wayland-protocols does.
> +
> +Upstream-Status: Submitted [https://gitlab.freedesktop.org/wayland/wayland/-/merge_requests/272]
> +---
> + src/meson.build | 6 +++---
> + 1 file changed, 3 insertions(+), 3 deletions(-)
> +
> +diff --git a/src/meson.build b/src/meson.build
> +index a8a1d2b..721e151 100644
> +--- a/src/meson.build
> ++++ b/src/meson.build
> +@@ -65,7 +65,7 @@ if get_option('scanner')
> +               version: meson.project_version(),
> +               variables: [
> +                       'datarootdir=' + join_paths('${prefix}', get_option('datadir')),
> +-                      'pkgdatadir=' + join_paths('${datarootdir}', meson.project_name()),
> ++                      'pkgdatadir=' + join_paths('${pc_sysrootdir}${datarootdir}', meson.project_name()),
> +                       'bindir=' + join_paths('${prefix}', get_option('bindir')),
> +                       'wayland_scanner=${bindir}/wayland-scanner'
> +               ],
> +@@ -211,7 +211,7 @@ if get_option('libraries')
> +               filebase: 'wayland-server',
> +               variables: [
> +                       'datarootdir=' + join_paths('${prefix}', get_option('datadir')),
> +-                      'pkgdatadir=' + join_paths('${datarootdir}', meson.project_name())
> ++                      'pkgdatadir=' + join_paths('${pc_sysrootdir}${datarootdir}', meson.project_name())
> +               ]
> +       )
> +
> +@@ -250,7 +250,7 @@ if get_option('libraries')
> +               filebase: 'wayland-client',
> +               variables: [
> +                       'datarootdir=' + join_paths('${prefix}', get_option('datadir')),
> +-                      'pkgdatadir=' + join_paths('${datarootdir}', meson.project_name())
> ++                      'pkgdatadir=' + join_paths('${pc_sysrootdir}${datarootdir}', meson.project_name())
> +               ]
> +       )
> +
> +--
> +2.37.2
> diff --git a/meta/recipes-graphics/wayland/wayland_1.22.0.bb b/meta/recipes-graphics/wayland/wayland_1.22.0.bb
> index 26bad580eb..17e4a0cd98 100644
> --- a/meta/recipes-graphics/wayland/wayland_1.22.0.bb
> +++ b/meta/recipes-graphics/wayland/wayland_1.22.0.bb
> @@ -15,6 +15,7 @@ DEPENDS = "expat libffi wayland-native"
>  SRC_URI = "https://gitlab.freedesktop.org/wayland/wayland/-/releases/${PV}/downloads/${BPN}-${PV}.tar.xz \
>             file://run-ptest \
>             file://0001-build-Fix-strndup-detection-on-MinGW.patch \
> +           file://0002-Consider-pkgconfig-sysroot-for-pkgdatadir.patch \
>             "
>  SRC_URI[sha256sum] = "1540af1ea698a471c2d8e9d288332c7e0fd360c8f1d12936ebb7e7cbc2425842"
>
> --
> 2.39.2
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#105288): https://lists.openembedded.org/g/openembedded-devel/message/105288
> Mute This Topic: https://lists.openembedded.org/mt/101683693/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Andreas Cord-Landwehr Oct. 1, 2023, 10:26 a.m. UTC | #2
Hi Khem,

thank your for the hint! Will resent the patch to the correct list.

Best regards,
Andreas

On 01.10.23 00:50, Khem Raj wrote:
> Hi Andreas
> 
> Thanks for the patch, but since this component is part of core layer,
> the patch for core layers should be sent to
> openembedded-core@lists.openembedded.org see
> https://docs.yoctoproject.org/contributor-guide/submit-changes.html#finding-a-suitable-mailing-list
> 
> On Sat, Sep 30, 2023 at 3:37 PM Andreas Cord-Landwehr
> <cordlandwehr@kde.org> wrote:
>>
>> Fix pkgconfig find calls to find wayland protocol XML files.
>> See discussion in:
>> https://gitlab.freedesktop.org/wayland/wayland/-/merge_requests/102
>>
>> Signed-off-by: Andreas Cord-Landwehr <cordlandwehr@kde.org>
>> ---
>>   ...der-pkgconfig-sysroot-for-pkgdatadir.patch | 46 +++++++++++++++++++
>>   .../wayland/wayland_1.22.0.bb                 |  1 +
>>   2 files changed, 47 insertions(+)
>>   create mode 100644 meta/recipes-graphics/wayland/wayland/0002-Consider-pkgconfig-sysroot-for-pkgdatadir.patch
>>
>> diff --git a/meta/recipes-graphics/wayland/wayland/0002-Consider-pkgconfig-sysroot-for-pkgdatadir.patch b/meta/recipes-graphics/wayland/wayland/0002-Consider-pkgconfig-sysroot-for-pkgdatadir.patch
>> new file mode 100644
>> index 0000000000..4573bb635a
>> --- /dev/null
>> +++ b/meta/recipes-graphics/wayland/wayland/0002-Consider-pkgconfig-sysroot-for-pkgdatadir.patch
>> @@ -0,0 +1,46 @@
>> +From ff8ecbe8891d592e645927659318720f9e190054 Mon Sep 17 00:00:00 2001
>> +From: Andreas Cord-Landwehr <cordlandwehr@kde.org>
>> +Date: Sun, 6 Feb 2022 17:23:46 +0100
>> +Subject: [PATCH] Consider pkgconfig sysroot for pkgdatadir
>> +
>> +For libs/cflags this is done automatically, but not for manually accessed
>> +variables. This matches what wayland-protocols does.
>> +
>> +Upstream-Status: Submitted [https://gitlab.freedesktop.org/wayland/wayland/-/merge_requests/272]
>> +---
>> + src/meson.build | 6 +++---
>> + 1 file changed, 3 insertions(+), 3 deletions(-)
>> +
>> +diff --git a/src/meson.build b/src/meson.build
>> +index a8a1d2b..721e151 100644
>> +--- a/src/meson.build
>> ++++ b/src/meson.build
>> +@@ -65,7 +65,7 @@ if get_option('scanner')
>> +               version: meson.project_version(),
>> +               variables: [
>> +                       'datarootdir=' + join_paths('${prefix}', get_option('datadir')),
>> +-                      'pkgdatadir=' + join_paths('${datarootdir}', meson.project_name()),
>> ++                      'pkgdatadir=' + join_paths('${pc_sysrootdir}${datarootdir}', meson.project_name()),
>> +                       'bindir=' + join_paths('${prefix}', get_option('bindir')),
>> +                       'wayland_scanner=${bindir}/wayland-scanner'
>> +               ],
>> +@@ -211,7 +211,7 @@ if get_option('libraries')
>> +               filebase: 'wayland-server',
>> +               variables: [
>> +                       'datarootdir=' + join_paths('${prefix}', get_option('datadir')),
>> +-                      'pkgdatadir=' + join_paths('${datarootdir}', meson.project_name())
>> ++                      'pkgdatadir=' + join_paths('${pc_sysrootdir}${datarootdir}', meson.project_name())
>> +               ]
>> +       )
>> +
>> +@@ -250,7 +250,7 @@ if get_option('libraries')
>> +               filebase: 'wayland-client',
>> +               variables: [
>> +                       'datarootdir=' + join_paths('${prefix}', get_option('datadir')),
>> +-                      'pkgdatadir=' + join_paths('${datarootdir}', meson.project_name())
>> ++                      'pkgdatadir=' + join_paths('${pc_sysrootdir}${datarootdir}', meson.project_name())
>> +               ]
>> +       )
>> +
>> +--
>> +2.37.2
>> diff --git a/meta/recipes-graphics/wayland/wayland_1.22.0.bb b/meta/recipes-graphics/wayland/wayland_1.22.0.bb
>> index 26bad580eb..17e4a0cd98 100644
>> --- a/meta/recipes-graphics/wayland/wayland_1.22.0.bb
>> +++ b/meta/recipes-graphics/wayland/wayland_1.22.0.bb
>> @@ -15,6 +15,7 @@ DEPENDS = "expat libffi wayland-native"
>>   SRC_URI = "https://gitlab.freedesktop.org/wayland/wayland/-/releases/${PV}/downloads/${BPN}-${PV}.tar.xz \
>>              file://run-ptest \
>>              file://0001-build-Fix-strndup-detection-on-MinGW.patch \
>> +           file://0002-Consider-pkgconfig-sysroot-for-pkgdatadir.patch \
>>              "
>>   SRC_URI[sha256sum] = "1540af1ea698a471c2d8e9d288332c7e0fd360c8f1d12936ebb7e7cbc2425842"
>>
>> --
>> 2.39.2
>>
>>
>> 
>>
diff mbox series

Patch

diff --git a/meta/recipes-graphics/wayland/wayland/0002-Consider-pkgconfig-sysroot-for-pkgdatadir.patch b/meta/recipes-graphics/wayland/wayland/0002-Consider-pkgconfig-sysroot-for-pkgdatadir.patch
new file mode 100644
index 0000000000..4573bb635a
--- /dev/null
+++ b/meta/recipes-graphics/wayland/wayland/0002-Consider-pkgconfig-sysroot-for-pkgdatadir.patch
@@ -0,0 +1,46 @@ 
+From ff8ecbe8891d592e645927659318720f9e190054 Mon Sep 17 00:00:00 2001
+From: Andreas Cord-Landwehr <cordlandwehr@kde.org>
+Date: Sun, 6 Feb 2022 17:23:46 +0100
+Subject: [PATCH] Consider pkgconfig sysroot for pkgdatadir
+
+For libs/cflags this is done automatically, but not for manually accessed
+variables. This matches what wayland-protocols does.
+
+Upstream-Status: Submitted [https://gitlab.freedesktop.org/wayland/wayland/-/merge_requests/272]
+---
+ src/meson.build | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/meson.build b/src/meson.build
+index a8a1d2b..721e151 100644
+--- a/src/meson.build
++++ b/src/meson.build
+@@ -65,7 +65,7 @@ if get_option('scanner')
+ 		version: meson.project_version(),
+ 		variables: [
+ 			'datarootdir=' + join_paths('${prefix}', get_option('datadir')),
+-			'pkgdatadir=' + join_paths('${datarootdir}', meson.project_name()),
++			'pkgdatadir=' + join_paths('${pc_sysrootdir}${datarootdir}', meson.project_name()),
+ 			'bindir=' + join_paths('${prefix}', get_option('bindir')),
+ 			'wayland_scanner=${bindir}/wayland-scanner'
+ 		],
+@@ -211,7 +211,7 @@ if get_option('libraries')
+ 		filebase: 'wayland-server',
+ 		variables: [
+ 			'datarootdir=' + join_paths('${prefix}', get_option('datadir')),
+-			'pkgdatadir=' + join_paths('${datarootdir}', meson.project_name())
++			'pkgdatadir=' + join_paths('${pc_sysrootdir}${datarootdir}', meson.project_name())
+ 		]
+ 	)
+
+@@ -250,7 +250,7 @@ if get_option('libraries')
+ 		filebase: 'wayland-client',
+ 		variables: [
+ 			'datarootdir=' + join_paths('${prefix}', get_option('datadir')),
+-			'pkgdatadir=' + join_paths('${datarootdir}', meson.project_name())
++			'pkgdatadir=' + join_paths('${pc_sysrootdir}${datarootdir}', meson.project_name())
+ 		]
+ 	)
+
+--
+2.37.2
diff --git a/meta/recipes-graphics/wayland/wayland_1.22.0.bb b/meta/recipes-graphics/wayland/wayland_1.22.0.bb
index 26bad580eb..17e4a0cd98 100644
--- a/meta/recipes-graphics/wayland/wayland_1.22.0.bb
+++ b/meta/recipes-graphics/wayland/wayland_1.22.0.bb
@@ -15,6 +15,7 @@  DEPENDS = "expat libffi wayland-native"
 SRC_URI = "https://gitlab.freedesktop.org/wayland/wayland/-/releases/${PV}/downloads/${BPN}-${PV}.tar.xz \
            file://run-ptest \
            file://0001-build-Fix-strndup-detection-on-MinGW.patch \
+           file://0002-Consider-pkgconfig-sysroot-for-pkgdatadir.patch \
            "
 SRC_URI[sha256sum] = "1540af1ea698a471c2d8e9d288332c7e0fd360c8f1d12936ebb7e7cbc2425842"