diff mbox series

[meta-python] python3-parse-type: update version 0.5.2 -> 0.6.2

Message ID 20230929211912.2137840-1-derek@asterius.io
State Under Review
Headers show
Series [meta-python] python3-parse-type: update version 0.5.2 -> 0.6.2 | expand

Commit Message

Derek Straka Sept. 29, 2023, 9:19 p.m. UTC
Verify the license remains the same and update the checksum
Remove python-six runtime dependency

Signed-off-by: Derek Straka <derek@asterius.io>
---
 ...rse-type_0.5.2.bb => python3-parse-type_0.6.2.bb} | 12 +++---------
 1 file changed, 3 insertions(+), 9 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-parse-type_0.5.2.bb => python3-parse-type_0.6.2.bb} (51%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-parse-type_0.5.2.bb b/meta-python/recipes-devtools/python/python3-parse-type_0.6.2.bb
similarity index 51%
rename from meta-python/recipes-devtools/python/python3-parse-type_0.5.2.bb
rename to meta-python/recipes-devtools/python/python3-parse-type_0.6.2.bb
index 7eebbfb50..99493db32 100644
--- a/meta-python/recipes-devtools/python/python3-parse-type_0.5.2.bb
+++ b/meta-python/recipes-devtools/python/python3-parse-type_0.6.2.bb
@@ -1,15 +1,14 @@ 
 SUMMARY = "Simplifies building parse types based on the parse module"
 HOMEPAGE = "https://github.com/jenisys/parse_type"
 LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=16374dbaeaca1890153edb3f41371222"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=2e469278ace89c246d52505acc39c3da"
 
-SRC_URI[md5sum] = "b954062f14ab723a91fe1e2be15e859d"
-SRC_URI[sha256sum] = "7f690b18d35048c15438d6d0571f9045cffbec5907e0b1ccf006f889e3a38c0b"
+SRC_URI[sha256sum] = "79b1f2497060d0928bc46016793f1fca1057c4aacdf15ef876aa48d75a73a355"
 
 PYPI_PACKAGE = "parse_type"
 inherit pypi ptest setuptools3
 
-RDEPENDS:${PN} += "${PYTHON_PN}-parse ${PYTHON_PN}-six"
+RDEPENDS:${PN} += "${PYTHON_PN}-parse"
 
 SRC_URI += " \
 	file://run-ptest \
@@ -19,11 +18,6 @@  RDEPENDS:${PN}-ptest += " \
 	${PYTHON_PN}-pytest \
 "
 
-do_configure:prepend() {
-	sed -i -e "/python_version >= 3.0/d" ${S}/setup.py
-	sed -i -e "/use_2to3/d" ${S}/setup.py
-}
-
 do_install_ptest() {
 	install -d ${D}${PTEST_PATH}/tests
 	cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/