diff mbox series

[meta-python] python3-cachecontrol: Fix upstream check by specifying the UPSTREAM_CHECK_URI and UPSTREAM_CHECK_REGEX

Message ID 20230927051951.1695789-1-derek@asterius.io
State Under Review
Headers show
Series [meta-python] python3-cachecontrol: Fix upstream check by specifying the UPSTREAM_CHECK_URI and UPSTREAM_CHECK_REGEX | expand

Commit Message

Derek Straka Sept. 27, 2023, 5:19 a.m. UTC
Signed-off-by: Derek Straka <derek@asterius.io>
---
 .../recipes-devtools/python/python3-cachecontrol_0.13.1.bb     | 3 +++
 1 file changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-cachecontrol_0.13.1.bb b/meta-python/recipes-devtools/python/python3-cachecontrol_0.13.1.bb
index 535bac0e3..b4c90bcff 100644
--- a/meta-python/recipes-devtools/python/python3-cachecontrol_0.13.1.bb
+++ b/meta-python/recipes-devtools/python/python3-cachecontrol_0.13.1.bb
@@ -7,6 +7,9 @@  SRC_URI[sha256sum] = "f012366b79d2243a6118309ce73151bf52a38d4a5dac8ea57f09bd2908
 
 inherit pypi python_poetry_core
 
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/CacheControl/"
+UPSTREAM_CHECK_REGEX = "/CacheControl/(?P<pver>(\d+[\.\-_]*)+)"
+
 RDEPENDS:${PN} += "\
     python3-crypt \
     python3-datetime \