diff mbox series

[meta-python,1/2] python3-pymysql: Fix upstream check by specifying the UPSTREAM_CHECK_URI and UPSTREAM_CHECK_REGEX

Message ID 20230927040223.1628803-1-derek@asterius.io
State Under Review
Headers show
Series [meta-python,1/2] python3-pymysql: Fix upstream check by specifying the UPSTREAM_CHECK_URI and UPSTREAM_CHECK_REGEX | expand

Commit Message

Derek Straka Sept. 27, 2023, 4:02 a.m. UTC
Signed-off-by: Derek Straka <derek@asterius.io>
---
 meta-python/recipes-devtools/python/python3-pymysql_1.0.2.bb | 3 +++
 1 file changed, 3 insertions(+)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pymysql_1.0.2.bb b/meta-python/recipes-devtools/python/python3-pymysql_1.0.2.bb
index 1f6fbd3bb..062d7e7ea 100644
--- a/meta-python/recipes-devtools/python/python3-pymysql_1.0.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pymysql_1.0.2.bb
@@ -13,4 +13,7 @@  SRC_URI[sha256sum] = "816927a350f38d56072aeca5dfb10221fe1dc653745853d30a216637f5
 PYPI_PACKAGE = "PyMySQL"
 inherit pypi setuptools3
 
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/pymysql/"
+UPSTREAM_CHECK_REGEX = "/pymysql/(?P<pver>(\d+[\.\-_]*)+)"
+
 RDEPENDS:${PN} += "${PYTHON_PN}-cryptography"