diff mbox series

[meta-python] python3-pydantic: Update version 1.10.7 -> 2.4.1

Message ID 20230926220423.1601455-1-derek@asterius.io
State Under Review
Headers show
Series [meta-python] python3-pydantic: Update version 1.10.7 -> 2.4.1 | expand

Commit Message

Derek Straka Sept. 26, 2023, 10:04 p.m. UTC
Update build to use hatchling
Add dependency for README generation
Verify the license terms and update the checksum

Note from upstream
=======
Pydantic V2 is a ground-up rewrite that offers many new features, performance improvements, and some breaking changes compared to Pydantic V1.

If you're using Pydantic V1 you may want to look at the pydantic V1.10 Documentation or, 1.10.X-fixes git branch. Pydantic V2 also ships with the latest version of Pydantic V1 built in so that you can incrementally upgrade your code base and projects: from pydantic import v1 as pydantic_v1.

Signed-off-by: Derek Straka <derek@asterius.io>
---
 ...thon3-pydantic_1.10.7.bb => python3-pydantic_2.4.1.bb} | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-pydantic_1.10.7.bb => python3-pydantic_2.4.1.bb} (61%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pydantic_1.10.7.bb b/meta-python/recipes-devtools/python/python3-pydantic_2.4.1.bb
similarity index 61%
rename from meta-python/recipes-devtools/python/python3-pydantic_1.10.7.bb
rename to meta-python/recipes-devtools/python/python3-pydantic_2.4.1.bb
index 9d59cf859..6d06650eb 100644
--- a/meta-python/recipes-devtools/python/python3-pydantic_1.10.7.bb
+++ b/meta-python/recipes-devtools/python/python3-pydantic_2.4.1.bb
@@ -1,11 +1,13 @@ 
 SUMMARY = "Data validation and settings management using Python type hinting"
 HOMEPAGE = "https://github.com/samuelcolvin/pydantic"
 LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=2c02ea30650b91528657db64baea1757"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=09280955509d1c4ca14bae02f21d49a6"
 
-inherit pypi setuptools3
+inherit pypi python_hatchling
 
-SRC_URI[sha256sum] = "cfc83c0678b6ba51b0532bea66860617c4cd4251ecf76e9846fa5a9f3454e97e"
+SRC_URI[sha256sum] = "b172505886028e4356868d617d2d1a776d7af1625d1313450fd51bdd19d9d61f"
+
+DEPENDS += "python3-hatch-fancy-pypi-readme-native"
 
 RDEPENDS:${PN} += "\
     python3-core \