diff mbox series

[meta-python,3/6] Remove python3-license-expression

Message ID 20230925114142.2508458-4-samantha.jalabert@syslinbit.com
State Under Review
Headers show
Series Remove recipes | expand

Commit Message

Samantha Jalabert Sept. 25, 2023, 11:41 a.m. UTC
From: Samantha Jalabert <samantha.jalabert@syslinbit.com>

python3-license-expression recipe is moved to openembedded-core.

Signed-off-by: Marta Rybczynska <mrybczynska@syslinbit.com>
Signed-off-by: Samantha Jalabert <samantha.jalabert@syslinbit.com>
---
 .../python3-license-expression/run-ptest      |  3 --
 .../python3-license-expression_30.1.1.bb      | 36 -------------------
 2 files changed, 39 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-license-expression/run-ptest
 delete mode 100644 meta-python/recipes-devtools/python/python3-license-expression_30.1.1.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-license-expression/run-ptest b/meta-python/recipes-devtools/python/python3-license-expression/run-ptest
deleted file mode 100644
index 5cec711696..0000000000
--- a/meta-python/recipes-devtools/python/python3-license-expression/run-ptest
+++ /dev/null
@@ -1,3 +0,0 @@ 
-#!/bin/sh
-
-pytest
diff --git a/meta-python/recipes-devtools/python/python3-license-expression_30.1.1.bb b/meta-python/recipes-devtools/python/python3-license-expression_30.1.1.bb
deleted file mode 100644
index 31fb88d6e5..0000000000
--- a/meta-python/recipes-devtools/python/python3-license-expression_30.1.1.bb
+++ /dev/null
@@ -1,36 +0,0 @@ 
-SUMMARY = "Utility library to parse, compare, simplify and normalize license expressions"
-HOMEPAGE = "https://github.com/nexB/license-expression"
-
-LICENSE = "Apache-2.0"
-LIC_FILES_CHKSUM = "file://apache-2.0.LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
-
-SRC_URI[sha256sum] = "42375df653ad85e6f5b4b0385138b2dbea1f5d66360783d8625c3e4f97f11f0c"
-
-inherit pypi ptest python_setuptools_build_meta
-
-DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
-
-RDEPENDS:${PN} += "\
-    ${PYTHON_PN}-booleanpy \
-    ${PYTHON_PN}-core \
-    ${PYTHON_PN}-json \
-    ${PYTHON_PN}-stringold \
-    ${PYTHON_PN}-logging \
-"
-
-BBCLASSEXTEND = "native nativesdk"
-
-SRC_URI += " \
-	file://run-ptest \
-"
-
-RDEPENDS:${PN}-ptest += " \
-	${PYTHON_PN}-pytest \
-"
-
-do_install_ptest() {
-    install -d ${D}${PTEST_PATH}/tests
-    install -d ${D}${PTEST_PATH}/src
-    cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
-    cp -rf ${S}/src/* ${D}${PTEST_PATH}/src/
-}