diff mbox series

[meta-oe] bpftool: add native and nativesdk support

Message ID 20230901125653.1143552-1-dzagorui@cisco.com
State Under Review
Headers show
Series [meta-oe] bpftool: add native and nativesdk support | expand

Commit Message

Denys Zagorui Sept. 1, 2023, 12:56 p.m. UTC
There are issues with nativesdk variant
...
ERROR: nativesdk-bpftool-1.0-r0 do_package: QA Issue:
nativesdk-bpftool: Files/directories were installed but not shipped in any package:
  /usr/local/oe-sdk-hardcoded-buildpath/sysroots/x86_64-xesdk-linux/usr/sbin/bpftool
  /usr/share/bash-completion/completions/bpftool
...

nativesdk.bbclass sets sbindir = "${bindir}" but bpftool is installed under sbin
to fix that add sbin to FILES

for bpftool completions {prefix} is not used but it seems that bitbake expects that
installed files should be perfixed with "${SDKPATHNATIVE}${prefix_nativesdk}"
to fix that override bash_compdir

Signed-off-by: Denys Zagorui <dzagorui@cisco.com>
---
 meta-oe/recipes-kernel/bpftool/bpftool.bb | 5 +++++
 1 file changed, 5 insertions(+)
diff mbox series

Patch

diff --git a/meta-oe/recipes-kernel/bpftool/bpftool.bb b/meta-oe/recipes-kernel/bpftool/bpftool.bb
index bbfab47aa..317ec1926 100644
--- a/meta-oe/recipes-kernel/bpftool/bpftool.bb
+++ b/meta-oe/recipes-kernel/bpftool/bpftool.bb
@@ -18,6 +18,7 @@  EXTRA_OEMAKE = "\
     LD="${LD}" \
     AR=${AR} \
     ARCH=${ARCH} \
+    bash_compdir=${prefix}/share/bash-completion \
 "
 
 SECURITY_CFLAGS = ""
@@ -42,3 +43,7 @@  python do_package:prepend() {
 }
 
 B = "${WORKDIR}/${BPN}-${PV}"
+
+FILES:${PN} += "${exec_prefix}/sbin/*"
+
+BBCLASSEXTEND = "native nativesdk"