diff mbox series

[meta-python,2/2] python3-lz4: Add missing rdeps needed for ptests

Message ID 20230827002904.566500-2-raj.khem@gmail.com
State New
Headers show
Series [meta-python,1/2] python3-lz4: Drop using PYTHON_PN | expand

Commit Message

Khem Raj Aug. 27, 2023, 12:29 a.m. UTC
Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 meta-python/recipes-devtools/python/python3-lz4_4.3.2.bb | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-lz4_4.3.2.bb b/meta-python/recipes-devtools/python/python3-lz4_4.3.2.bb
index 2d6663fc86..9d31ab68c2 100644
--- a/meta-python/recipes-devtools/python/python3-lz4_4.3.2.bb
+++ b/meta-python/recipes-devtools/python/python3-lz4_4.3.2.bb
@@ -15,7 +15,14 @@  SRC_URI[sha256sum] = "e1431d84a9cfb23e6773e72078ce8e65cad6745816d4cbf9ae67da5ea4
 
 inherit pkgconfig pypi python_setuptools_build_meta ptest
 
-RDEPENDS:${PN}-ptest += "python3-pytest python3-multiprocessing python3-psutil"
+RDEPENDS:${PN}-ptest += "\
+    python3-coverage \
+    python3-pytest \
+    python3-pytest-cov \
+    python3-pytest-runner \
+    python3-multiprocessing \
+    python3-psutil \
+"
 
 do_install_ptest() {
     cp -rf ${S}/tests/ ${D}${PTEST_PATH}/