diff mbox series

[meta-oe,v3] libfaketime: add recipe

Message ID 20230823085310.339821-1-tymoteusz.burak@3mdeb.com
State Under Review
Headers show
Series [meta-oe,v3] libfaketime: add recipe | expand

Commit Message

Tymoteusz Burak Aug. 23, 2023, 8:53 a.m. UTC
This commit adds the libfaketime library recipe, which provides time
manipulation capabilities for testing and debugging purposes. libfaketime allows
developers to modify the system time reported to applications, aiding in scenarios
where accurate time emulation is required.

I deleted the extra flags altogether as they seem to be only necessary
for old versions of this project (0.9.6).

CC: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Tymoteusz Burak <tymoteusz.burak@3mdeb.com>
---
 .../libfaketime/libfaketime_0.9.10.bb         | 30 +++++++++++++++++++
 1 file changed, 30 insertions(+)
 create mode 100644 meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb

Comments

Khem Raj Aug. 24, 2023, 7:54 a.m. UTC | #1
fails to compile with clang

https://errors.yoctoproject.org/Errors/Details/732866/

-Wno-nonnull-compare seems to be not a portable option

On Wed, Aug 23, 2023 at 1:53 AM Tymoteusz Burak
<tymoteusz.burak@3mdeb.com> wrote:
>
> This commit adds the libfaketime library recipe, which provides time
> manipulation capabilities for testing and debugging purposes. libfaketime allows
> developers to modify the system time reported to applications, aiding in scenarios
> where accurate time emulation is required.
>
> I deleted the extra flags altogether as they seem to be only necessary
> for old versions of this project (0.9.6).
>
> CC: Khem Raj <raj.khem@gmail.com>
> Signed-off-by: Tymoteusz Burak <tymoteusz.burak@3mdeb.com>
> ---
>  .../libfaketime/libfaketime_0.9.10.bb         | 30 +++++++++++++++++++
>  1 file changed, 30 insertions(+)
>  create mode 100644 meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb
>
> diff --git a/meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb b/meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb
> new file mode 100644
> index 000000000000..7500e57658aa
> --- /dev/null
> +++ b/meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb
> @@ -0,0 +1,30 @@
> +DESCRIPTION = "A library for faking the system time in user-space programs"
> +SECTION = "libs"
> +LICENSE = "GPL-2.0-only"
> +LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
> +
> +SRCREV = "d475b925943ad404c6c728ac868dc73949e7281c"
> +SRC_URI = "\
> +    git://git@github.com/wolfcw/libfaketime.git;branch=master;protocol=https \
> +    "
> +
> +S = "${WORKDIR}/git"
> +
> +do_configure[noexec] = "1"
> +do_compile () {
> +    oe_runmake
> +}
> +do_install () {
> +    install -d ${D}${libdir}/faketime
> +    oe_libinstall -C src libfaketime ${D}${libdir}/faketime
> +    install -d ${D}${bindir}
> +    install -m 0755 src/faketime ${D}${bindir}
> +}
> +
> +PACKAGES =+ "lib${PN}"
> +
> +FILES:${PN} = "${bindir}/faketime"
> +FILES:lib${PN} = "${libdir}/faketime/*"
> +
> +INSANE_SKIP:${PN} += "dev-so"
> +INSANE_SKIP:lib${PN} += "dev-so"
> --
> 2.41.0
>
Tymoteusz Burak Aug. 31, 2023, 9:35 a.m. UTC | #2
Hello everyone,

I hope you're doing well. Your feedback is much appreciated, and I'd 
like to provide some context on a few matters.

I understand that there's a reported Clang build failure with the patch. 
I'd like to clarify that I don't currently have Clang configured on my 
workstation, and I'm not entirely familiar with the steps required to 
address this issue. If someone could provide guidance on how to 
investigate and resolve this specific problem, I'd be grateful. The 
libfaketime recipe I submitted is from a few projects ago, and it worked 
successfully when I tested it in a fresh project environment. I aimed to 
contribute this recipe to the OpenEmbedded layer to benefit the 
community. I apologize for any inconvenience the build failure might be 
causing and appreciate your assistance in ensuring the patch's 
compatibility.

ll happily review the RFC patch and adress other issues as i have to 
agree that the package name lib32-liblib32-libfaketime is quite ridiculous

Once again, thank you for your time and feedback. I look forward to your 
guidance and advice on how to proceed with resolving the issues raised.

Best regards, Tymoteusz Burak

On 8/24/23 09:54, Khem Raj wrote:
> fails to compile with clang
>
> https://errors.yoctoproject.org/Errors/Details/732866/
>
> -Wno-nonnull-compare seems to be not a portable option
>
> On Wed, Aug 23, 2023 at 1:53 AM Tymoteusz Burak
> <tymoteusz.burak@3mdeb.com> wrote:
>> This commit adds the libfaketime library recipe, which provides time
>> manipulation capabilities for testing and debugging purposes. libfaketime allows
>> developers to modify the system time reported to applications, aiding in scenarios
>> where accurate time emulation is required.
>>
>> I deleted the extra flags altogether as they seem to be only necessary
>> for old versions of this project (0.9.6).
>>
>> CC: Khem Raj <raj.khem@gmail.com>
>> Signed-off-by: Tymoteusz Burak <tymoteusz.burak@3mdeb.com>
>> ---
>>   .../libfaketime/libfaketime_0.9.10.bb         | 30 +++++++++++++++++++
>>   1 file changed, 30 insertions(+)
>>   create mode 100644 meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb
>>
>> diff --git a/meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb b/meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb
>> new file mode 100644
>> index 000000000000..7500e57658aa
>> --- /dev/null
>> +++ b/meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb
>> @@ -0,0 +1,30 @@
>> +DESCRIPTION = "A library for faking the system time in user-space programs"
>> +SECTION = "libs"
>> +LICENSE = "GPL-2.0-only"
>> +LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
>> +
>> +SRCREV = "d475b925943ad404c6c728ac868dc73949e7281c"
>> +SRC_URI = "\
>> +    git://git@github.com/wolfcw/libfaketime.git;branch=master;protocol=https \
>> +    "
>> +
>> +S = "${WORKDIR}/git"
>> +
>> +do_configure[noexec] = "1"
>> +do_compile () {
>> +    oe_runmake
>> +}
>> +do_install () {
>> +    install -d ${D}${libdir}/faketime
>> +    oe_libinstall -C src libfaketime ${D}${libdir}/faketime
>> +    install -d ${D}${bindir}
>> +    install -m 0755 src/faketime ${D}${bindir}
>> +}
>> +
>> +PACKAGES =+ "lib${PN}"
>> +
>> +FILES:${PN} = "${bindir}/faketime"
>> +FILES:lib${PN} = "${libdir}/faketime/*"
>> +
>> +INSANE_SKIP:${PN} += "dev-so"
>> +INSANE_SKIP:lib${PN} += "dev-so"
>> --
>> 2.41.0
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#104557): https://lists.openembedded.org/g/openembedded-devel/message/104557
>> Mute This Topic: https://lists.openembedded.org/mt/100911255/7790941
>> Group Owner: openembedded-devel+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [tymoteusz.burak@3mdeb.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
Khem Raj Aug. 31, 2023, 4:09 p.m. UTC | #3
On Thu, Aug 31, 2023 at 2:35 AM Tymoteusz Burak
<tymoteusz.burak@3mdeb.com> wrote:
>
> Hello everyone,
>
> I hope you're doing well. Your feedback is much appreciated, and I'd
> like to provide some context on a few matters.
>
> I understand that there's a reported Clang build failure with the patch.
> I'd like to clarify that I don't currently have Clang configured on my
> workstation, and I'm not entirely familiar with the steps required to
> address this issue. If someone could provide guidance on how to
> investigate and resolve this specific problem, I'd be grateful. The
> libfaketime recipe I submitted is from a few projects ago, and it worked
> successfully when I tested it in a fresh project environment. I aimed to
> contribute this recipe to the OpenEmbedded layer to benefit the
> community. I apologize for any inconvenience the build failure might be
> causing and appreciate your assistance in ensuring the patch's
> compatibility.

Thanks for your contribution. Although it had issues as reported, I went
ahead and fixed them myself, atleast for build matrix that I have including
clang issue. building with clang should be easier just include meta-clang
and follow the readme to enable it for your component under test.

https://github.com/yoedistro/meta-clang

obviously, it had more issues, as Martin figured out subsequently.

Usually when a patch is sent for upstream inclusion there are more
usecases users have that can bring out latent problems as seen here
I would expect you to keep this component in good shape from here
because getting it upstream is the first step, it follows up with
maintaining it in good shape for the rest of its life.

>
> ll happily review the RFC patch and adress other issues as i have to
> agree that the package name lib32-liblib32-libfaketime is quite ridiculous
>
> Once again, thank you for your time and feedback. I look forward to your
> guidance and advice on how to proceed with resolving the issues raised.
>
> Best regards, Tymoteusz Burak
>
> On 8/24/23 09:54, Khem Raj wrote:
> > fails to compile with clang
> >
> > https://errors.yoctoproject.org/Errors/Details/732866/
> >
> > -Wno-nonnull-compare seems to be not a portable option
> >
> > On Wed, Aug 23, 2023 at 1:53 AM Tymoteusz Burak
> > <tymoteusz.burak@3mdeb.com> wrote:
> >> This commit adds the libfaketime library recipe, which provides time
> >> manipulation capabilities for testing and debugging purposes. libfaketime allows
> >> developers to modify the system time reported to applications, aiding in scenarios
> >> where accurate time emulation is required.
> >>
> >> I deleted the extra flags altogether as they seem to be only necessary
> >> for old versions of this project (0.9.6).
> >>
> >> CC: Khem Raj <raj.khem@gmail.com>
> >> Signed-off-by: Tymoteusz Burak <tymoteusz.burak@3mdeb.com>
> >> ---
> >>   .../libfaketime/libfaketime_0.9.10.bb         | 30 +++++++++++++++++++
> >>   1 file changed, 30 insertions(+)
> >>   create mode 100644 meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb
> >>
> >> diff --git a/meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb b/meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb
> >> new file mode 100644
> >> index 000000000000..7500e57658aa
> >> --- /dev/null
> >> +++ b/meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb
> >> @@ -0,0 +1,30 @@
> >> +DESCRIPTION = "A library for faking the system time in user-space programs"
> >> +SECTION = "libs"
> >> +LICENSE = "GPL-2.0-only"
> >> +LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
> >> +
> >> +SRCREV = "d475b925943ad404c6c728ac868dc73949e7281c"
> >> +SRC_URI = "\
> >> +    git://git@github.com/wolfcw/libfaketime.git;branch=master;protocol=https \
> >> +    "
> >> +
> >> +S = "${WORKDIR}/git"
> >> +
> >> +do_configure[noexec] = "1"
> >> +do_compile () {
> >> +    oe_runmake
> >> +}
> >> +do_install () {
> >> +    install -d ${D}${libdir}/faketime
> >> +    oe_libinstall -C src libfaketime ${D}${libdir}/faketime
> >> +    install -d ${D}${bindir}
> >> +    install -m 0755 src/faketime ${D}${bindir}
> >> +}
> >> +
> >> +PACKAGES =+ "lib${PN}"
> >> +
> >> +FILES:${PN} = "${bindir}/faketime"
> >> +FILES:lib${PN} = "${libdir}/faketime/*"
> >> +
> >> +INSANE_SKIP:${PN} += "dev-so"
> >> +INSANE_SKIP:lib${PN} += "dev-so"
> >> --
> >> 2.41.0
> >>
> >>
> >>
> >>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104682): https://lists.openembedded.org/g/openembedded-devel/message/104682
> Mute This Topic: https://lists.openembedded.org/mt/100911255/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb b/meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb
new file mode 100644
index 000000000000..7500e57658aa
--- /dev/null
+++ b/meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb
@@ -0,0 +1,30 @@ 
+DESCRIPTION = "A library for faking the system time in user-space programs"
+SECTION = "libs"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRCREV = "d475b925943ad404c6c728ac868dc73949e7281c"
+SRC_URI = "\
+    git://git@github.com/wolfcw/libfaketime.git;branch=master;protocol=https \
+    "
+
+S = "${WORKDIR}/git"
+
+do_configure[noexec] = "1"
+do_compile () {
+    oe_runmake
+}
+do_install () {
+    install -d ${D}${libdir}/faketime
+    oe_libinstall -C src libfaketime ${D}${libdir}/faketime
+    install -d ${D}${bindir}
+    install -m 0755 src/faketime ${D}${bindir}
+}
+
+PACKAGES =+ "lib${PN}"
+
+FILES:${PN} = "${bindir}/faketime"
+FILES:lib${PN} = "${libdir}/faketime/*"
+
+INSANE_SKIP:${PN} += "dev-so"
+INSANE_SKIP:lib${PN} += "dev-so"