diff mbox series

[meta-oe] libfaketime: add recipe

Message ID 20230817084423.20928-1-tymoteusz.burak@3mdeb.com
State Under Review
Headers show
Series [meta-oe] libfaketime: add recipe | expand

Commit Message

Tymoteusz Burak Aug. 17, 2023, 8:44 a.m. UTC
This commit adds the libfaketime library recipe, which provides time
manipulation capabilities for testing and debugging purposes. libfaketime allows
developers to modify the system time reported to applications, aiding in scenarios
where accurate time emulation is required.

GitHub Repository: https://github.com/wolfcw/libfaketime

Signed-off-by: Tymoteusz Burak <tymoteusz.burak@3mdeb.com>
---
 .../recipes-test/libfaketime/libfaketime.bb   | 34 +++++++++++++++++++
 1 file changed, 34 insertions(+)
 create mode 100644 meta-oe/recipes-test/libfaketime/libfaketime.bb

Comments

Khem Raj Aug. 17, 2023, 9:53 p.m. UTC | #1
On Thu, Aug 17, 2023 at 1:45 AM Tymoteusz Burak
<tymoteusz.burak@3mdeb.com> wrote:
>
> This commit adds the libfaketime library recipe, which provides time
> manipulation capabilities for testing and debugging purposes. libfaketime allows
> developers to modify the system time reported to applications, aiding in scenarios
> where accurate time emulation is required.
>
> GitHub Repository: https://github.com/wolfcw/libfaketime
>
> Signed-off-by: Tymoteusz Burak <tymoteusz.burak@3mdeb.com>
> ---
>  .../recipes-test/libfaketime/libfaketime.bb   | 34 +++++++++++++++++++
>  1 file changed, 34 insertions(+)
>  create mode 100644 meta-oe/recipes-test/libfaketime/libfaketime.bb
>
> diff --git a/meta-oe/recipes-test/libfaketime/libfaketime.bb b/meta-oe/recipes-test/libfaketime/libfaketime.bb
> new file mode 100644
> index 000000000000..fadf9c432292
> --- /dev/null
> +++ b/meta-oe/recipes-test/libfaketime/libfaketime.bb
> @@ -0,0 +1,34 @@
> +DESCRIPTION = "A library for faking the system time in user-space programs"
> +SECTION = "libs"
> +LICENSE = "GPLv2"

Use SPDX string for LICENSE filed.

> +LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
> +PV = "v0.9.10"

Name the recipe libfaketime_0.9.10.bb and remove it here.

> +
> +SRC_URI = "\
> +    git://git@github.com/wolfcw/libfaketime.git;branch=master;tag=${PV};protocol=ssh \
> +    "

Please use https protocol.

> +
> +S = "${WORKDIR}/git"
> +
> +EXTRA_OEMAKE += "\
> +    EXTRA_FLAGS='-Wno-error=nonnull-compare' \
> +    "
> +
> +do_configure[noexec] = "1"
> +do_compile () {
> +    oe_runmake
> +}
> +do_install () {
> +    install -d ${D}${libdir}/faketime
> +    oe_libinstall -C src libfaketime ${D}${libdir}/faketime
> +    install -d ${D}${bindir}
> +    install -m 0755 src/faketime ${D}${bindir}
> +}
> +
> +PACKAGES =+ "lib${PN}"
> +
> +FILES:${PN} = "${bindir}/faketime"
> +FILES:lib${PN} = "${libdir}/faketime/*"
> +
> +INSANE_SKIP:${PN} += "dev-so"
> +INSANE_SKIP:lib${PN} += "dev-so"
> --
> 2.41.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104450): https://lists.openembedded.org/g/openembedded-devel/message/104450
> Mute This Topic: https://lists.openembedded.org/mt/100796818/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Khem Raj Aug. 17, 2023, 10 p.m. UTC | #2
On Thu, Aug 17, 2023 at 1:45 AM Tymoteusz Burak
<tymoteusz.burak@3mdeb.com> wrote:
>
> This commit adds the libfaketime library recipe, which provides time
> manipulation capabilities for testing and debugging purposes. libfaketime allows
> developers to modify the system time reported to applications, aiding in scenarios
> where accurate time emulation is required.
>
> GitHub Repository: https://github.com/wolfcw/libfaketime
>
> Signed-off-by: Tymoteusz Burak <tymoteusz.burak@3mdeb.com>
> ---
>  .../recipes-test/libfaketime/libfaketime.bb   | 34 +++++++++++++++++++
>  1 file changed, 34 insertions(+)
>  create mode 100644 meta-oe/recipes-test/libfaketime/libfaketime.bb
>
> diff --git a/meta-oe/recipes-test/libfaketime/libfaketime.bb b/meta-oe/recipes-test/libfaketime/libfaketime.bb
> new file mode 100644
> index 000000000000..fadf9c432292
> --- /dev/null
> +++ b/meta-oe/recipes-test/libfaketime/libfaketime.bb
> @@ -0,0 +1,34 @@
> +DESCRIPTION = "A library for faking the system time in user-space programs"
> +SECTION = "libs"
> +LICENSE = "GPLv2"
> +LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
> +PV = "v0.9.10"
> +
> +SRC_URI = "\
> +    git://git@github.com/wolfcw/libfaketime.git;branch=master;tag=${PV};protocol=ssh \

Also avoid using tag= in public recipes instead use SRCREV="<SHA1>"
which might correspond to a tag too

> +    "
> +
> +S = "${WORKDIR}/git"
> +
> +EXTRA_OEMAKE += "\
> +    EXTRA_FLAGS='-Wno-error=nonnull-compare' \
> +    "
> +
> +do_configure[noexec] = "1"
> +do_compile () {
> +    oe_runmake
> +}
> +do_install () {
> +    install -d ${D}${libdir}/faketime
> +    oe_libinstall -C src libfaketime ${D}${libdir}/faketime
> +    install -d ${D}${bindir}
> +    install -m 0755 src/faketime ${D}${bindir}
> +}
> +
> +PACKAGES =+ "lib${PN}"
> +
> +FILES:${PN} = "${bindir}/faketime"
> +FILES:lib${PN} = "${libdir}/faketime/*"
> +
> +INSANE_SKIP:${PN} += "dev-so"
> +INSANE_SKIP:lib${PN} += "dev-so"
> --
> 2.41.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104450): https://lists.openembedded.org/g/openembedded-devel/message/104450
> Mute This Topic: https://lists.openembedded.org/mt/100796818/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-test/libfaketime/libfaketime.bb b/meta-oe/recipes-test/libfaketime/libfaketime.bb
new file mode 100644
index 000000000000..fadf9c432292
--- /dev/null
+++ b/meta-oe/recipes-test/libfaketime/libfaketime.bb
@@ -0,0 +1,34 @@ 
+DESCRIPTION = "A library for faking the system time in user-space programs"
+SECTION = "libs"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+PV = "v0.9.10"
+
+SRC_URI = "\
+    git://git@github.com/wolfcw/libfaketime.git;branch=master;tag=${PV};protocol=ssh \
+    "
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE += "\
+    EXTRA_FLAGS='-Wno-error=nonnull-compare' \
+    "
+
+do_configure[noexec] = "1"
+do_compile () {
+    oe_runmake
+}
+do_install () {
+    install -d ${D}${libdir}/faketime
+    oe_libinstall -C src libfaketime ${D}${libdir}/faketime
+    install -d ${D}${bindir}
+    install -m 0755 src/faketime ${D}${bindir}
+}
+
+PACKAGES =+ "lib${PN}"
+
+FILES:${PN} = "${bindir}/faketime"
+FILES:lib${PN} = "${libdir}/faketime/*"
+
+INSANE_SKIP:${PN} += "dev-so"
+INSANE_SKIP:lib${PN} += "dev-so"