diff mbox series

[meta-oe,1/2] libnvme: add recipe

Message ID 20230725210925.158485-1-cvubrugier@fastmail.fm
State Superseded
Headers show
Series [meta-oe,1/2] libnvme: add recipe | expand

Commit Message

Christophe Vu-Brugier July 25, 2023, 9:09 p.m. UTC
From: Christophe Vu-Brugier <christophe.vu-brugier@seagate.com>

Signed-off-by: Christophe Vu-Brugier <christophe.vu-brugier@seagate.com>
---
 .../recipes-support/libnvme/libnvme_1.5.bb    | 20 +++++++++++++++++++
 1 file changed, 20 insertions(+)
 create mode 100644 meta-oe/recipes-support/libnvme/libnvme_1.5.bb

Comments

Khem Raj July 27, 2023, 5:21 a.m. UTC | #1
This fails to build python pieces see

https://errors.yoctoproject.org/Errors/Details/729064/

Something like below might helps fix it. Please test it out and resend
a v2 if it works for you.

diff --git a/meta-oe/recipes-support/libnvme/libnvme_1.5.bb
b/meta-oe/recipes-support/libnvme/libnvme_1.5.bb
index 607b055d81..2166ff677d 100644
--- a/meta-oe/recipes-support/libnvme/libnvme_1.5.bb
+++ b/meta-oe/recipes-support/libnvme/libnvme_1.5.bb
@@ -17,4 +17,6 @@ SRC_URI =
"git://github.com/linux-nvme/libnvme;protocol=https;branch=master"

 S = "${WORKDIR}/git"

-inherit meson pkgconfig
+inherit meson pkgconfig python3targetconfig
+
+FILES:${PN} += "${libdir}/${PYTHON_DIR}/site-packages/${BPN}"

On Tue, Jul 25, 2023 at 2:09 PM Christophe Vu-Brugier
<cvubrugier@fastmail.fm> wrote:
>
> From: Christophe Vu-Brugier <christophe.vu-brugier@seagate.com>
>
> Signed-off-by: Christophe Vu-Brugier <christophe.vu-brugier@seagate.com>
> ---
>  .../recipes-support/libnvme/libnvme_1.5.bb    | 20 +++++++++++++++++++
>  1 file changed, 20 insertions(+)
>  create mode 100644 meta-oe/recipes-support/libnvme/libnvme_1.5.bb
>
> diff --git a/meta-oe/recipes-support/libnvme/libnvme_1.5.bb b/meta-oe/recipes-support/libnvme/libnvme_1.5.bb
> new file mode 100644
> index 0000000000..607b055d81
> --- /dev/null
> +++ b/meta-oe/recipes-support/libnvme/libnvme_1.5.bb
> @@ -0,0 +1,20 @@
> +SUMMARY = "libnvme development C library"
> +DESCRIPTION = "\
> +libnvme provides type definitions for NVMe specification structures, \
> +enumerations, and bit fields, helper functions to construct, dispatch, \
> +and decode commands and payloads, and utilities to connect, scan, and \
> +manage nvme devices on a Linux system."
> +HOMEPAGE = "https://github.com/linux-nvme/${BPN}"
> +SECTION = "libs"
> +LICENSE = "LGPL-2.1-only & CC0-1.0 & MIT"
> +LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
> +                    file://ccan/licenses/CC0;md5=c17af43b05840255a6fedc5eda9d56cc \
> +                    file://ccan/licenses/BSD-MIT;md5=838c366f69b72c5df05c96dff79b35f2"
> +DEPENDS = "json-c"
> +SRCREV = "4fea83db8328ea788ea8f1001e8ce1cb80ef5fae"
> +
> +SRC_URI = "git://github.com/linux-nvme/libnvme;protocol=https;branch=master"
> +
> +S = "${WORKDIR}/git"
> +
> +inherit meson pkgconfig
> --
> 2.40.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104026): https://lists.openembedded.org/g/openembedded-devel/message/104026
> Mute This Topic: https://lists.openembedded.org/mt/100359101/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
diff mbox series

Patch

diff --git a/meta-oe/recipes-support/libnvme/libnvme_1.5.bb b/meta-oe/recipes-support/libnvme/libnvme_1.5.bb
new file mode 100644
index 0000000000..607b055d81
--- /dev/null
+++ b/meta-oe/recipes-support/libnvme/libnvme_1.5.bb
@@ -0,0 +1,20 @@ 
+SUMMARY = "libnvme development C library"
+DESCRIPTION = "\
+libnvme provides type definitions for NVMe specification structures, \
+enumerations, and bit fields, helper functions to construct, dispatch, \
+and decode commands and payloads, and utilities to connect, scan, and \
+manage nvme devices on a Linux system."
+HOMEPAGE = "https://github.com/linux-nvme/${BPN}"
+SECTION = "libs"
+LICENSE = "LGPL-2.1-only & CC0-1.0 & MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
+                    file://ccan/licenses/CC0;md5=c17af43b05840255a6fedc5eda9d56cc \
+                    file://ccan/licenses/BSD-MIT;md5=838c366f69b72c5df05c96dff79b35f2"
+DEPENDS = "json-c"
+SRCREV = "4fea83db8328ea788ea8f1001e8ce1cb80ef5fae"
+
+SRC_URI = "git://github.com/linux-nvme/libnvme;protocol=https;branch=master"
+
+S = "${WORKDIR}/git"
+
+inherit meson pkgconfig