diff mbox series

[meta-python,5/7] python3-pyaudio: upgrade 0.2.11 -> 0.2.13

Message ID 20230725190947.660933-5-tgamblin@baylibre.com
State New
Headers show
Series [meta-python,1/7] python3-fastjsonschema: upgrade 2.16.3 -> 2.18.0 | expand

Commit Message

Trevor Gamblin July 25, 2023, 7:09 p.m. UTC
License-Update: Move to LICENSE.txt

Changelog:

2022-12-26  Hubert Pham  <hubert@mit.edu>

  PyAudio 0.2.13

  * Move pyaudio.Stream to pyaudio.PyAudio.Stream.
    The pyaudio.Stream class is now pyaudio.PyAudio.Stream, nested under the
    existing pyaudio.PyAudio class. This should not affect existing code, as
    directly accessing the module-level pyaudio.Stream class has always been
    unsupported (use PyAudio.open instead). Accessing pyaudio.Stream
    directly is deprecated and will raise a DeprecationWarning.

  * Deprecate PaMacCoreStreamInfo's get_channel_map() and get_flags() methods.
    Use the channel_map and flags properties, respectively, instead. Also
    deprecates internal method _get_host_api_stream_object. Calling
    deprecated methods will raise a DeprecationWarning.

  * Package PyAudio as an actual package (directory).
    Previously, the library deployed a single pyaudio.py file and a C
    extension module to the root of site-packages. Now, the library deploys
    a Python package.

  * Add default shared library path for Homebrew installations on Apple Silicon.

  * Refactor and cleanup.
    - Refactor C extension for better maintainability.
    - Add more unit tests.
    - Update and modernize examples directory.
    - Improve C and python style conformance, plus many cosmetic updates.

2022-07-18  Hubert Pham  <hubert@mit.edu>

  PyAudio 0.2.12

  - Modernize build process for Microsoft Windows, using the native toolchain.

    Setuptool setup.py and INSTALL instructions are more streamlined.
    Building from Cygwin/MinGW is no longer supported nor tested.

    Thanks to Sean Zimmermann for the patches and general help!

  - Change default frames per buffer size to paFramesPerBufferUnspecified.

    Previously, pyaudio.py set a default frames per buffer size of 1024,
    which can lead to dropped frames on some systems.  Now, by default,
    PortAudio selects the buffer size based on host and latency
    requirements.

    Thanks to Jason Hihn for the suggestion!

  - Minor fixes and refactoring for compatibility with Python 3.7+.

    Updates include:
    * Remove call to deprecated PyEval_InitThreads() for Python 3.7+
    * Use Py_ssize_t types in appropriate places (for Python 3.10+).
    * Remove the min macro to ease compilation for Windows.

  - Use the locale's preferred encoding to decode device names.

    Thanks to Eiichi Takamori for the patch!

  - Unit tests: add skipIf decorators to skip tests that require hardware.

    Set the PYAUDIO_SKIP_HW_TESTS environment variable to disable tests that
    require sound hardware, useful for (automated) test environments without
    access to audio devices.

    Thanks to Matěj Cepl for the suggestion and patch!

  - Documentation, examples, and unit tests: various fixes.
    * Add more unit tests and repair a few that test the GIL on macOS.
    * Remove examples/error.py, which is redundant with tests/error_tests.py.
    * Fix type documentation of return value types in docstrings.

    Thanks to Vasily Zakharov for pointing out the return-value type errors!

  - Modernize packaging: add LICENSE.txt, pyproject.toml, and classifiers.

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 ...{python3-pyaudio_0.2.11.bb => python3-pyaudio_0.2.13.bb} | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-pyaudio_0.2.11.bb => python3-pyaudio_0.2.13.bb} (53%)

Comments

Khem Raj July 26, 2023, 2:55 p.m. UTC | #1
its failing for me

https://autobuilder.yoctoproject.org/typhoon/#/builders/88/builds/2933/steps/14/logs/stdio

If there is a quick fix that will be good, since its already escaped
into master, I will have to revert it otherwise.

On Tue, Jul 25, 2023 at 12:09 PM Trevor Gamblin <tgamblin@baylibre.com> wrote:
>
> License-Update: Move to LICENSE.txt
>
> Changelog:
>
> 2022-12-26  Hubert Pham  <hubert@mit.edu>
>
>   PyAudio 0.2.13
>
>   * Move pyaudio.Stream to pyaudio.PyAudio.Stream.
>     The pyaudio.Stream class is now pyaudio.PyAudio.Stream, nested under the
>     existing pyaudio.PyAudio class. This should not affect existing code, as
>     directly accessing the module-level pyaudio.Stream class has always been
>     unsupported (use PyAudio.open instead). Accessing pyaudio.Stream
>     directly is deprecated and will raise a DeprecationWarning.
>
>   * Deprecate PaMacCoreStreamInfo's get_channel_map() and get_flags() methods.
>     Use the channel_map and flags properties, respectively, instead. Also
>     deprecates internal method _get_host_api_stream_object. Calling
>     deprecated methods will raise a DeprecationWarning.
>
>   * Package PyAudio as an actual package (directory).
>     Previously, the library deployed a single pyaudio.py file and a C
>     extension module to the root of site-packages. Now, the library deploys
>     a Python package.
>
>   * Add default shared library path for Homebrew installations on Apple Silicon.
>
>   * Refactor and cleanup.
>     - Refactor C extension for better maintainability.
>     - Add more unit tests.
>     - Update and modernize examples directory.
>     - Improve C and python style conformance, plus many cosmetic updates.
>
> 2022-07-18  Hubert Pham  <hubert@mit.edu>
>
>   PyAudio 0.2.12
>
>   - Modernize build process for Microsoft Windows, using the native toolchain.
>
>     Setuptool setup.py and INSTALL instructions are more streamlined.
>     Building from Cygwin/MinGW is no longer supported nor tested.
>
>     Thanks to Sean Zimmermann for the patches and general help!
>
>   - Change default frames per buffer size to paFramesPerBufferUnspecified.
>
>     Previously, pyaudio.py set a default frames per buffer size of 1024,
>     which can lead to dropped frames on some systems.  Now, by default,
>     PortAudio selects the buffer size based on host and latency
>     requirements.
>
>     Thanks to Jason Hihn for the suggestion!
>
>   - Minor fixes and refactoring for compatibility with Python 3.7+.
>
>     Updates include:
>     * Remove call to deprecated PyEval_InitThreads() for Python 3.7+
>     * Use Py_ssize_t types in appropriate places (for Python 3.10+).
>     * Remove the min macro to ease compilation for Windows.
>
>   - Use the locale's preferred encoding to decode device names.
>
>     Thanks to Eiichi Takamori for the patch!
>
>   - Unit tests: add skipIf decorators to skip tests that require hardware.
>
>     Set the PYAUDIO_SKIP_HW_TESTS environment variable to disable tests that
>     require sound hardware, useful for (automated) test environments without
>     access to audio devices.
>
>     Thanks to Matěj Cepl for the suggestion and patch!
>
>   - Documentation, examples, and unit tests: various fixes.
>     * Add more unit tests and repair a few that test the GIL on macOS.
>     * Remove examples/error.py, which is redundant with tests/error_tests.py.
>     * Fix type documentation of return value types in docstrings.
>
>     Thanks to Vasily Zakharov for pointing out the return-value type errors!
>
>   - Modernize packaging: add LICENSE.txt, pyproject.toml, and classifiers.
>
> Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> ---
>  ...{python3-pyaudio_0.2.11.bb => python3-pyaudio_0.2.13.bb} | 6 +++---
>  1 file changed, 3 insertions(+), 3 deletions(-)
>  rename meta-python/recipes-devtools/python/{python3-pyaudio_0.2.11.bb => python3-pyaudio_0.2.13.bb} (53%)
>
> diff --git a/meta-python/recipes-devtools/python/python3-pyaudio_0.2.11.bb b/meta-python/recipes-devtools/python/python3-pyaudio_0.2.13.bb
> similarity index 53%
> rename from meta-python/recipes-devtools/python/python3-pyaudio_0.2.11.bb
> rename to meta-python/recipes-devtools/python/python3-pyaudio_0.2.13.bb
> index 802ca35100..dbeed9c2d8 100644
> --- a/meta-python/recipes-devtools/python/python3-pyaudio_0.2.11.bb
> +++ b/meta-python/recipes-devtools/python/python3-pyaudio_0.2.13.bb
> @@ -1,12 +1,12 @@
>  SUMMARY = "PyAudio provides Python bindings for PortAudio, the cross-platform audio I/O library"
>  SECTION = "devel/python"
>  LICENSE = "MIT"
> -LIC_FILES_CHKSUM = "file://README;md5=288793c2b9b05bd67abbd2a8f5d144f7"
> +LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7c3152b432b96d6dc4a1cb35397da9ec"
>
>  PYPI_PACKAGE = "PyAudio"
>
> -SRC_URI[md5sum] = "7e4c88139284033f67b4336c74eda3b8"
> -SRC_URI[sha256sum] = "93bfde30e0b64e63a46f2fd77e85c41fd51182a4a3413d9edfaf9ffaa26efb74"
> +SRC_URI[md5sum] = "41199ffd2abbdaf1ce6b88cf8af48cc5"
> +SRC_URI[sha256sum] = "26bccc81e4243d1c0ff5487e6b481de6329fcd65c79365c267cef38f363a2b56"
>
>  inherit pypi setuptools3
>
> --
> 2.41.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#104022): https://lists.openembedded.org/g/openembedded-devel/message/104022
> Mute This Topic: https://lists.openembedded.org/mt/100356782/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Trevor Gamblin July 26, 2023, 3:15 p.m. UTC | #2
On 2023-07-26 10:55, Khem Raj wrote:
> its failing for me
>
> https://autobuilder.yoctoproject.org/typhoon/#/builders/88/builds/2933/steps/14/logs/stdio
>
> If there is a quick fix that will be good, since its already escaped
> into master, I will have to revert it otherwise.

Go ahead and revert. I'm not able to reproduce this exact failure and 
switching to python_setuptools_build_meta causes extra issues. I'll 
resubmit once I've figured it out.

Thanks,

Trevor

>
> On Tue, Jul 25, 2023 at 12:09 PM Trevor Gamblin <tgamblin@baylibre.com> wrote:
>> License-Update: Move to LICENSE.txt
>>
>> Changelog:
>>
>> 2022-12-26  Hubert Pham  <hubert@mit.edu>
>>
>>    PyAudio 0.2.13
>>
>>    * Move pyaudio.Stream to pyaudio.PyAudio.Stream.
>>      The pyaudio.Stream class is now pyaudio.PyAudio.Stream, nested under the
>>      existing pyaudio.PyAudio class. This should not affect existing code, as
>>      directly accessing the module-level pyaudio.Stream class has always been
>>      unsupported (use PyAudio.open instead). Accessing pyaudio.Stream
>>      directly is deprecated and will raise a DeprecationWarning.
>>
>>    * Deprecate PaMacCoreStreamInfo's get_channel_map() and get_flags() methods.
>>      Use the channel_map and flags properties, respectively, instead. Also
>>      deprecates internal method _get_host_api_stream_object. Calling
>>      deprecated methods will raise a DeprecationWarning.
>>
>>    * Package PyAudio as an actual package (directory).
>>      Previously, the library deployed a single pyaudio.py file and a C
>>      extension module to the root of site-packages. Now, the library deploys
>>      a Python package.
>>
>>    * Add default shared library path for Homebrew installations on Apple Silicon.
>>
>>    * Refactor and cleanup.
>>      - Refactor C extension for better maintainability.
>>      - Add more unit tests.
>>      - Update and modernize examples directory.
>>      - Improve C and python style conformance, plus many cosmetic updates.
>>
>> 2022-07-18  Hubert Pham  <hubert@mit.edu>
>>
>>    PyAudio 0.2.12
>>
>>    - Modernize build process for Microsoft Windows, using the native toolchain.
>>
>>      Setuptool setup.py and INSTALL instructions are more streamlined.
>>      Building from Cygwin/MinGW is no longer supported nor tested.
>>
>>      Thanks to Sean Zimmermann for the patches and general help!
>>
>>    - Change default frames per buffer size to paFramesPerBufferUnspecified.
>>
>>      Previously, pyaudio.py set a default frames per buffer size of 1024,
>>      which can lead to dropped frames on some systems.  Now, by default,
>>      PortAudio selects the buffer size based on host and latency
>>      requirements.
>>
>>      Thanks to Jason Hihn for the suggestion!
>>
>>    - Minor fixes and refactoring for compatibility with Python 3.7+.
>>
>>      Updates include:
>>      * Remove call to deprecated PyEval_InitThreads() for Python 3.7+
>>      * Use Py_ssize_t types in appropriate places (for Python 3.10+).
>>      * Remove the min macro to ease compilation for Windows.
>>
>>    - Use the locale's preferred encoding to decode device names.
>>
>>      Thanks to Eiichi Takamori for the patch!
>>
>>    - Unit tests: add skipIf decorators to skip tests that require hardware.
>>
>>      Set the PYAUDIO_SKIP_HW_TESTS environment variable to disable tests that
>>      require sound hardware, useful for (automated) test environments without
>>      access to audio devices.
>>
>>      Thanks to Matěj Cepl for the suggestion and patch!
>>
>>    - Documentation, examples, and unit tests: various fixes.
>>      * Add more unit tests and repair a few that test the GIL on macOS.
>>      * Remove examples/error.py, which is redundant with tests/error_tests.py.
>>      * Fix type documentation of return value types in docstrings.
>>
>>      Thanks to Vasily Zakharov for pointing out the return-value type errors!
>>
>>    - Modernize packaging: add LICENSE.txt, pyproject.toml, and classifiers.
>>
>> Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
>> ---
>>   ...{python3-pyaudio_0.2.11.bb => python3-pyaudio_0.2.13.bb} | 6 +++---
>>   1 file changed, 3 insertions(+), 3 deletions(-)
>>   rename meta-python/recipes-devtools/python/{python3-pyaudio_0.2.11.bb => python3-pyaudio_0.2.13.bb} (53%)
>>
>> diff --git a/meta-python/recipes-devtools/python/python3-pyaudio_0.2.11.bb b/meta-python/recipes-devtools/python/python3-pyaudio_0.2.13.bb
>> similarity index 53%
>> rename from meta-python/recipes-devtools/python/python3-pyaudio_0.2.11.bb
>> rename to meta-python/recipes-devtools/python/python3-pyaudio_0.2.13.bb
>> index 802ca35100..dbeed9c2d8 100644
>> --- a/meta-python/recipes-devtools/python/python3-pyaudio_0.2.11.bb
>> +++ b/meta-python/recipes-devtools/python/python3-pyaudio_0.2.13.bb
>> @@ -1,12 +1,12 @@
>>   SUMMARY = "PyAudio provides Python bindings for PortAudio, the cross-platform audio I/O library"
>>   SECTION = "devel/python"
>>   LICENSE = "MIT"
>> -LIC_FILES_CHKSUM = "file://README;md5=288793c2b9b05bd67abbd2a8f5d144f7"
>> +LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7c3152b432b96d6dc4a1cb35397da9ec"
>>
>>   PYPI_PACKAGE = "PyAudio"
>>
>> -SRC_URI[md5sum] = "7e4c88139284033f67b4336c74eda3b8"
>> -SRC_URI[sha256sum] = "93bfde30e0b64e63a46f2fd77e85c41fd51182a4a3413d9edfaf9ffaa26efb74"
>> +SRC_URI[md5sum] = "41199ffd2abbdaf1ce6b88cf8af48cc5"
>> +SRC_URI[sha256sum] = "26bccc81e4243d1c0ff5487e6b481de6329fcd65c79365c267cef38f363a2b56"
>>
>>   inherit pypi setuptools3
>>
>> --
>> 2.41.0
>>
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#104022): https://lists.openembedded.org/g/openembedded-devel/message/104022
>> Mute This Topic: https://lists.openembedded.org/mt/100356782/1997914
>> Group Owner: openembedded-devel+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pyaudio_0.2.11.bb b/meta-python/recipes-devtools/python/python3-pyaudio_0.2.13.bb
similarity index 53%
rename from meta-python/recipes-devtools/python/python3-pyaudio_0.2.11.bb
rename to meta-python/recipes-devtools/python/python3-pyaudio_0.2.13.bb
index 802ca35100..dbeed9c2d8 100644
--- a/meta-python/recipes-devtools/python/python3-pyaudio_0.2.11.bb
+++ b/meta-python/recipes-devtools/python/python3-pyaudio_0.2.13.bb
@@ -1,12 +1,12 @@ 
 SUMMARY = "PyAudio provides Python bindings for PortAudio, the cross-platform audio I/O library"
 SECTION = "devel/python"
 LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://README;md5=288793c2b9b05bd67abbd2a8f5d144f7"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=7c3152b432b96d6dc4a1cb35397da9ec"
 
 PYPI_PACKAGE = "PyAudio"
 
-SRC_URI[md5sum] = "7e4c88139284033f67b4336c74eda3b8"
-SRC_URI[sha256sum] = "93bfde30e0b64e63a46f2fd77e85c41fd51182a4a3413d9edfaf9ffaa26efb74"
+SRC_URI[md5sum] = "41199ffd2abbdaf1ce6b88cf8af48cc5"
+SRC_URI[sha256sum] = "26bccc81e4243d1c0ff5487e6b481de6329fcd65c79365c267cef38f363a2b56"
 
 inherit pypi setuptools3