diff mbox series

[meta-python,3/5] python3-sh: upgrade 1.14.3 -> 2.0.4

Message ID 20230725141600.118138-3-tgamblin@baylibre.com
State Under Review
Headers show
Series [meta-python,1/5] python3-semver: upgrade 2.13.0 -> 3.0.1 | expand

Commit Message

Trevor Gamblin July 25, 2023, 2:15 p.m. UTC
- The project uses poetry now, so inherit python_poetry_core
- Add python3-asyncio and python3-compression to RDEPENDS

Changelog (https://github.com/amoffat/sh/blob/develop/CHANGELOG.md):

2.0.4 - 5/13/22

- Allow ok_code to be used with fg #665
- Make sure new_group never creates a new session #675

2.0.2 / 2.0.3 (misversioned) - 2/13/22

- Performance regression when using a generator with _in #650
- Adding test support for python 3.11

2.0.0 - 2/9/22

- Executed commands now return a unicode string by default
- Removed magical module-like execution contexts #636
- Added basic asyncio support via _async
- Dropped support for Python < 3.8
- Bumped default tty size to more standard (24, 80)
- First argument being a RunningCommand no longer automatically passes it as stdin
- RunningCommand.__eq__ no longer has the side effect of executing the command #518
- _tee now supports both "err" and "out" #215
- Removed the builtin override cd link
- Altered process launching model to behave more expectedly #495
- Bugfix where _no_out isn't allowed with _iter="err" #638
- Allow keyword arguments to have a list of values #529

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 .../python/{python3-sh_1.14.3.bb => python3-sh_2.0.4.bb}    | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-sh_1.14.3.bb => python3-sh_2.0.4.bb} (73%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-sh_1.14.3.bb b/meta-python/recipes-devtools/python/python3-sh_2.0.4.bb
similarity index 73%
rename from meta-python/recipes-devtools/python/python3-sh_1.14.3.bb
rename to meta-python/recipes-devtools/python/python3-sh_2.0.4.bb
index 317f648dcd..fa9f97a8f9 100644
--- a/meta-python/recipes-devtools/python/python3-sh_1.14.3.bb
+++ b/meta-python/recipes-devtools/python/python3-sh_2.0.4.bb
@@ -3,14 +3,16 @@  HOMEPAGE = "https://github.com/amoffat/sh"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5317094292296f03405f59ae5f6544b6"
 
-SRC_URI[sha256sum] = "e4045b6c732d9ce75d571c79f5ac2234edd9ae4f5fa9d59b09705082bdca18c7"
+SRC_URI[sha256sum] = "a18920f0839991bc9dfddb6dcc006c360b1064ba96257359f0ea356e9fa75a60"
 
 PYPI_PACKAGE = "sh"
 
-inherit pypi setuptools3
+inherit pypi python_poetry_core
 
 RDEPENDS:${PN} += " \
+    ${PYTHON_PN}-asyncio \
     ${PYTHON_PN}-codecs \
+    ${PYTHON_PN}-compression \
     ${PYTHON_PN}-core \
     ${PYTHON_PN}-io \
     ${PYTHON_PN}-logging \