diff mbox series

[meta-python] python3-rdflib: upgrade 6.2.0 -> 6.3.2

Message ID 20230724211544.399191-1-tgamblin@baylibre.com
State Under Review
Headers show
Series [meta-python] python3-rdflib: upgrade 6.2.0 -> 6.3.2 | expand

Commit Message

Trevor Gamblin July 24, 2023, 9:15 p.m. UTC
The LICENSE file's copyright year was updated, so the checksum changed.
rdflib now uses poetry as the backend, so switch from setuptools3.

Changelog: https://github.com/RDFLib/rdflib/releases

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 .../{python3-rdflib_6.2.0.bb => python3-rdflib_6.3.2.bb}    | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-rdflib_6.2.0.bb => python3-rdflib_6.3.2.bb} (63%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-rdflib_6.2.0.bb b/meta-python/recipes-devtools/python/python3-rdflib_6.3.2.bb
similarity index 63%
rename from meta-python/recipes-devtools/python/python3-rdflib_6.2.0.bb
rename to meta-python/recipes-devtools/python/python3-rdflib_6.3.2.bb
index 282d407090..1b4bb5a40e 100644
--- a/meta-python/recipes-devtools/python/python3-rdflib_6.2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-rdflib_6.3.2.bb
@@ -1,10 +1,10 @@ 
 SUMMARY = "RDFLib is a pure Python package for working with RDF"
 LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=bcae79bd3c84b857f42a98a7ccf6ad47"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=37d489c0cefe52a17e1d5007e196464a"
 
-SRC_URI[sha256sum] = "62dc3c86d1712db0f55785baf8047f63731fa59b2682be03219cb89262065942"
+SRC_URI[sha256sum] = "72af591ff704f4caacea7ecc0c5a9056b8553e0489dd4f35a9bc52dbd41522e0"
 
-inherit pypi setuptools3
+inherit pypi python_poetry_core
 
 RDEPENDS:${PN} += " \
     ${PYTHON_PN}-isodate \