diff mbox series

[meta-python,v2] python3-pandas: upgrade 1.5.3 -> 2.0.3

Message ID 20230724194426.246455-1-tgamblin@baylibre.com
State Under Review
Headers show
Series [meta-python,v2] python3-pandas: upgrade 1.5.3 -> 2.0.3 | expand

Commit Message

Trevor Gamblin July 24, 2023, 7:44 p.m. UTC
pandas now requires versioneer, so add that to the DEPENDS list. The
LICENSE checksum changed but this was due to line endings and not a
difference in content.

Changelog: https://github.com/pandas-dev/pandas/releases

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
v2 fixes the recipe name in the subject line and clarifies why the
LICENSE checksum changed.

 .../{python3-pandas_1.5.3.bb => python3-pandas_2.0.3.bb}  | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-pandas_1.5.3.bb => python3-pandas_2.0.3.bb} (77%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pandas_1.5.3.bb b/meta-python/recipes-devtools/python/python3-pandas_2.0.3.bb
similarity index 77%
rename from meta-python/recipes-devtools/python/python3-pandas_1.5.3.bb
rename to meta-python/recipes-devtools/python/python3-pandas_2.0.3.bb
index 129c3147cf..87a173c8a2 100644
--- a/meta-python/recipes-devtools/python/python3-pandas_1.5.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pandas_2.0.3.bb
@@ -4,14 +4,16 @@  high-performance, easy-to-use data structures and data analysis tools for \
 the Python programming language."
 HOMEPAGE = "http://pandas.pydata.org/"
 LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=c1cc9ab35a8b2aabf933cd6d245b5db3"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=cb819092901ddb13a7d0a4f5e05f098a"
 
-SRC_URI[sha256sum] = "74a3fd7e5a7ec052f183273dc7b0acd3a863edf7520f5d3a1765c04ffdb3b0b1"
+SRC_URI[sha256sum] = "c02f372a88e0d17f36d3093a644c73cfc1788e876a7c4bcb4020a77512e2043c"
 
 inherit pypi setuptools3
 
 DEPENDS += " \
-    ${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \
+    ${PYTHON_PN}-cython-native \
+    ${PYTHON_PN}-numpy-native \
+    ${PYTHON_PN}-versioneer-native \
 "
 
 PACKAGESPLITFUNCS =+ "fix_cythonized_sources"