diff mbox series

[meta-python,1/2] python3-versioneer: add recipe

Message ID 20230724175826.80617-1-tgamblin@baylibre.com
State Under Review
Headers show
Series [meta-python,1/2] python3-versioneer: add recipe | expand

Commit Message

Trevor Gamblin July 24, 2023, 5:58 p.m. UTC
This module is required by newer versions of pandas, so add it as a
recipe.

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 .../packagegroups/packagegroup-meta-python.bb  |  1 +
 .../python/python3-versioneer_0.29.bb          | 18 ++++++++++++++++++
 2 files changed, 19 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-versioneer_0.29.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index b23d24c6d4..9500f80e03 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -446,6 +446,7 @@  RDEPENDS:packagegroup-meta-python3 = "\
     python3-unidiff \
     python3-uritemplate \
     python3-vcversioner \
+    python3-versioneer \
     python3-versiontools \
     python3-visitor \
     python3-waitress \
diff --git a/meta-python/recipes-devtools/python/python3-versioneer_0.29.bb b/meta-python/recipes-devtools/python/python3-versioneer_0.29.bb
new file mode 100644
index 0000000000..bdfbfd1be1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-versioneer_0.29.bb
@@ -0,0 +1,18 @@ 
+SUMMARY = "Easy VCS-based management of project version strings"
+HOMEPAGE = "https://github.com/python-versioneer/python-versioneer"
+SECTION = "devel/python"
+
+LICENSE = "Unlicense"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=f4c62131f879a8445e16a7f265aea635"
+
+SRC_URI[sha256sum] = "5ab283b9857211d61b53318b7c792cf68e798e765ee17c27ade9f6c924235731"
+
+inherit pypi python_setuptools_build_meta
+
+RDEPENDS:${PN} += "\
+    python3-json \
+    python3-netclient \
+    python3-tomllib \
+"
+
+BBCLASSEXTEND = "native nativesdk"