diff mbox series

[meta-python,2/2] python3-mypy, python3-mypy-extensions: remove

Message ID 20230724165113.2925-2-tgamblin@baylibre.com
State New
Headers show
Series [meta-python,1/2] python3-humanize: upgrade 4.4.0 -> 4.7.0 | expand

Commit Message

Trevor Gamblin July 24, 2023, 4:51 p.m. UTC
While attempting to upgrade mypy and mypy-extensions, it was discovered
that it depends on new modules, some of which have no maintenance plan
in place, e.g.: https://pypi.org/project/types-typed-ast/

Since this is something we want to avoid adding to the ecosystem and
mypy isn't a dependency for anything else in meta-python, remove the
recipes.

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 .../python/python3-mypy-extensions_0.4.3.bb   | 12 ----------
 .../python/python3-mypy_0.971.bb              | 23 -------------------
 2 files changed, 35 deletions(-)
 delete mode 100644 meta-python/recipes-devtools/python/python3-mypy-extensions_0.4.3.bb
 delete mode 100644 meta-python/recipes-devtools/python/python3-mypy_0.971.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-mypy-extensions_0.4.3.bb b/meta-python/recipes-devtools/python/python3-mypy-extensions_0.4.3.bb
deleted file mode 100644
index 83ac5362d6..0000000000
--- a/meta-python/recipes-devtools/python/python3-mypy-extensions_0.4.3.bb
+++ /dev/null
@@ -1,12 +0,0 @@ 
-SUMMARY = "Experimental type system extensions for programs checked with the mypy typechecker"
-HOMEPAGE = "https://github.com/python/mypy_extensions"
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=0fe3219e2470a78c0d1837019b8b426e"
-
-PYPI_PACKAGE = "mypy_extensions"
-
-inherit pypi setuptools3
-
-SRC_URI[sha256sum] = "2d82818f5bb3e369420cb3c4060a7970edba416647068eb4c5343488a6c604a8"
-
-BBCLASSEXTEND = "native"
diff --git a/meta-python/recipes-devtools/python/python3-mypy_0.971.bb b/meta-python/recipes-devtools/python/python3-mypy_0.971.bb
deleted file mode 100644
index 31fcb06c9e..0000000000
--- a/meta-python/recipes-devtools/python/python3-mypy_0.971.bb
+++ /dev/null
@@ -1,23 +0,0 @@ 
-SUMMARY = "Optional static typing for Python 3 and 2 (PEP 484)"
-HOMEPAGE = "https://github.com/python/mypy"
-LICENSE = "MIT & Python-2.0"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=6ba8ec528da02073b7e1f4124c0f836f"
-
-PYPI_PACKAGE = "mypy"
-
-inherit pypi python_setuptools_build_meta
-
-SRC_URI[sha256sum] = "40b0f21484238269ae6a57200c807d80debc6459d444c0489a102d7c6a75fa56"
-
-BBCLASSEXTEND = "native"
-
-RDEPENDS:${PN} += " \
-    ${PYTHON_PN}-mypy-extensions \
-    ${PYTHON_PN}-typed-ast \
-    ${PYTHON_PN}-typing-extensions \
-    ${PYTHON_PN}-json \
-    ${PYTHON_PN}-compression \
-    ${PYTHON_PN}-pprint \
-    ${PYTHON_PN}-difflib \
-    ${PYTHON_PN}-toml \
-"