diff mbox series

[meta-python] python3-greenstalk: upgrade 2.0.0 -> 2.0.2

Message ID 20230721203825.2557064-1-tgamblin@baylibre.com
State Under Review
Headers show
Series [meta-python] python3-greenstalk: upgrade 2.0.0 -> 2.0.2 | expand

Commit Message

Trevor Gamblin July 21, 2023, 8:38 p.m. UTC
Switch to python_setuptools_build_meta.

No changelog provided Commit history:

a4643c4 (HEAD -> main, tag: v2.0.2, origin/main, origin/HEAD) Release 2.0.2
87269f0 Remove redundant wheel dep from pyproject.toml
e30d3c4 (tag: v2.0.1) Release 2.0.1
36b348a Require a current version of Python
e189f4b Revert breaking API changes
868e9d0 Format with Black
5f4f424 Strip quotes from string stats
a31ad74 Add __repr__ to Job and Client
ebbb0f2 Improve names of private parsing functions
3ff9ef1 Use phony targets in Makefile
4feaf07 Format with Black
2c9165f Add test for drain mode
5068dc2 Enable strict mode in mypy
383176c Add type hints to integration test decorator
6fb0a48 Polish documentation
e8c5f20 Fix reportUnknownVariableType Pylance warnings
e7ac1da Polish API reference
9a384a8 Remove __slots__ from Job
45c53b4 Polish error handling
4f79e7c Document and type hint Job attributes
0f576a0 Remove sphinx-autodoc-typehints dev dependency
29a5499 Always use bytes for job bodies
3dc6430 Make it clear the requirements are for development
db496d5 Add command for building HTML docs
da73ed0 Fix Sphinx import path
c93efc0 Update link after changing default branch to main
7fc7eef Add PEP 561 py.typed marker file
5174142 Switch to package directory structure
40a9149 Add python_requires
18196e2 Add project_urls
59e3f99 Avoid installing unnecessary dependencies on CI
764f5bf Stop checking code coverage by default
45de080 Remove Codecov integration
1f0baf6 Specify license with license_files
74cad3b Switch to declarative package configuration
9e6aebb Remove unused Flake8 ignore
48cecff Use variable annotation syntax
56387c8 Drop support for Python 3.5
62e4bbf Update CI to only send one coverage report
d168cff Move CI to GitHub Actions
6281716 Add 3.9 to list of supported Python versions

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 ...thon3-greenstalk_2.0.0.bb => python3-greenstalk_2.0.2.bb} | 5 ++---
 1 file changed, 2 insertions(+), 3 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-greenstalk_2.0.0.bb => python3-greenstalk_2.0.2.bb} (65%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-greenstalk_2.0.0.bb b/meta-python/recipes-devtools/python/python3-greenstalk_2.0.2.bb
similarity index 65%
rename from meta-python/recipes-devtools/python/python3-greenstalk_2.0.0.bb
rename to meta-python/recipes-devtools/python/python3-greenstalk_2.0.2.bb
index 841b84ddf6..33eb62d5d9 100644
--- a/meta-python/recipes-devtools/python/python3-greenstalk_2.0.0.bb
+++ b/meta-python/recipes-devtools/python/python3-greenstalk_2.0.2.bb
@@ -3,9 +3,8 @@  HOMEPAGE = "https://github.com/mayhewj/greenstalk"
 LICENSE = "MIT"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=8f98432ba1fce3933c556430fd47298f"
 
-SRC_URI[sha256sum] = "0020970abdb6f400586938573cbbec80410e83805d61e46cf76ea3ed71129257"
+SRC_URI[sha256sum] = "3ebde5fc9ecf986f96f6779fd6d15a53f33d432c52a2e28012e100a99ee154a4"
 
 RDEPENDS:${PN} += "python3-io python3-core"
 
-inherit pypi
-inherit setuptools3
+inherit pypi python_setuptools_build_meta