diff mbox series

[meta-python,1/2] python3-django: upgrade 4.2.2 -> 4.2.3

Message ID 20230718150055.2501513-1-tgamblin@baylibre.com
State Under Review
Headers show
Series [meta-python,1/2] python3-django: upgrade 4.2.2 -> 4.2.3 | expand

Commit Message

Trevor Gamblin July 18, 2023, 3 p.m. UTC
Changelog: https://docs.djangoproject.com/en/4.2/releases/4.2.3/

Django 4.2.3 fixes a security issue with severity “moderate” and several
bugs in 4.2.2.

CVE-2023-36053: Potential regular expression denial of service
vulnerability in EmailValidator/URLValidator

EmailValidator and URLValidator were subject to potential regular
expression denial of service attack via a very large number of domain
name labels of emails and URLs.

Bugfixes

- Fixed a regression in Django 4.2 that caused incorrect alignment of
timezone warnings for DateField and TimeField in the admin (#34645).
- Fixed a regression in Django 4.2 that caused incorrect highlighting of
rows in the admin changelist view when ModelAdmin.list_editable
contained a BooleanField (#34638).

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 .../python/{python3-django_4.2.2.bb => python3-django_4.2.3.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-django_4.2.2.bb => python3-django_4.2.3.bb} (58%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-django_4.2.2.bb b/meta-python/recipes-devtools/python/python3-django_4.2.3.bb
similarity index 58%
rename from meta-python/recipes-devtools/python/python3-django_4.2.2.bb
rename to meta-python/recipes-devtools/python/python3-django_4.2.3.bb
index da65eb9c32..4e3192744e 100644
--- a/meta-python/recipes-devtools/python/python3-django_4.2.2.bb
+++ b/meta-python/recipes-devtools/python/python3-django_4.2.3.bb
@@ -1,7 +1,7 @@ 
 require python-django.inc
 inherit setuptools3
 
-SRC_URI[sha256sum] = "2a6b6fbff5b59dd07bef10bcb019bee2ea97a30b2a656d51346596724324badf"
+SRC_URI[sha256sum] = "45a747e1c5b3d6df1b141b1481e193b033fd1fdbda3ff52677dc81afdaacbaed"
 
 RDEPENDS:${PN} += "\
     ${PYTHON_PN}-sqlparse \