diff mbox series

[meta-python,8/9] python3-bandit: add python3-rich to RDEPENDS

Message ID 20230717152032.3161667-8-tgamblin@baylibre.com
State New
Headers show
Series [meta-python,1/9] python3-alembic: upgrade 1.10.4 -> 1.11.1 | expand

Commit Message

Trevor Gamblin July 17, 2023, 3:20 p.m. UTC
bandit wasn't imported properly without the rich module, so add it.

Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 .../recipes-devtools/python/python3-bandit_1.7.5.bb    | 10 +++++++++-
 1 file changed, 9 insertions(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-bandit_1.7.5.bb b/meta-python/recipes-devtools/python/python3-bandit_1.7.5.bb
index 5e2a7e8bc5..bccdf284e5 100644
--- a/meta-python/recipes-devtools/python/python3-bandit_1.7.5.bb
+++ b/meta-python/recipes-devtools/python/python3-bandit_1.7.5.bb
@@ -8,6 +8,14 @@  DEPENDS = "python3-pbr-native python3-git python3-pbr python3-pyyaml python3-six
 
 inherit setuptools3 pypi
 
-RDEPENDS:${PN} += "python3-modules python3-git python3-pbr python3-pyyaml python3-six python3-stevedore"
+RDEPENDS:${PN} += "\
+        python3-git \
+        python3-modules \
+        python3-pbr \
+        python3-pyyaml \
+        python3-rich \
+        python3-six \
+        python3-stevedore \
+        "
 
 BBCLASSEXTEND = "native"