diff mbox series

[meta-python,3/5] python3-virtualenv: Add initial recipe 20.23.0

Message ID 20230626114533.221953-3-jasper@fancydomain.eu
State Under Review
Headers show
Series [meta-python,1/5] python3-distlib: Add initial recipe 0.3.6 | expand

Commit Message

Jasper Orschulko June 26, 2023, 11:45 a.m. UTC
Dependency for python3-tox

Signed-off-by: Jasper Orschulko <jasper@fancydomain.eu>
---
 .../python/python3-virtualenv_20.23.0.bb      | 22 +++++++++++++++++++
 1 file changed, 22 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-virtualenv_20.23.0.bb
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-virtualenv_20.23.0.bb b/meta-python/recipes-devtools/python/python3-virtualenv_20.23.0.bb
new file mode 100644
index 0000000000..38487488a9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-virtualenv_20.23.0.bb
@@ -0,0 +1,22 @@ 
+# SPDX-License-Identifier: MIT
+# Copyright (C) 2023 iris-GmbH infrared & intelligent sensors
+
+SUMMARY = "A tool for creating isolated virtual python environments."
+HOMEPAGE = "https://github.com/pypa/virtualenv"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=0ce089158cf60a8ab6abb452b6405538"
+
+SRC_URI[sha256sum] = "a85caa554ced0c0afbd0d638e7e2d7b5f92d23478d05d17a76daeac8f279f924"
+
+BBCLASSEXTEND = "native nativesdk"
+inherit pypi python_hatchling
+
+DEPENDS += "\
+    ${PYTHON_PN}-hatch-vcs-native \
+"
+
+RDEPENDS:${PN} += " \
+    ${PYTHON_PN}-distlib \
+    ${PYTHON_PN}-filelock \
+    ${PYTHON_PN}-platformdirs \
+"