diff mbox series

[meta-python,1/6] python3-platformdirs: Add recipe

Message ID 20230502165005.880470-2-tgamblin@baylibre.com
State Under Review
Headers show
Series Support updated python3-pylint | expand

Commit Message

Trevor Gamblin May 2, 2023, 4:50 p.m. UTC
Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
---
 .../python/python3-platformdirs/run-ptest     |  3 ++
 .../python/python3-platformdirs_3.5.0.bb      | 35 +++++++++++++++++++
 2 files changed, 38 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
 create mode 100644 meta-python/recipes-devtools/python/python3-platformdirs_3.5.0.bb

Comments

Khem Raj May 2, 2023, 9:46 p.m. UTC | #1
I think it needs python3-hatchling or native variant of this. It fails to build

| ERROR Missing dependencies:
|       hatchling>=1.14

On Tue, May 2, 2023 at 9:50 AM Trevor Gamblin <tgamblin@baylibre.com> wrote:
>
> Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> ---
>  .../python/python3-platformdirs/run-ptest     |  3 ++
>  .../python/python3-platformdirs_3.5.0.bb      | 35 +++++++++++++++++++
>  2 files changed, 38 insertions(+)
>  create mode 100644 meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
>  create mode 100644 meta-python/recipes-devtools/python/python3-platformdirs_3.5.0.bb
>
> diff --git a/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest b/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
> new file mode 100644
> index 000000000..b63c4de0d
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
> @@ -0,0 +1,3 @@
> +#!/bin/sh
> +
> +pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
> diff --git a/meta-python/recipes-devtools/python/python3-platformdirs_3.5.0.bb b/meta-python/recipes-devtools/python/python3-platformdirs_3.5.0.bb
> new file mode 100644
> index 000000000..b5ff369d0
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/python3-platformdirs_3.5.0.bb
> @@ -0,0 +1,35 @@
> +SUMMARY = "A small Python module for determining appropriate platform-specific dirs"
> +HOMEPAGE = "https://github.com/platformdirs/platformdirs"
> +LICENSE = "BSD-3-Clause"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=ea4f5a41454746a9ed111e3d8723d17a"
> +
> +SRC_URI = " \
> +    git://github.com/platformdirs/platformdirs.git;branch=main;protocol=https \
> +    file://run-ptest \
> +"
> +
> +SRCREV ?= "dcb56802714f5570236c86d03773ff881be6e39f"
> +SRC_URI[sha256sum] = "7954a68d0ba23558d753f73437c55f89027cf8f5108c19844d4b82e5af396335"
> +
> +inherit python_setuptools_build_meta ptest
> +
> +DEPENDS += " \
> +    python3-hatch-vcs-native \
> +    python3-setuptools-scm-native \
> +    python3-toml-native \
> +"
> +
> +S = "${WORKDIR}/git"
> +
> +RDEPENDS:${PN}-ptest += " \
> +    ${PYTHON_PN}-appdirs \
> +    ${PYTHON_PN}-pytest \
> +    ${PYTHON_PN}-pytest-mock \
> +"
> +
> +do_install_ptest() {
> +        install -d ${D}${PTEST_PATH}/Tests
> +        cp -rf ${S}/tests ${D}${PTEST_PATH}/
> +}
> +
> +BBCLASSEXTEND = "native"
> --
> 2.40.0
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#102266): https://lists.openembedded.org/g/openembedded-devel/message/102266
> Mute This Topic: https://lists.openembedded.org/mt/98643291/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Khem Raj May 2, 2023, 9:57 p.m. UTC | #2
ah nm, I needed your patches for oe-core as well which upgrades
hatchling to 1.14.x but it still fails to build let me see what could
be going on.

On Tue, May 2, 2023 at 2:46 PM Khem Raj <raj.khem@gmail.com> wrote:
>
> I think it needs python3-hatchling or native variant of this. It fails to build
>
> | ERROR Missing dependencies:
> |       hatchling>=1.14
>
> On Tue, May 2, 2023 at 9:50 AM Trevor Gamblin <tgamblin@baylibre.com> wrote:
> >
> > Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> > ---
> >  .../python/python3-platformdirs/run-ptest     |  3 ++
> >  .../python/python3-platformdirs_3.5.0.bb      | 35 +++++++++++++++++++
> >  2 files changed, 38 insertions(+)
> >  create mode 100644 meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
> >  create mode 100644 meta-python/recipes-devtools/python/python3-platformdirs_3.5.0.bb
> >
> > diff --git a/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest b/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
> > new file mode 100644
> > index 000000000..b63c4de0d
> > --- /dev/null
> > +++ b/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
> > @@ -0,0 +1,3 @@
> > +#!/bin/sh
> > +
> > +pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
> > diff --git a/meta-python/recipes-devtools/python/python3-platformdirs_3.5.0.bb b/meta-python/recipes-devtools/python/python3-platformdirs_3.5.0.bb
> > new file mode 100644
> > index 000000000..b5ff369d0
> > --- /dev/null
> > +++ b/meta-python/recipes-devtools/python/python3-platformdirs_3.5.0.bb
> > @@ -0,0 +1,35 @@
> > +SUMMARY = "A small Python module for determining appropriate platform-specific dirs"
> > +HOMEPAGE = "https://github.com/platformdirs/platformdirs"
> > +LICENSE = "BSD-3-Clause"
> > +LIC_FILES_CHKSUM = "file://LICENSE;md5=ea4f5a41454746a9ed111e3d8723d17a"
> > +
> > +SRC_URI = " \
> > +    git://github.com/platformdirs/platformdirs.git;branch=main;protocol=https \
> > +    file://run-ptest \
> > +"
> > +
> > +SRCREV ?= "dcb56802714f5570236c86d03773ff881be6e39f"
> > +SRC_URI[sha256sum] = "7954a68d0ba23558d753f73437c55f89027cf8f5108c19844d4b82e5af396335"
> > +
> > +inherit python_setuptools_build_meta ptest
> > +
> > +DEPENDS += " \
> > +    python3-hatch-vcs-native \
> > +    python3-setuptools-scm-native \
> > +    python3-toml-native \
> > +"
> > +
> > +S = "${WORKDIR}/git"
> > +
> > +RDEPENDS:${PN}-ptest += " \
> > +    ${PYTHON_PN}-appdirs \
> > +    ${PYTHON_PN}-pytest \
> > +    ${PYTHON_PN}-pytest-mock \
> > +"
> > +
> > +do_install_ptest() {
> > +        install -d ${D}${PTEST_PATH}/Tests
> > +        cp -rf ${S}/tests ${D}${PTEST_PATH}/
> > +}
> > +
> > +BBCLASSEXTEND = "native"
> > --
> > 2.40.0
> >
> >
> > -=-=-=-=-=-=-=-=-=-=-=-
> > Links: You receive all messages sent to this group.
> > View/Reply Online (#102266): https://lists.openembedded.org/g/openembedded-devel/message/102266
> > Mute This Topic: https://lists.openembedded.org/mt/98643291/1997914
> > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> > -=-=-=-=-=-=-=-=-=-=-=-
> >
Khem Raj May 2, 2023, 10 p.m. UTC | #3
nm cleaned tmpdir it builds and runs ok

On Tue, May 2, 2023 at 2:57 PM Khem Raj <raj.khem@gmail.com> wrote:
>
> ah nm, I needed your patches for oe-core as well which upgrades
> hatchling to 1.14.x but it still fails to build let me see what could
> be going on.
>
> On Tue, May 2, 2023 at 2:46 PM Khem Raj <raj.khem@gmail.com> wrote:
> >
> > I think it needs python3-hatchling or native variant of this. It fails to build
> >
> > | ERROR Missing dependencies:
> > |       hatchling>=1.14
> >
> > On Tue, May 2, 2023 at 9:50 AM Trevor Gamblin <tgamblin@baylibre.com> wrote:
> > >
> > > Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> > > ---
> > >  .../python/python3-platformdirs/run-ptest     |  3 ++
> > >  .../python/python3-platformdirs_3.5.0.bb      | 35 +++++++++++++++++++
> > >  2 files changed, 38 insertions(+)
> > >  create mode 100644 meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
> > >  create mode 100644 meta-python/recipes-devtools/python/python3-platformdirs_3.5.0.bb
> > >
> > > diff --git a/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest b/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
> > > new file mode 100644
> > > index 000000000..b63c4de0d
> > > --- /dev/null
> > > +++ b/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
> > > @@ -0,0 +1,3 @@
> > > +#!/bin/sh
> > > +
> > > +pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
> > > diff --git a/meta-python/recipes-devtools/python/python3-platformdirs_3.5.0.bb b/meta-python/recipes-devtools/python/python3-platformdirs_3.5.0.bb
> > > new file mode 100644
> > > index 000000000..b5ff369d0
> > > --- /dev/null
> > > +++ b/meta-python/recipes-devtools/python/python3-platformdirs_3.5.0.bb
> > > @@ -0,0 +1,35 @@
> > > +SUMMARY = "A small Python module for determining appropriate platform-specific dirs"
> > > +HOMEPAGE = "https://github.com/platformdirs/platformdirs"
> > > +LICENSE = "BSD-3-Clause"
> > > +LIC_FILES_CHKSUM = "file://LICENSE;md5=ea4f5a41454746a9ed111e3d8723d17a"
> > > +
> > > +SRC_URI = " \
> > > +    git://github.com/platformdirs/platformdirs.git;branch=main;protocol=https \
> > > +    file://run-ptest \
> > > +"
> > > +
> > > +SRCREV ?= "dcb56802714f5570236c86d03773ff881be6e39f"
> > > +SRC_URI[sha256sum] = "7954a68d0ba23558d753f73437c55f89027cf8f5108c19844d4b82e5af396335"
> > > +
> > > +inherit python_setuptools_build_meta ptest
> > > +
> > > +DEPENDS += " \
> > > +    python3-hatch-vcs-native \
> > > +    python3-setuptools-scm-native \
> > > +    python3-toml-native \
> > > +"
> > > +
> > > +S = "${WORKDIR}/git"
> > > +
> > > +RDEPENDS:${PN}-ptest += " \
> > > +    ${PYTHON_PN}-appdirs \
> > > +    ${PYTHON_PN}-pytest \
> > > +    ${PYTHON_PN}-pytest-mock \
> > > +"
> > > +
> > > +do_install_ptest() {
> > > +        install -d ${D}${PTEST_PATH}/Tests
> > > +        cp -rf ${S}/tests ${D}${PTEST_PATH}/
> > > +}
> > > +
> > > +BBCLASSEXTEND = "native"
> > > --
> > > 2.40.0
> > >
> > >
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > > Links: You receive all messages sent to this group.
> > > View/Reply Online (#102266): https://lists.openembedded.org/g/openembedded-devel/message/102266
> > > Mute This Topic: https://lists.openembedded.org/mt/98643291/1997914
> > > Group Owner: openembedded-devel+owner@lists.openembedded.org
> > > Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> > > -=-=-=-=-=-=-=-=-=-=-=-
> > >
Tim Orling May 3, 2023, 3:08 a.m. UTC | #4
On Tue, May 2, 2023 at 3:01 PM Khem Raj <raj.khem@gmail.com> wrote:

> nm cleaned tmpdir it builds and runs ok
>
> On Tue, May 2, 2023 at 2:57 PM Khem Raj <raj.khem@gmail.com> wrote:
> >
> > ah nm, I needed your patches for oe-core as well which upgrades
> > hatchling to 1.14.x but it still fails to build let me see what could
> > be going on.
> >
> > On Tue, May 2, 2023 at 2:46 PM Khem Raj <raj.khem@gmail.com> wrote:
> > >
> > > I think it needs python3-hatchling or native variant of this. It fails
> to build
> > >
> > > | ERROR Missing dependencies:
> > > |       hatchling>=1.14
> > >
> > > On Tue, May 2, 2023 at 9:50 AM Trevor Gamblin <tgamblin@baylibre.com>
> wrote:
> > > >
> > > > Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
> > > > ---
> > > >  .../python/python3-platformdirs/run-ptest     |  3 ++
> > > >  .../python/python3-platformdirs_3.5.0.bb      | 35
> +++++++++++++++++++
> > > >  2 files changed, 38 insertions(+)
> > > >  create mode 100644
> meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
> > > >  create mode 100644 meta-python/recipes-devtools/python/
> python3-platformdirs_3.5.0.bb
> > > >
> > > > diff --git
> a/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
> b/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
> > > > new file mode 100644
> > > > index 000000000..b63c4de0d
> > > > --- /dev/null
> > > > +++
> b/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
> > > > @@ -0,0 +1,3 @@
> > > > +#!/bin/sh
> > > > +
> > > > +pytest -o log_cli=true -o log_cli_level=INFO | sed -e
> 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e
> 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" ||
> $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk
> '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" ||
> $NF=="XPASS") {$NF="";print $0}else{print}}'
> > > > diff --git a/meta-python/recipes-devtools/python/
> python3-platformdirs_3.5.0.bb b/meta-python/recipes-devtools/python/
> python3-platformdirs_3.5.0.bb
> > > > new file mode 100644
> > > > index 000000000..b5ff369d0
> > > > --- /dev/null
> > > > +++ b/meta-python/recipes-devtools/python/
> python3-platformdirs_3.5.0.bb
> > > > @@ -0,0 +1,35 @@
> > > > +SUMMARY = "A small Python module for determining appropriate
> platform-specific dirs"
> > > > +HOMEPAGE = "https://github.com/platformdirs/platformdirs"
> > > > +LICENSE = "BSD-3-Clause"
> > > > +LIC_FILES_CHKSUM =
> "file://LICENSE;md5=ea4f5a41454746a9ed111e3d8723d17a"
> > > > +
> > > > +SRC_URI = " \
> > > > +    git://
> github.com/platformdirs/platformdirs.git;branch=main;protocol=https \
> > > > +    file://run-ptest \
> > > > +"
> > > > +
> > > > +SRCREV ?= "dcb56802714f5570236c86d03773ff881be6e39f"
> > > > +SRC_URI[sha256sum] =
> "7954a68d0ba23558d753f73437c55f89027cf8f5108c19844d4b82e5af396335"
> > > > +
> > > > +inherit python_setuptools_build_meta ptest


https://github.com/platformdirs/platformdirs/blob/a57f88b67210f26587d06ee77cbd0aea89e45cf9/pyproject.toml#L2

Seems like this should “inherit python_hatchling” instead of
python_setuptools_build_meta
https://git.yoctoproject.org/poky/tree/meta/classes-recipe/python_hatchling.bbclass


> > > > +
> > > > +DEPENDS += " \
> > > > +    python3-hatch-vcs-native \
> > > > +    python3-setuptools-scm-native \
> > > > +    python3-toml-native \
> > > > +"
> > > > +
> > > > +S = "${WORKDIR}/git"
> > > > +
> > > > +RDEPENDS:${PN}-ptest += " \
> > > > +    ${PYTHON_PN}-appdirs \
> > > > +    ${PYTHON_PN}-pytest \
> > > > +    ${PYTHON_PN}-pytest-mock \
> > > > +"
> > > > +
> > > > +do_install_ptest() {
> > > > +        install -d ${D}${PTEST_PATH}/Tests
> > > > +        cp -rf ${S}/tests ${D}${PTEST_PATH}/
> > > > +}
> > > > +
> > > > +BBCLASSEXTEND = "native"
> > > > --
> > > > 2.40.0
> > > >
> > > >
> > > >
> > > >
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#102282):
> https://lists.openembedded.org/g/openembedded-devel/message/102282
> Mute This Topic: https://lists.openembedded.org/mt/98643291/924729
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
> ticotimo@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
>
Trevor Gamblin May 3, 2023, 12:51 p.m. UTC | #5
On Tue, May 2, 2023 at 11:08 PM Tim Orling <ticotimo@gmail.com> wrote:

>
>
> On Tue, May 2, 2023 at 3:01 PM Khem Raj <raj.khem@gmail.com> wrote:
>
>> nm cleaned tmpdir it builds and runs ok
>>
>> On Tue, May 2, 2023 at 2:57 PM Khem Raj <raj.khem@gmail.com> wrote:
>> >
>> > ah nm, I needed your patches for oe-core as well which upgrades
>> > hatchling to 1.14.x but it still fails to build let me see what could
>> > be going on.
>> >
>> > On Tue, May 2, 2023 at 2:46 PM Khem Raj <raj.khem@gmail.com> wrote:
>> > >
>> > > I think it needs python3-hatchling or native variant of this. It
>> fails to build
>> > >
>> > > | ERROR Missing dependencies:
>> > > |       hatchling>=1.14
>> > >
>> > > On Tue, May 2, 2023 at 9:50 AM Trevor Gamblin <tgamblin@baylibre.com>
>> wrote:
>> > > >
>> > > > Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
>> > > > ---
>> > > >  .../python/python3-platformdirs/run-ptest     |  3 ++
>> > > >  .../python/python3-platformdirs_3.5.0.bb      | 35
>> +++++++++++++++++++
>> > > >  2 files changed, 38 insertions(+)
>> > > >  create mode 100644
>> meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
>> > > >  create mode 100644 meta-python/recipes-devtools/python/
>> python3-platformdirs_3.5.0.bb
>> > > >
>> > > > diff --git
>> a/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
>> b/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
>> > > > new file mode 100644
>> > > > index 000000000..b63c4de0d
>> > > > --- /dev/null
>> > > > +++
>> b/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
>> > > > @@ -0,0 +1,3 @@
>> > > > +#!/bin/sh
>> > > > +
>> > > > +pytest -o log_cli=true -o log_cli_level=INFO | sed -e
>> 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e
>> 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" ||
>> $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk
>> '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" ||
>> $NF=="XPASS") {$NF="";print $0}else{print}}'
>> > > > diff --git a/meta-python/recipes-devtools/python/
>> python3-platformdirs_3.5.0.bb b/meta-python/recipes-devtools/python/
>> python3-platformdirs_3.5.0.bb
>> > > > new file mode 100644
>> > > > index 000000000..b5ff369d0
>> > > > --- /dev/null
>> > > > +++ b/meta-python/recipes-devtools/python/
>> python3-platformdirs_3.5.0.bb
>> > > > @@ -0,0 +1,35 @@
>> > > > +SUMMARY = "A small Python module for determining appropriate
>> platform-specific dirs"
>> > > > +HOMEPAGE = "https://github.com/platformdirs/platformdirs"
>> > > > +LICENSE = "BSD-3-Clause"
>> > > > +LIC_FILES_CHKSUM =
>> "file://LICENSE;md5=ea4f5a41454746a9ed111e3d8723d17a"
>> > > > +
>> > > > +SRC_URI = " \
>> > > > +    git://
>> github.com/platformdirs/platformdirs.git;branch=main;protocol=https \
>> > > > +    file://run-ptest \
>> > > > +"
>> > > > +
>> > > > +SRCREV ?= "dcb56802714f5570236c86d03773ff881be6e39f"
>> > > > +SRC_URI[sha256sum] =
>> "7954a68d0ba23558d753f73437c55f89027cf8f5108c19844d4b82e5af396335"
>> > > > +
>> > > > +inherit python_setuptools_build_meta ptest
>
>
>
> https://github.com/platformdirs/platformdirs/blob/a57f88b67210f26587d06ee77cbd0aea89e45cf9/pyproject.toml#L2
>
> Seems like this should “inherit python_hatchling” instead of
> python_setuptools_build_meta
>
> https://git.yoctoproject.org/poky/tree/meta/classes-recipe/python_hatchling.bbclass
>

I've tested it with both now and no difference seems apparent on the build
side. I'll resend with python_hatchling instead of
python_setuptools_build_meta to make sure hatchling is more explicit in the
dependencies.

>
>
>> > > > +
>> > > > +DEPENDS += " \
>> > > > +    python3-hatch-vcs-native \
>> > > > +    python3-setuptools-scm-native \
>> > > > +    python3-toml-native \
>> > > > +"
>> > > > +
>> > > > +S = "${WORKDIR}/git"
>> > > > +
>> > > > +RDEPENDS:${PN}-ptest += " \
>> > > > +    ${PYTHON_PN}-appdirs \
>> > > > +    ${PYTHON_PN}-pytest \
>> > > > +    ${PYTHON_PN}-pytest-mock \
>> > > > +"
>> > > > +
>> > > > +do_install_ptest() {
>> > > > +        install -d ${D}${PTEST_PATH}/Tests
>> > > > +        cp -rf ${S}/tests ${D}${PTEST_PATH}/
>> > > > +}
>> > > > +
>> > > > +BBCLASSEXTEND = "native"
>> > > > --
>> > > > 2.40.0
>> > > >
>> > > >
>> > > >
>> > > >
>>
>> -=-=-=-=-=-=-=-=-=-=-=-
>> Links: You receive all messages sent to this group.
>> View/Reply Online (#102282):
>> https://lists.openembedded.org/g/openembedded-devel/message/102282
>> Mute This Topic: https://lists.openembedded.org/mt/98643291/924729
>> Group Owner: openembedded-devel+owner@lists.openembedded.org
>> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [
>> ticotimo@gmail.com]
>> -=-=-=-=-=-=-=-=-=-=-=-
>>
>>
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest b/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
new file mode 100644
index 000000000..b63c4de0d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-platformdirs/run-ptest
@@ -0,0 +1,3 @@ 
+#!/bin/sh
+
+pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}'
diff --git a/meta-python/recipes-devtools/python/python3-platformdirs_3.5.0.bb b/meta-python/recipes-devtools/python/python3-platformdirs_3.5.0.bb
new file mode 100644
index 000000000..b5ff369d0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-platformdirs_3.5.0.bb
@@ -0,0 +1,35 @@ 
+SUMMARY = "A small Python module for determining appropriate platform-specific dirs"
+HOMEPAGE = "https://github.com/platformdirs/platformdirs"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ea4f5a41454746a9ed111e3d8723d17a"
+
+SRC_URI = " \
+    git://github.com/platformdirs/platformdirs.git;branch=main;protocol=https \
+    file://run-ptest \
+"
+
+SRCREV ?= "dcb56802714f5570236c86d03773ff881be6e39f"
+SRC_URI[sha256sum] = "7954a68d0ba23558d753f73437c55f89027cf8f5108c19844d4b82e5af396335"
+
+inherit python_setuptools_build_meta ptest
+
+DEPENDS += " \
+    python3-hatch-vcs-native \
+    python3-setuptools-scm-native \
+    python3-toml-native \
+"
+
+S = "${WORKDIR}/git"
+
+RDEPENDS:${PN}-ptest += " \
+    ${PYTHON_PN}-appdirs \
+    ${PYTHON_PN}-pytest \
+    ${PYTHON_PN}-pytest-mock \
+"
+
+do_install_ptest() {
+        install -d ${D}${PTEST_PATH}/Tests
+        cp -rf ${S}/tests ${D}${PTEST_PATH}/
+}
+
+BBCLASSEXTEND = "native"