diff mbox series

[meta-python] python3-pillow: add tk to RDEPENDS ptest pkg only if x11 in DISTRO_FEATURES

Message ID 20230206075954.600087-1-geoffhp@gmail.com
State Under Review
Headers show
Series [meta-python] python3-pillow: add tk to RDEPENDS ptest pkg only if x11 in DISTRO_FEATURES | expand

Commit Message

Geoff Parker Feb. 6, 2023, 7:59 a.m. UTC
From: Geoff Parker <geoffrey.parker@arthrex.com>

commit 7b0e71e00 ("python3-pillow: add ptest support", 2023-01-31)
added tk to RDEPENDS:${PN}-ptest. Which cause this error on non x11
builds:

    ERROR: Nothing RPROVIDES 'tk' (but meta-openembedded/meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb
           RDEPENDS on or otherwise requires it) tk was skipped: missing required
           distro feature 'x11' (not in DISTRO_FEATURES)
    NOTE: Runtime target 'tk' is unbuildable, removing...
          Missing or unbuildable dependency chain was: ['tk']
    NOTE: Runtime target 'iotmanager' is unbuildable, removing...
          Missing or unbuildable dependency chain was: ['iotmanager', 'python3-pillow', 'tk']
    ERROR: Required build target 'update-runtime' has no buildable providers.
           Missing or unbuildable dependency chain was:
           ['update-runtime', 'runtime-image', 'iotmanager', 'python3-pillow', 'tk']

Add tk dependency only if DISTRO_FEATURES includes x11

Signed-off-by: Geoff Parker <geoffrey.parker@arthrex.com>
---
 meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb b/meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb
index 68c81029c..9f1cc9eac 100644
--- a/meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pillow_9.4.0.bb
@@ -43,7 +43,7 @@  RDEPENDS:${PN}-ptest += " \
     ${PYTHON_PN}-pytest \
     ${PYTHON_PN}-pytest-timeout \
     ${PYTHON_PN}-resource \
-    tk \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'tk', '', d)} \
 "
 
 CVE_PRODUCT = "pillow"