diff mbox series

[meta-python,09/10] python3-pybind11: Upgrade to 2.10.3

Message ID 20230127055440.2108933-9-raj.khem@gmail.com
State New
Headers show
Series [meta-oe,01/10] poco: Do not use std::atomic<bool> | expand

Commit Message

Khem Raj Jan. 27, 2023, 5:54 a.m. UTC
It gets pkgconfig support which is required by some dependent packages
like rwmem

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 ...11_2.10.0.bb => python3-pybind11_2.10.3.bb} | 18 +++++++-----------
 1 file changed, 7 insertions(+), 11 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-pybind11_2.10.0.bb => python3-pybind11_2.10.3.bb} (68%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-pybind11_2.10.0.bb b/meta-python/recipes-devtools/python/python3-pybind11_2.10.3.bb
similarity index 68%
rename from meta-python/recipes-devtools/python/python3-pybind11_2.10.0.bb
rename to meta-python/recipes-devtools/python/python3-pybind11_2.10.3.bb
index 66aefac3d6..bb604982d0 100644
--- a/meta-python/recipes-devtools/python/python3-pybind11_2.10.0.bb
+++ b/meta-python/recipes-devtools/python/python3-pybind11_2.10.3.bb
@@ -5,16 +5,12 @@  LIC_FILES_CHKSUM = "file://LICENSE;md5=774f65abd8a7fe3124be2cdf766cd06f"
 
 DEPENDS = "boost"
 
-SRC_URI = "git://github.com/pybind/pybind11.git;branch=stable;protocol=https \
-           file://0001-Do-not-strip-binaries.patch \
-"
+SRC_URI = "git://github.com/pybind/pybind11.git;branch=stable;protocol=https"
 
-SRCREV = "aa304c9c7d725ffb9d10af08a3b34cb372307020"
+SRCREV = "0bd8896a4010f2d91b2340570c24fa08606ec406"
 
 S = "${WORKDIR}/git"
 
-BBCLASSEXTEND = "native"
-
 EXTRA_OECMAKE =  "-DPYBIND11_TEST=OFF"
 
 inherit cmake setuptools3 python3native
@@ -23,17 +19,17 @@  PIP_INSTALL_DIST_PATH = "${S}/dist"
 PIP_INSTALL_PACKAGE = "pybind11"
 
 do_configure() {
-	cmake_do_configure
+   cmake_do_configure
 }
 
 do_compile() {
-	setuptools3_do_compile
-	cmake_do_compile
+   setuptools3_do_compile
+   cmake_do_compile
 }
 
 do_install() {
-	setuptools3_do_install
-	cmake_do_install
+   setuptools3_do_install
+   cmake_do_install
 }
 
 BBCLASSEXTEND = "native nativesdk"