diff mbox series

[meta-oe] Fix missing leading whitespace with ':append'

Message ID 20230124120813.3888580-1-niko.mauno@vaisala.com
State Under Review
Headers show
Series [meta-oe] Fix missing leading whitespace with ':append' | expand

Commit Message

Niko Mauno Jan. 24, 2023, 12:08 p.m. UTC
Mitigate occurences where ':append' operator is used and leading
whitespace character is obviously missing, risking inadvertent
string concatenation.

Signed-off-by: Niko Mauno <niko.mauno@vaisala.com>
---
 meta-oe/recipes-core/dbus-cxx/dbus-cxx_2.1.0.bb             | 2 +-
 meta-oe/recipes-crypto/fsverity-utils/fsverity-utils_1.5.bb | 2 +-
 meta-oe/recipes-support/neon/neon_0.32.4.bb                 | 2 +-
 3 files changed, 3 insertions(+), 3 deletions(-)
diff mbox series

Patch

diff --git a/meta-oe/recipes-core/dbus-cxx/dbus-cxx_2.1.0.bb b/meta-oe/recipes-core/dbus-cxx/dbus-cxx_2.1.0.bb
index c8dabc5ea..44804545d 100644
--- a/meta-oe/recipes-core/dbus-cxx/dbus-cxx_2.1.0.bb
+++ b/meta-oe/recipes-core/dbus-cxx/dbus-cxx_2.1.0.bb
@@ -9,7 +9,7 @@  SRC_URI = "git://github.com/dbus-cxx/dbus-cxx.git;branch=master;protocol=https \
            file://0001-Include-typeinfo-for-typeid.patch \
            file://0001-include-utility-header.patch \
 "
-SRC_URI:append:libc-musl = "file://fix_build_musl.patch"
+SRC_URI:append:libc-musl = " file://fix_build_musl.patch"
 SRCREV = "73532d6a5faae9c721c2cc9535b8ef32d4d18264"
 
 DEPENDS = "\
diff --git a/meta-oe/recipes-crypto/fsverity-utils/fsverity-utils_1.5.bb b/meta-oe/recipes-crypto/fsverity-utils/fsverity-utils_1.5.bb
index c95a5b2d3..1c2c6e21e 100644
--- a/meta-oe/recipes-crypto/fsverity-utils/fsverity-utils_1.5.bb
+++ b/meta-oe/recipes-crypto/fsverity-utils/fsverity-utils_1.5.bb
@@ -16,7 +16,7 @@  S = "${WORKDIR}/git"
 
 DEPENDS = "openssl"
 
-EXTRA_OEMAKE:append = "PREFIX=${prefix} LIBDIR=${libdir} USE_SHARED_LIB=1"
+EXTRA_OEMAKE:append = " PREFIX=${prefix} LIBDIR=${libdir} USE_SHARED_LIB=1"
 # We want to statically link the binary to libfsverity on native Windows
 EXTRA_OEMAKE:remove:mingw32:class-nativesdk = "USE_SHARED_LIB=1"
 EXTRA_OEMAKE:remove:mingw32:class-native = "USE_SHARED_LIB=1"
diff --git a/meta-oe/recipes-support/neon/neon_0.32.4.bb b/meta-oe/recipes-support/neon/neon_0.32.4.bb
index c16a2c10a..d281bfde6 100644
--- a/meta-oe/recipes-support/neon/neon_0.32.4.bb
+++ b/meta-oe/recipes-support/neon/neon_0.32.4.bb
@@ -33,7 +33,7 @@  PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib"
 EXTRA_OECONF += "--enable-shared --enable-threadsafe-ssl=posix"
 
 # Do not install into /usr/local
-EXTRA_OEMAKE:append:class-native = "prefix=${prefix_native}"
+EXTRA_OEMAKE:append:class-native = " prefix=${prefix_native}"
 
 do_configure:prepend() {
     echo "${PV}" > ${S}/.version