diff mbox series

[meta-python,6/7] python3-matplotlib: Upgrade to 3.6.3

Message ID 20230117052237.3117521-6-raj.khem@gmail.com
State New
Headers show
Series [meta-networking,1/7] libtevent: Package cmocka tests into ptest package | expand

Commit Message

Khem Raj Jan. 17, 2023, 5:22 a.m. UTC
Forward port the disable download patch
Location of license changed inside setup.py

Signed-off-by: Khem Raj <raj.khem@gmail.com>
---
 .../matplotlib-disable-download.patch         | 26 ++++++++++++++-----
 ...b_3.5.3.bb => python3-matplotlib_3.6.3.bb} |  4 +--
 2 files changed, 22 insertions(+), 8 deletions(-)
 rename meta-python/recipes-devtools/python/{python3-matplotlib_3.5.3.bb => python3-matplotlib_3.6.3.bb} (93%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch b/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
index 25c49afb97..899cac624a 100644
--- a/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
+++ b/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
@@ -6,18 +6,32 @@  Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
 
 --- a/setup.py
 +++ b/setup.py
-@@ -316,8 +316,6 @@ setup(  # Finally, pass this all along t
+@@ -303,7 +303,6 @@ setup(  # Finally, pass this all along t
      setup_requires=[
          "certifi>=2020.06.20",
-         "numpy>=1.17",
--        "setuptools_scm>=4,<7",
--        "setuptools_scm_git_archive",
+         "numpy>=1.19",
+-        "setuptools_scm>=7",
      ],
      install_requires=[
-         "cycler>=0.10",
+         "contourpy>=1.0.1",
+@@ -315,13 +314,7 @@ setup(  # Finally, pass this all along t
+         "pillow>=6.2.0",
+         "pyparsing>=2.2.1",
+         "python-dateutil>=2.7",
+-    ] + (
+-        # Installing from a git checkout that is not producing a wheel.
+-        ["setuptools_scm>=7"] if (
+-            Path(__file__).with_name(".git").exists() and
+-            os.environ.get("CIBUILDWHEEL", "0") != "1"
+-        ) else []
+-    ),
++    ],
+     use_scm_version={
+         "version_scheme": "release-branch-semver",
+         "local_scheme": "node-and-date",
 --- a/setupext.py
 +++ b/setupext.py
-@@ -64,40 +64,7 @@ def get_from_cache_or_download(url, sha)
+@@ -65,40 +65,7 @@ def get_from_cache_or_download(url, sha)
      BytesIO
          The file loaded into memory.
      """
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib_3.5.3.bb b/meta-python/recipes-devtools/python/python3-matplotlib_3.6.3.bb
similarity index 93%
rename from meta-python/recipes-devtools/python/python3-matplotlib_3.5.3.bb
rename to meta-python/recipes-devtools/python/python3-matplotlib_3.6.3.bb
index 1a0b93b030..809f9425ba 100644
--- a/meta-python/recipes-devtools/python/python3-matplotlib_3.5.3.bb
+++ b/meta-python/recipes-devtools/python/python3-matplotlib_3.6.3.bb
@@ -7,7 +7,7 @@  HOMEPAGE = "https://github.com/matplotlib/matplotlib"
 SECTION = "devel/python"
 LICENSE = "PSF-2.0"
 LIC_FILES_CHKSUM = "\
-    file://setup.py;beginline=296;endline=296;md5=20e7ab4d2b2b1395a0e4ab800181eb96 \
+    file://setup.py;beginline=283;endline=283;md5=20e7ab4d2b2b1395a0e4ab800181eb96 \
     file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \
 "
 
@@ -21,7 +21,7 @@  DEPENDS = "\
     python3-certifi-native \
     python3-setuptools-scm-native \
 "
-SRC_URI[sha256sum] = "339cac48b80ddbc8bfd05daae0a3a73414651a8596904c2a881cfd1edb65f26c"
+SRC_URI[sha256sum] = "1f4d69707b1677560cd952544ee4962f68ff07952fb9069ff8c12b56353cb8c9"
 
 inherit pypi setuptools3 pkgconfig