diff mbox series

[meta-python,2/3] python3-prompt-toolkit: Upgrade 3.0.31 -> 3.0.36

Message ID 20230104100016.268755-2-leon.anavi@konsulko.com
State Under Review
Headers show
Series [meta-python,1/3] python3-coverage: Upgrade 7.0.1 -> 7.0.3 | expand

Commit Message

Leon Anavi Jan. 4, 2023, 10 a.m. UTC
Upgrade to release 3.0.36:

- Another Python 3.6 fix for a bug that was introduced in 3.0.34.
- Fix bug introduced in 3.0.34 for Python 3.6. Use
  asynccontextmanager implementation from prompt_toolkit itself.
- Improve completion performance in various places.
- Improve renderer performance.
- Handle `KeyboardInterrupt` when the stacktrace of an unhandled
  error is displayed.
- Use correct event loop in `Application.create_background_task()`.
- Fix `show_cursor` attribute in `ScrollablePane`.
- Improve termination of `Application`. Don't suppress
  `CancelledError`. This fixes a race condition when an
  `Application` gets cancelled while we're waiting for the
  background tasks to complete.
- Fixed typehint for `OneStyleAndTextTuple`.
- Small bugfix in `CombinedRegistry`. Fixed missing `@property`.
- Use `DummyInput` by default in `create_input()` if `sys.stdin`
  does not have a valid file descriptor. This fixes errors when
  `sys.stdin` is patched in certain situations.
- Fix control-c key binding for `ProgressBar` when the progress
  bar was not created from the main thread. The current code would
  try to kill the main thread when control-c was pressed.
- Accept a `cancel_callback` in `ProgressBar` to specify the
  cancellation behavior for when `control-c` is pressed.
- Small performance improvement in the renderer.

Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
---
 ...rompt-toolkit_3.0.31.bb => python3-prompt-toolkit_3.0.36.bb} | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)
 rename meta-python/recipes-devtools/python/{python3-prompt-toolkit_3.0.31.bb => python3-prompt-toolkit_3.0.36.bb} (87%)
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.31.bb b/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.36.bb
similarity index 87%
rename from meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.31.bb
rename to meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.36.bb
index 0b8962ded..a5299318b 100644
--- a/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.31.bb
+++ b/meta-python/recipes-devtools/python/python3-prompt-toolkit_3.0.36.bb
@@ -3,7 +3,7 @@  HOMEPAGE = "https://python-prompt-toolkit.readthedocs.io/"
 LICENSE = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=b2cde7da89f0c1f3e49bf968d00d554f"
 
-SRC_URI[sha256sum] = "9ada952c9d1787f52ff6d5f3484d0b4df8952787c087edf6a1f7c2cb1ea88148"
+SRC_URI[sha256sum] = "3e163f254bef5a03b146397d7c1963bd3e2812f0964bb9a24e6ec761fd28db63"
 
 inherit pypi setuptools3