diff mbox series

[meta-python,V3,1/2] python3-binwalk: add recipe for version 2.3.3

Message ID 20221201083456.1573628-1-tomasz.zyjewski@3mdeb.com
State New
Headers show
Series [meta-python,V3,1/2] python3-binwalk: add recipe for version 2.3.3 | expand

Commit Message

Tomasz Żyjewski Dec. 1, 2022, 8:34 a.m. UTC
Install binwalk utility.

Binwalk is a fast, easy to use tool for analyzing, reverse engineering,
and extracting firmware images.

Signed-off-by: Tomasz Żyjewski <tomasz.zyjewski@3mdeb.com>
---
 .../python/python3-binwalk_2.3.3.bb             | 17 +++++++++++++++++
 1 file changed, 17 insertions(+)
 create mode 100644 meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb

Comments

Khem Raj Dec. 1, 2022, 6:42 p.m. UTC | #1
Can you rebase these patches on top of master or master-next and
resend v3 please ?

On Thu, Dec 1, 2022 at 12:35 AM tomzy <tomasz.zyjewski@3mdeb.com> wrote:
>
> Install binwalk utility.
>
> Binwalk is a fast, easy to use tool for analyzing, reverse engineering,
> and extracting firmware images.
>
> Signed-off-by: Tomasz Żyjewski <tomasz.zyjewski@3mdeb.com>
> ---
>  .../python/python3-binwalk_2.3.3.bb             | 17 +++++++++++++++++
>  1 file changed, 17 insertions(+)
>  create mode 100644 meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
>
> diff --git a/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb b/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
> new file mode 100644
> index 000000000000..362efa275148
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
> @@ -0,0 +1,17 @@
> +SUMMARY = "Firmware analysis tool"
> +DESCRIPTION = "This package contains Python Binwalk tool. Binwalk is a fast, \
> +easy to use tool for analyzing, reverse engineering, and extracting firmware \
> +images."
> +HOMEPAGE = "https://github.com/ReFirmLabs/binwalk"
> +LICENSE = "MIT"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=65bbee055d3ea3bfc475f07aecf4de64"
> +
> +SRC_URI = "git://github.com/ReFirmLabs/binwalk;protocol=https;branch=master"
> +
> +SRCREV = "fa0c0bd59b8588814756942fe4cb5452e76c1dcd"
> +
> +S = "${WORKDIR}/git"
> +
> +inherit setuptools3
> +
> +RDEPENDS:${PN} += "python3-core"
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#99882): https://lists.openembedded.org/g/openembedded-devel/message/99882
> Mute This Topic: https://lists.openembedded.org/mt/95377962/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Tomasz Żyjewski Dec. 2, 2022, 6:48 a.m. UTC | #2
On Thu, Dec 1, 2022 at 07:43 PM, Khem Raj wrote:

> 
> Can you rebase these patches on top of master or master-next and
> resend v3 please ?

I can but isn't it already merged in master?

https://git.openembedded.org/meta-openembedded/commit/?id=7ea0e04aaee19f61e18bf998bb07f02e52d8146e

> 
> On Thu, Dec 1, 2022 at 12:35 AM tomzy <tomasz.zyjewski@3mdeb.com> wrote:
> 
>> Install binwalk utility.
>> 
>> Binwalk is a fast, easy to use tool for analyzing, reverse engineering,
>> and extracting firmware images.
>> 
>> Signed-off-by: Tomasz Żyjewski <tomasz.zyjewski@3mdeb.com>
>> ---
>> .../python/python3-binwalk_2.3.3.bb | 17 +++++++++++++++++
>> 1 file changed, 17 insertions(+)
>> create mode 100644
>> meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
>> 
>> diff --git a/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
>> b/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
>> new file mode 100644
>> index 000000000000..362efa275148
>> --- /dev/null
>> +++ b/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
>> @@ -0,0 +1,17 @@
>> +SUMMARY = "Firmware analysis tool"
>> +DESCRIPTION = "This package contains Python Binwalk tool. Binwalk is a
>> fast, \
>> +easy to use tool for analyzing, reverse engineering, and extracting
>> firmware \
>> +images."
>> +HOMEPAGE = " https://github.com/ReFirmLabs/binwalk"
>> +LICENSE = "MIT"
>> +LIC_FILES_CHKSUM = "file://LICENSE;md5=65bbee055d3ea3bfc475f07aecf4de64"
>> +
>> +SRC_URI =
>> "git://github.com/ReFirmLabs/binwalk;protocol=https;branch=master"
>> +
>> +SRCREV = "fa0c0bd59b8588814756942fe4cb5452e76c1dcd"
>> +
>> +S = "${WORKDIR}/git"
>> +
>> +inherit setuptools3
>> +
>> +RDEPENDS:${PN} += "python3-core"
>> --
>> 2.25.1
>> 
>> 
> 
>
Khem Raj Dec. 2, 2022, 4:50 p.m. UTC | #3
On Thu, Dec 1, 2022 at 10:49 PM tomzy <tomasz.zyjewski@3mdeb.com> wrote:
>
> On Thu, Dec 1, 2022 at 07:43 PM, Khem Raj wrote:
>
> Can you rebase these patches on top of master or master-next and
> resend v3 please ?
>
> I can but isn't it already merged in master?
>
> https://git.openembedded.org/meta-openembedded/commit/?id=7ea0e04aaee19f61e18bf998bb07f02e52d8146e
>

It is, thats why I am asking for an incremental patch on top of what is merged.

> On Thu, Dec 1, 2022 at 12:35 AM tomzy <tomasz.zyjewski@3mdeb.com> wrote:
>
> Install binwalk utility.
>
> Binwalk is a fast, easy to use tool for analyzing, reverse engineering,
> and extracting firmware images.
>
> Signed-off-by: Tomasz Żyjewski <tomasz.zyjewski@3mdeb.com>
> ---
> .../python/python3-binwalk_2.3.3.bb | 17 +++++++++++++++++
> 1 file changed, 17 insertions(+)
> create mode 100644 meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
>
> diff --git a/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb b/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
> new file mode 100644
> index 000000000000..362efa275148
> --- /dev/null
> +++ b/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
> @@ -0,0 +1,17 @@
> +SUMMARY = "Firmware analysis tool"
> +DESCRIPTION = "This package contains Python Binwalk tool. Binwalk is a fast, \
> +easy to use tool for analyzing, reverse engineering, and extracting firmware \
> +images."
> +HOMEPAGE = "https://github.com/ReFirmLabs/binwalk"
> +LICENSE = "MIT"
> +LIC_FILES_CHKSUM = "file://LICENSE;md5=65bbee055d3ea3bfc475f07aecf4de64"
> +
> +SRC_URI = "git://github.com/ReFirmLabs/binwalk;protocol=https;branch=master"
> +
> +SRCREV = "fa0c0bd59b8588814756942fe4cb5452e76c1dcd"
> +
> +S = "${WORKDIR}/git"
> +
> +inherit setuptools3
> +
> +RDEPENDS:${PN} += "python3-core"
> --
> 2.25.1
>
>
> -=-=-=-=-=-=-=-=-=-=-=-
> Links: You receive all messages sent to this group.
> View/Reply Online (#99908): https://lists.openembedded.org/g/openembedded-devel/message/99908
> Mute This Topic: https://lists.openembedded.org/mt/95377962/1997914
> Group Owner: openembedded-devel+owner@lists.openembedded.org
> Unsubscribe: https://lists.openembedded.org/g/openembedded-devel/unsub [raj.khem@gmail.com]
> -=-=-=-=-=-=-=-=-=-=-=-
>
Tomasz Żyjewski Dec. 5, 2022, 8:46 a.m. UTC | #4
On Fri, Dec 2, 2022 at 05:50 PM, Khem Raj wrote:

> 
> On Thu, Dec 1, 2022 at 10:49 PM tomzy <tomasz.zyjewski@3mdeb.com> wrote:
> 
>> On Thu, Dec 1, 2022 at 07:43 PM, Khem Raj wrote:
>> 
>> Can you rebase these patches on top of master or master-next and
>> resend v3 please ?
>> 
>> I can but isn't it already merged in master?
>> 
>> https://git.openembedded.org/meta-openembedded/commit/?id=7ea0e04aaee19f61e18bf998bb07f02e52d8146e
>> 
> 
> It is, thats why I am asking for an incremental patch on top of what is
> merged.

Hi, sorry I am not sure what you mean here. Did you want me to rebase the second change and resend as V3?

Something like this? https://lists.openembedded.org/g/openembedded-devel/message/99950

> 
> 
> 
>> On Thu, Dec 1, 2022 at 12:35 AM tomzy <tomasz.zyjewski@3mdeb.com> wrote:
>> 
>> Install binwalk utility.
>> 
>> Binwalk is a fast, easy to use tool for analyzing, reverse engineering,
>> and extracting firmware images.
>> 
>> Signed-off-by: Tomasz Żyjewski <tomasz.zyjewski@3mdeb.com>
>> ---
>> .../python/python3-binwalk_2.3.3.bb | 17 +++++++++++++++++
>> 1 file changed, 17 insertions(+)
>> create mode 100644
>> meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
>> 
>> diff --git a/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
>> b/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
>> new file mode 100644
>> index 000000000000..362efa275148
>> --- /dev/null
>> +++ b/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
>> @@ -0,0 +1,17 @@
>> +SUMMARY = "Firmware analysis tool"
>> +DESCRIPTION = "This package contains Python Binwalk tool. Binwalk is a
>> fast, \
>> +easy to use tool for analyzing, reverse engineering, and extracting
>> firmware \
>> +images."
>> +HOMEPAGE = " https://github.com/ReFirmLabs/binwalk"
>> +LICENSE = "MIT"
>> +LIC_FILES_CHKSUM = "file://LICENSE;md5=65bbee055d3ea3bfc475f07aecf4de64"
>> +
>> +SRC_URI =
>> "git://github.com/ReFirmLabs/binwalk;protocol=https;branch=master"
>> +
>> +SRCREV = "fa0c0bd59b8588814756942fe4cb5452e76c1dcd"
>> +
>> +S = "${WORKDIR}/git"
>> +
>> +inherit setuptools3
>> +
>> +RDEPENDS:${PN} += "python3-core"
>> --
>> 2.25.1
>> 
>> 
>> 
> 
>
diff mbox series

Patch

diff --git a/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb b/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
new file mode 100644
index 000000000000..362efa275148
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-binwalk_2.3.3.bb
@@ -0,0 +1,17 @@ 
+SUMMARY = "Firmware analysis tool"
+DESCRIPTION = "This package contains Python Binwalk tool. Binwalk is a fast, \
+easy to use tool for analyzing, reverse engineering, and extracting firmware \
+images."
+HOMEPAGE = "https://github.com/ReFirmLabs/binwalk"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=65bbee055d3ea3bfc475f07aecf4de64"
+
+SRC_URI = "git://github.com/ReFirmLabs/binwalk;protocol=https;branch=master"
+
+SRCREV = "fa0c0bd59b8588814756942fe4cb5452e76c1dcd"
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3
+
+RDEPENDS:${PN} += "python3-core"